Bug 7194 - Browser randomly crashes
: Browser randomly crashes
Status: RESOLVED INVALID
Product: Browser
MicroB engine
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low major (vote)
: ---
Assigned To: unassigned
: microb-bugs
:
: crash, moreinfo
:
:
  Show dependency tree
 
Reported: 2009-12-21 19:30 UTC by EC
Modified: 2010-01-11 16:02 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description EC (reporter) 2009-12-21 19:30:06 UTC
EXACT STEPS LEADING TO PROBLEM: 
1. Open some web pages with the N900 browser (at least two)

EXPECTED OUTCOME: the N900 shows a page and keeps the other one in the
background

ACTUAL OUTCOME: the Web application crashes with the message: "Internal
application error. 'Web' closed."

REPRODUCIBILITY: 3/5

OTHER COMMENTS: I just don't know what I could add to this description. My
browser simply crashes, and this happens quite often when I have many pages in
the background!
Comment 1 EC (reporter) 2009-12-21 19:31:09 UTC
 I'm sorry i cannot be helpful with this bug because i'm not an expert, I would
be grateful if you could tell me what else can I do! This is my first bug
report, sorry if I've made some errors!
Comment 2 Andre Klapper maemo.org 2009-12-21 23:27:51 UTC
Thanks for reporting this.

So this is not specific to the web pages themselves, but happens with any
webpages?
Does this also happen when no other applications are running?

Could you install "Crash Reporter" from the SDK Tools repository (see
http://wiki.maemo.org/Documentation/devtools/maemo5 ) and send core dumps of
these crashes directly to Nokia for analysis?
Comment 3 EC (reporter) 2009-12-21 23:47:47 UTC
It seems to happen with every web page, but I can't be sure: I'll pay more
attention next time. I'm going to install that tool and send those core dumps
tomorrow, thanks for pointing me there.
Comment 4 EC (reporter) 2009-12-22 10:39:01 UTC
I had just installed the Crash Reporter using that repository, and while I was
surfing the web I managed to reproduce the crash I'm reporting. By the way, how
does Crash Reporter works? When Web crashed, nothing happened! I was expecting
some pop-ups or a sending request... 
However, crashes seem to be related to the uploading of a comment in Maemo.org,
these are the steps i used:
-With some pages on the background, open the browser and load Maemo.org
-Login with your username and password
-Go to the Download section and comment an application
-While the uploading of the comment is in progress, open another page from the
background or another app.
-After a while, Web crashes.

I'd like to precise that actually crashes happen not just with Maemo.org, but I
can reproduce them with more probability with this site.
I always use a wireless connection and yes, it happens even when no other app
is running.
Comment 5 EC (reporter) 2009-12-22 11:07:34 UTC
Ok I can definetely reproduce it as many times as I want, and this is quite
annoying for me... I've just found that the uploading of a comment in Maemo.org
with any other page in the background and the updating of the application
catalogues in the Application Manager at the same time leads to a crash of the
web app with a 100% probability. Let me precise that it also happens in many
different cases I can't actually reproduce!
And I still can't understand how the Crash Reporter works, I'm going to Google
it.
Comment 6 EC (reporter) 2009-12-24 17:00:59 UTC
The browser still crashes and I haven't found how crash reporter works yet. It
creates a core dump everytime the web app crashes, in MyDocs/core dumps, should
I send them manually? And what email should i write to? I'd attach them to this
bug report if there were not some personal information inside them...
Comment 7 EC (reporter) 2009-12-24 23:32:29 UTC
Ok I've finally found the setting menu of Crash Reporter... :P It should be
explained better. However, I've just sent 2 core dumps to Nokia for analysis,
is there anything else I can do now?
Comment 8 EC (reporter) 2010-01-02 20:45:45 UTC
I have to change the summary of this bug because the browser crashes even with
one page opened, but I have no idea of what should I write instead. If you have
any suggestions, please leave a comment. By the way, I've been sending tons of
core dumps to Nokia for analysis for ages, hope it will help... :S
Comment 9 timeless 2010-01-03 05:30:47 UTC
you should be able to include a comment, please include this bug's number when
you send comments....
Comment 10 EC (reporter) 2010-01-03 13:17:27 UTC
(In reply to comment #9)
> you should be able to include a comment, please include this bug's number when
> you send comments....
> 

I'm not sure of what you're talking about... You mean I have to write the bug's
number every comment I post? What's the reason? Please be patient I'm just a
novice
Comment 11 timeless 2010-01-03 13:25:18 UTC
when something crashes, the crash reporter should ask you to enter some text
describing what was happening. if you include this bug's number in that field,
it'll make it much easier for us to find your report.
Comment 12 EC (reporter) 2010-01-03 13:36:32 UTC
You have just helped me a lot, thanks for the hint.
Comment 13 Andre Klapper maemo.org 2010-01-11 16:02:39 UTC
------- Comment #13 from timeless  2010-01-09 20:38 GMT+3 -------
But because I need to figure out who is doing what how, I'm going to comment
here as I kill this bug.

Bugzilla needs to focus on tracking actual bugs. An actual bug is not an
amorphous bug. An amorphous bug is any bug for which any random person
experiencing totally unrelated circumstances can say "yes, that's my bug".

If people have crashes, they need to submit crash reports using crash-reporter.
If they have steps to reproduce they should:

1. trigger crash reporter the first time and explain what they were doing (the
explanation here will be rather vague).
2. trigger crash reporter the second time (the explanation here should be much
less vague)
3. file a bug including the explanation from 2.
4. trigger crash reporter a third time (including the bug number from 3 in the
crash report)
5. comment in the bug indicating that they've sent the crash report at 4 with
the bug number referenced.
6. wait patiently for someone from nokia to retrieve their crash report and
provide something into the bug indicating that they've retrieved it.

If you encounter multiple crashes within a short interval, and you believe
they're from the same root cause, please continue to use the same bug number in
your crash report comments. And please feel free to include additional
*clarifying* steps in your bug to help people reproduce your *specific*
problem.

If your problem is not specific or you can not come up with any remotely useful
steps -- this can be seen in the form of:
> OTHER COMMENTS:
> I just don't know what I could add to this description.
> My browser simply crashes,

Then instead of a bug number, include your email address in your crash-reporter
comments.

We do analyze crash reports statistically. If a problem turns up with higher
frequency, it's more likely that an engineer will look at it and get around to
fixing it.

BTW if you think that this is not the way things should work, or is not the way
that things work elsewhere, please take a moment to look at
http://bugzilla.mozilla.org/ and http://crash-stats.mozilla.com/
as what I'm describing is precisely the way the Mozilla project works, and
they're considerably larger and much more established. And I've been working
with them for 10 years.

No bug tracker can survive under the weight of a couple of 'me too' lightning
rod tracking reports. No work can possibly be done to resolve the underlying
problems - as nothing can be understood when there are many unrelated
underlying causes. Browser software is very big and complicated and there will
always be crashes. Browser developers are aware that this is an inconvenience
to customers using their software.