Bug 7178 - Map should have button "track me" available for regular location
: Map should have button "track me" available for regular location
Status: RESOLVED FIXED
Product: Map
General
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low enhancement with 5 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: map-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-21 08:51 UTC by egoshin
Modified: 2010-01-21 20:19 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description egoshin (reporter) 2009-12-21 08:51:09 UTC
Map should have button "track me" available for regular usage. Today it is
available for "route" mode. It is very difficult to pay a constant attention to
red oval position without "track me" option.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.8)
Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2009-12-21 15:05:55 UTC
Thanks for reporting this. (Please never set Priority to High.)
This bug report isn't very useful because it doesn't describe the bug well. If
you have time and can still reproduce the bug, please read
https://bugs.maemo.org/page.cgi?id=bug-writing.html and add a more useful
description to this bug by actually using the template:


SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. 
2. 
3. 

EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Comment 2 egoshin (reporter) 2009-12-21 23:26:10 UTC
(In reply to comment #1)
> Thanks for reporting this. (Please never set Priority to High.)
> This bug report isn't very useful because it doesn't describe the bug well. If
> you have time and can still reproduce the bug, please read
> https://bugs.maemo.org/page.cgi?id=bug-writing.html and add a more useful
> description to this bug by actually using the template:
> 
> 
> SOFTWARE VERSION:
> (Settings > General > About product)
> 
> EXACT STEPS LEADING TO PROBLEM: 
> (Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
> Connection Failed appears))

1. launch a "maps" application, wait until it starts
2. search the "track me" button

> EXPECTED OUTCOME:

Have a "track me" button like there is one in "Routing" application

> 
> ACTUAL OUTCOME:

There is no "track me" button.

> REPRODUCIBILITY:
> (always, less than 1/10, 5/10, 9/10)

Always.

> EXTRA SOFTWARE INSTALLED:

Many but nothing in map or GPS area.

> 
> OTHER COMMENTS:
> 

Actually, there is "track me" button in "routing" mode. The exact sequence of
using it is here:

1. launch a "maps" application, wait until it starts
2. press right top corner button
3. after 3 choice screen shows - press ""Routing", wait until it starts
4. Press "add destination"
5. after choice of 3 shows up - select ""get from search"
6. after search window shows - enter some remote address (in my case - 200km
away)
7. Select address after search find it in RIGHT side ("plus" sign)
6. wait until it "route calculation" finishes
7. Now you have a screen map and down in center you see a white rectangular
labeled "track me". Press it.

This button forces maps application shift map in accordance with you movements
and put the current position (red oval) in the center of screen. 

Without this button ("track me") the map is impractical in car navigation until
you know an exact destination address and use "Routing" feature. You have no
time to periodically press the red button to force moving map to your current
location to look it - usually you have only 1.5 second to get look out of
windshield or take a serious crash risk. 

ANY GPS DEVICE (including Google map) has this tracking feature.
Comment 3 totalworlddomination 2009-12-22 20:45:12 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Olli Nevalainen 2010-01-15 08:45:42 UTC
I think this bug has been fixed as a part of PR1.1 update, and should therefore
be closed as fixed.
Comment 5 Andre Klapper maemo.org 2010-01-15 14:03:47 UTC
Closing as per last comment.
Comment 6 egoshin (reporter) 2010-01-21 20:19:50 UTC
Yes, the problem is fixed by new map software.