Bug 7174 - specifying "DejaVu Sans Mono","Courier New",monospace,Freemono fonts break pre
: specifying "DejaVu Sans Mono","Courier New",monospace,Freemono fonts break pre
Status: RESOLVED FIXED
Product: Browser
MicroB engine
: 5.0/(2.2009.51-1)
: ARM Maemo
: Medium major (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: microb-bugs
: data:text/html;charset=utf-8,%3Cstyle...
:
:
:
  Show dependency tree
 
Reported: 2009-12-21 02:22 UTC by bugzilla
Modified: 2010-03-15 20:51 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description bugzilla (reporter) 2009-12-21 02:22:20 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Visit a site like nfomation.net or any other site that uses pre and
fixed-width characters.
2. Nothing aligns
3. Every other browser has fixed-width support for pre and css for fixed-width
are used to account for the few that have bugs.

EXPECTED OUTCOME:
Fixed width fonts avail that are same as Win/Linux/Mac.  Pre Tag performs these

ACTUAL OUTCOME:
Non-fixed width

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6)
Gecko/20091215 Ubuntu/9.10 (karmic) Firefox/3.5.6
Comment 1 Andre Klapper maemo.org 2009-12-21 13:53:13 UTC
Thanks for reporting this.

Confirmed.
Comment 2 timeless 2009-12-21 14:36:31 UTC
So, pre alone works. The problem has to do with how fonts are selected/matched
and which fonts are available.
Comment 3 timeless 2009-12-21 14:41:49 UTC
OK, so the above url shows that we do support one font. The problem is that
somehow DejaVu Sans Mono/Courier New/monospace/Freemono is triggering some
other fallback.
Comment 4 tuukka.tolvanen nokia 2009-12-21 18:07:16 UTC
for one reason or another, http://nfomation.net/info/mascot.nfo comes out
properly monospaced in more recent browser bits, andre should be able to verify
in a week or so
Comment 5 Andre Klapper maemo.org 2009-12-21 18:16:11 UTC
At least in the internal version 2009.51-8 running here I can reproduce.
Comment 6 Andre Klapper maemo.org 2010-01-11 15:39:02 UTC
This seems to be fixed in the internal build version
2010.01-6
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-03-15 20:51:28 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).