Bug 7153 - (int-151576) Built-in MMC scripts only support FAT-formatted
(int-151576)
: Built-in MMC scripts only support FAT-formatted
Status: RESOLVED WONTFIX
Product: System software
mmc-and-usb
: 5.0/(2.2009.51-1)
: All Maemo
: Low enhancement with 9 votes (vote)
: ---
Assigned To: unassigned
: mmc-and-usb-bugs
:
: community-fremantle, patch
:
:
  Show dependency tree
 
Reported: 2009-12-20 12:13 UTC by Brad Mouring
Modified: 2012-03-24 11:46 UTC (History)
5 users (show)

See Also:


Attachments
A patch that supports auto-mounting linux-type partitions on the microSD card (1.45 KB, patch)
2009-12-20 12:15 UTC, Brad Mouring
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Brad Mouring (reporter) 2009-12-20 12:13:27 UTC
SOFTWARE VERSION:
(Settings > General > About product)
Maemo 5 1.2009.42-11.002

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Format microSD card in another machine to have a single partition, type
0x83, formatted as EXT3.
2. Insert the card into the N900

EXPECTED OUTCOME:
Card is recognized and can be used.

ACTUAL OUTCOME:
Card is detected, but yellow warning banner indicates that the format isn't
supported.  Can manually mount fine.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
Always

EXTRA SOFTWARE INSTALLED: (not that it really matters here)
account-plugin-haze
AdBlock Plus
aircrack-ng
AlmostTI
Bluetooth DUN
Bounce Evolution
DrNokSnes
Facebook Widget/Uploader
fennec
Flashlight
FM Radio Player
GPSJinni
Hermes
ines
irreco stuff
load applet
MasterGear
mbarcode
numptyphysics
Ogg Support
OMWeather
OpenArena
OpenSSH Client/Server
Personal IP
Petrovich
Pidgin + extra protocols
rdesktop
rootsh
SimpleFMTX widget
telnet client
TouchSearch
Transmission
unzip + zip
vncviewer
vpn + gui
wiicontrol
x11vnc
Zeemote Control Panel

OTHER COMMENTS:

Proposed patch to be posted.  Also note that whatever auto-creates the DCIM
photo folder for use by the photo app, it creates it on a EXT filesystem as
root, so the photo app will fail when set to save to memory card UNLESS the
ownership is set to "user"

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b6pre)
Gecko/20091213 Namoroka/3.6b6pre
Comment 1 Brad Mouring (reporter) 2009-12-20 12:15:53 UTC
Created an attachment (id=1808) [details]
A patch that supports auto-mounting linux-type partitions on the microSD card
Comment 2 Andre Klapper maemo.org 2009-12-21 18:57:51 UTC
Thanks for reporting this and providing a patch!
Comment 3 Kimmo Hämäläinen nokia 2010-01-07 15:50:03 UTC
FAT is the only officially supported format, so even ext3 is "invalid or
unsupported format". Otherwise we'd need to test the ext3 format as well as FAT
format, and accept that mass storage mode under Windows wouldn't work etc.

So, the patch is fine but the issues are product feature set related.
Comment 4 Kimmo Hämäläinen nokia 2010-01-07 15:51:53 UTC
maybe I could smuggle it in, but only if I get a more serious bug for ke-recv
that I can piggy-back :D
Comment 5 Andre Klapper maemo.org 2010-01-28 14:46:56 UTC
*** Bug 8179 has been marked as a duplicate of this bug. ***
Comment 6 Rene Castberg 2010-02-14 00:44:29 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 aapo.rantalainen 2010-05-14 18:22:47 UTC
Is this patch working (anymore)? 

I have ext3 formatted microSD in N900 but when booting I got yellow warning:
"format isn't supported".

Manual mounting works.
mount /dev/mmcblk1p1 /media/mmc1/

I apply patch, but situation is same.
Comment 8 Brad Mouring (reporter) 2010-05-14 20:30:45 UTC
I will check my patch when I can, I haven't had the EXT3 formatted card in my
N900 for a while
Comment 9 Andre Klapper maemo.org 2010-07-09 17:12:56 UTC
*** Bug 10856 has been marked as a duplicate of this bug. ***
Comment 10 aapo.rantalainen 2010-11-26 21:55:11 UTC
Is this fixed on PR-1.3? At least phone is not giving warning with
ext3-formatted card and it is automounted on boot.
Comment 11 Andre Klapper maemo.org 2012-03-24 11:46:29 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )