Bug 7139 - Replying to an email with non-ascii chars in From cuts name short
: Replying to an email with non-ascii chars in From cuts name short
Status: VERIFIED FIXED
Product: Email
General
: 5.0/(1.2009.42-11)
: All Maemo
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-19 23:36 UTC by Adam Sjøgen
Modified: 2010-03-15 20:56 UTC (History)
1 user (show)

See Also:


Attachments
Example email and reply (1.64 KB, text/plain)
2009-12-19 23:43 UTC, Adam Sjøgen
Details
Screenshot 1 from version 2009.51-8 (109.96 KB, image/png)
2009-12-20 15:53 UTC, Andre Klapper
Details
Screenshot 2 from version 2009.51-8 (107.33 KB, image/png)
2009-12-20 15:53 UTC, Andre Klapper
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Adam Sjøgen (reporter) 2009-12-19 23:36:26 UTC
SOFTWARE VERSION:
(Settings > General > About product)
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Receive an email from a person with non-ascii chars in the name. Eg. "Adam
Sjøgren"
2. Reply to the email.
3. Note that the To: field has chopped off one letter per non-ascii char in the
name, eg. "Adam Sjøgre"

EXPECTED OUTCOME:
The full name in the To: field, eg. "Adam Sjøgren"

ACTUAL OUTCOME:
One letter chopped off: "Adam Sjøgre"

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
It looks like a strlen() counting bytes vs. utf-8 characters problem. If I
receive a test email from "Frække frølår Test" (eg. three non-ascii chars) and
reply to it, the To: field contains the text "Frække frølår T" (three letters
chopped).

I haven't had time to dive into the code to produce a patch yet.

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.6)
Gecko/20091216 Iceweasel/3.5.6 (like Firefox/3.5.6; Debian-3.5.6-1)
Comment 1 Adam Sjøgen (reporter) 2009-12-19 23:43:02 UTC
Created an attachment (id=1804) [details]
Example email and reply

I am attaching an mbox file containing an email sent to my N900 and a reply
written on it, showing the chopping of three letters.
Comment 2 Andre Klapper maemo.org 2009-12-20 15:52:43 UTC
This works fine here running the internal version 2009.51-8, so I assume that
this has been fixed in the maintime.
Attaching two screenshots from the Composer window (but Name display also is
correct in the list view).
Comment 3 Andre Klapper maemo.org 2009-12-20 15:53:25 UTC
Created an attachment (id=1809) [details]
Screenshot 1 from version 2009.51-8
Comment 4 Andre Klapper maemo.org 2009-12-20 15:53:45 UTC
Created an attachment (id=1810) [details]
Screenshot 2 from version 2009.51-8
Comment 5 Adam Sjøgen (reporter) 2009-12-20 16:50:24 UTC
(In reply to comment #2)
> This works fine here running the internal version 2009.51-8, so I assume that
> this has been fixed in the maintime.

Sounds great!

I seem to have narrowed the problem down to 
quote_name_part () in src/modest-text-utils.c, but when I compare that to the
latest from "modest" on gitorious.org, I can't see what change fixed it. I
wonder what it was...

Ah, I was looking at the master branch, not the modest-3-2 branch (which oddly
contains fixes that master doesn't). This problem was fixed by svillar
(http://gitorious.org/modest/modest/commit/8ced6118ac86c3307ca676a5a705d6144e3349b7)
Comment 6 Andre Klapper maemo.org 2010-01-14 13:45:48 UTC
I must admit that I don't know if the fix is already included in today's
2.2009.51-1 update release or not. Checking and reporting back is welcome!
Comment 7 Adam Sjøgen (reporter) 2010-01-14 14:05:01 UTC
(In reply to comment #6)
> I must admit that I don't know if the fix is already included in today's
> 2.2009.51-1 update release or not. Checking and reporting back is welcome!

I can confirm that it is fixed for me in 2.2009.51-1. Thanks!
Comment 8 Andre Klapper maemo.org 2010-03-15 20:56:26 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).