Bug 7124 - (int-154438) media player loses cover art if song changes while screen is locked
(int-154438)
: media player loses cover art if song changes while screen is locked
Status: VERIFIED FIXED
Product: Media player
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium normal with 3 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-18 21:57 UTC by Nyall Dawson
Modified: 2010-05-25 23:02 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Nyall Dawson (reporter) 2009-12-18 21:57:07 UTC
SOFTWARE VERSION:
1.2009.42-11
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Start an album playing back, cover art works as expected for first track
played. (In my case, cover art is a cover.jpg file in the album folder).
2. Lock the screen and keys, or wait for the screen to lock by itself
3. Let the current track finish and a new track start
4. Unlock the screen - the cover art is missing from the now playing screen,
even though it exists. Skipping to the next song brings back the cover art,
which will show properly even if you skip back to the previous song. 


EXPECTED OUTCOME:
Cover art is correctly shown if the track changes while the screen is
blanked/locked.

ACTUAL OUTCOME:
No cover art shown for tracks that start playback while screen is blanked.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5)
Gecko/20091109 Ubuntu/9.10 (karmic) Firefox/3.5.5
Comment 1 Justin 2009-12-23 23:12:54 UTC
This occurs for me as well.
Comment 2 Peter Oliver 2010-01-10 20:33:12 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Andre Klapper maemo.org 2010-01-18 16:49:42 UTC
Is this also still an issue in 2.2009.51-1?
Also, this report needs better steps to reproduce. As written:
Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears).

Click by click, otherwise it is hard to reproduce.
Comment 4 Per 2010-01-18 18:24:45 UTC
This seems to be fixed on my device after upgrading to 2.2009.51-1.
Comment 5 Peter Oliver 2010-01-18 21:51:15 UTC
Still broken for me in 2.2009.51-1.

I'm able to reproduce with the following steps:

Start -> Media player -> (little black bars in the bottom right corner) -> Now
playing -> Clear current playlist -> Music -> (artist) -> (album) -> (menu) ->
Add songs to current playlist -> (little black bars in the bottom right corner)
-> (play) -> (ffw to near end of track) -> (power button) -> Lock screen and
keys.

Then wait for the current track to end and the next track to start.

(power button) -> (swipe to unlock)

Cover art appears for a fraction of a second before it's replaced by the
generic turntable image.  Note that this affects tracks where the cover art is
taken from cover.jpg, but it does not affect tracks that have embedded cover
art.
Comment 6 Andre Klapper maemo.org 2010-01-26 19:44:58 UTC
Tested with 2.2009.51-1 and the internal current version.

2.2009.51-1: Not working.
  2010.04-6: Working. => FIXED.

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Bartosz Taudul 2010-01-27 13:56:37 UTC
*** Bug 8561 has been marked as a duplicate of this bug. ***
Comment 8 Neil MacLeod maemo.org 2010-02-10 22:30:28 UTC
*** Bug 8977 has been marked as a duplicate of this bug. ***
Comment 9 Andre Klapper maemo.org 2010-03-15 20:54:50 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).