Bug 7100 - Ovi maps has problems when running without SIM card and without WLAN
: Ovi maps has problems when running without SIM card and without WLAN
Status: RESOLVED WORKSFORME
Product: Map
General
: 5.0/(1.2009.42-11)
: N900 Maemo
: Medium normal with 3 votes (vote)
: ---
Assigned To: unassigned
: map-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2009-12-18 05:21 UTC by klas_hultqvist
Modified: 2010-08-26 17:39 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description klas_hultqvist (reporter) 2009-12-18 05:21:15 UTC
SOFTWARE VERSION:
1.2009.41-11

EXACT STEPS LEADING TO PROBLEM: 
I'm trying ovi maps without sim cards and without WLAN connection (in presence
of many WLANs I do not have access to). I start the map application and try to
trace my walk on the map.

EXPECTED OUTCOME:
I would expect it to stay awake until it gets a GPS fix and then trace my
steps. With eCoach or GPXview this is what happens. Sometimes it's hard to get
a fix, but once I get one they generally provide accurate positions. Especially
GPXview works nicely.

ACTUAL OUTCOME:
1. It seems to time out before getting a GPS fix (at least the screen goes
black), but I keep it awake
2. After ~10 mins it sometimes gets a fix
3. The (obviously false) message "Downloading data" appears in a black box
which obscures my map and never goes away.
4. When I start walking the position doesn't update at all, or only for a short
time, then it is fixed where I once was.
5. The map application gets completely stuck and I cannot get out of it even
though I tap the "switch-to-dashboard" icon. After a minute or two the "network
has not been selected" dialogue pops up and I decline. This brings me out of
the maps application which I can kill. 

REPRODUCIBILITY:
So far, this seems completely reproducible (the trials are a bit
time-consuming). However, the time to get the fix obviously varies with
position and time.

EXTRA SOFTWARE INSTALLED:
eCoach, GPXview (I installed this when ovi maps didn't work)

OTHER COMMENTS:
It seems to me that nokia-maps in some context(s) assumes that there must be an
internet connection available and refuses to go on otherwise. If so, an option
to assume no connectivity ("offline mode") would be useful. I think a common
use-case for the gps is when you are travelling and therefore lack network
access.

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5)
Gecko/20091109 Ubuntu/9.10 (karmic) Firefox/3.5.5
Comment 1 Venomrush 2009-12-18 11:34:46 UTC
The issue you're seeing is because of Bug 5337 - Maps can't get GPS lock
without network connection when the GPS lock acquiring would take longer
Comment 2 Andre Klapper maemo.org 2009-12-18 14:33:06 UTC
Yes, Venomrush is right here (Thanks for finding!).

This particular bug has already been reported into our bug tracking system, but
please feel free to report any further bugs you find. Also feel encouraged to
vote for the original bug report if interested.
Please feel free to search for existing tickets first to avoid filing
duplicates.

*** This bug has been marked as a duplicate of bug 5337 ***
Comment 3 klas_hultqvist (reporter) 2009-12-25 03:33:02 UTC
I actually reported this under bug 5337 first, but Quim Gil asked me to file a
separate bug. Which I did.
Comment 4 Andre Klapper maemo.org 2009-12-28 14:15:04 UTC
(In reply to comment #3)
> I actually reported this under bug 5337 first, but Quim Gil asked me to file a
> separate bug. Which I did.

Oops. Okay, and sorry for the noise. :-/
Comment 5 anapospastos 2010-02-10 21:03:43 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 anapospastos 2010-02-12 12:09:51 UTC
This bug and the other that explains that n900 cant get gps lock with its
internal gps MUST be solved. Gps is worthless without an internet connection
and I dont have it always on the road. 2 major problems(for me).
Comment 7 Andre Klapper maemo.org 2010-02-12 12:38:40 UTC
(In reply to comment #6)
> MUST be solved.

Please do not add "me too!" comments as they just create bugmail and do not add
any additional value to a bug report. Please just silently vote.
Comment 8 Andre Klapper maemo.org 2010-04-27 16:21:24 UTC
This is still a valid issue in 3.2010.02-8 I assume?
Comment 9 Andre Klapper maemo.org 2010-05-05 03:23:57 UTC
ping - can you please confirm that this is still a problem in 3.2010.02-8?
Comment 10 Vincent Lefevre 2010-05-05 10:59:56 UTC
I'm not the bug reporter, but had the problem in the past. I now have a SIM
card, so that I'm no longer concerned by this bug. I could try if there's a way
to do this without removing the SIM card.
Comment 11 Andre Klapper maemo.org 2010-08-26 17:39:22 UTC
Closing this bug report as the issue could not be reproduced + no feedback on
comments 8 and 9. Please feel free to reopen this report if this is still an
issue in the latest Maemo5 software version.