Bug 7087 - Audio playback freezes during screen rotation
: Audio playback freezes during screen rotation
Status: RESOLVED FIXED
Product: Panucci
General
: unspecified
: N900 Maemo
: Low normal (vote)
: ---
Assigned To: Thomas Perl
: general
:
:
: int-147061
:
  Show dependency tree
 
Reported: 2009-12-17 21:52 UTC by Chad Diederichs
Modified: 2010-04-01 00:28 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Chad Diederichs (reporter) 2009-12-17 21:52:55 UTC
SOFTWARE VERSION:  0.3-8thp0
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 

1. Start audio playback with automatic rotation enabled.
2. Rotate display.


EXPECTED OUTCOME: Screen rotates with no break in music playback.

ACTUAL OUTCOME:  Music playback stutters and freezes for the duration of the
screen rotation.

REPRODUCIBILITY:  always.


EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10)
Gecko/20071115 Firefox/2.0.0.10 (.NET CLR 3.5.30729)
Comment 1 Thomas Perl 2009-12-17 22:59:46 UTC
I believe this is caused by bug 6203. Please wait for the next firmware update
to see if this fixes the problem. As you can see in this video:
http://www.youtube.com/watch?v=5rjXAGlLDHU the rotation did not always cause
the freezing (the video was taken with a pre-release firmware where the bug was
not yet introduced). I suspect when the fix to bug 6203 is released that this
bug will go away as well.

It would be nice if you could re-test this after the next firmware update to
see if the problem still exists. Thank you for your bug report.
Comment 2 Chad Diederichs (reporter) 2009-12-18 01:52:48 UTC
(In reply to comment #1)

At least on my N900's production firmware, this is easily reproducble every
time so it's interesting to see your example on pre-production firmware.

Whenever Nokia pushes out new firmware, I'll test this again and write in.

Thanks!
Comment 3 gidyn 2010-01-03 19:53:25 UTC
Can screen rotation be optional? Random gyrating every time I put the phone
down is driving me up the wall.
Comment 4 David Ward 2010-01-07 02:15:24 UTC
Panucci also pauses playback when locking the screen or doing any simple
multi-task.

I notice is uses a lot more CPU just to play files than the builtin player.
Maybe its the underlying Python. Don't know, but it is a resource hog.

Awesome player though, love it :)
Comment 5 Chad Diederichs (reporter) 2010-01-14 18:54:57 UTC
I can confirm that this bug is FIXED!   Get the latest Firmware update (PR1.1)
and audio playback in this application is glitch free during auto rotation!!!
Comment 6 John Veness 2010-04-01 00:28:15 UTC
(In reply to comment #5)
> I can confirm that this bug is FIXED!   Get the latest Firmware update (PR1.1)
> and audio playback in this application is glitch free during auto rotation!!!

Panucci music playback glitches a little for me in PR 1.1.1 during rotation,
although only for a tenth of a second or so.