Bug 7052 - (int-150534) Unable to see the sender's phone number used for a received sms
(int-150534)
: Unable to see the sender's phone number used for a received sms
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 6 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-16 21:57 UTC by Did.G.K
Modified: 2010-05-27 13:24 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Did.G.K (reporter) 2009-12-16 21:57:28 UTC
SOFTWARE VERSION: 1.2009.42-11
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
1. receive an sms from a recorded contact
2. try to see from wich phone number he sent the sms


EXPECTED OUTCOME:
the phone number used to send the sms is shown
ACTUAL OUTCOME:
Impossible de know from wich phone number the sms was sent.
REPRODUCIBILITY:always
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
In my contacts, some people have a mobile number abroad ... when I receive an
sms I do not know from what country they wrote me..


User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.33 Safari/532.0
Comment 1 Did.G.K (reporter) 2009-12-16 22:03:56 UTC
I forgot to specify in "severity" => ENHANCEMENT
Sorry :-/
Comment 2 Andre Klapper maemo.org 2009-12-17 00:59:52 UTC
Thanks for reporting this.

So even clicking the icon of the person left to the message to go to the
Contact Details page does not help you, because you cannot find out which
number it was?

This sounds a bit similar to bug 6651 but that one is abut the *Call* log.
Comment 3 Andrej Krutak 2010-01-15 02:03:08 UTC
this still isn't fixed/implemented in 51-1
Comment 4 Alex Smirnoff 2010-01-28 16:07:13 UTC
And i'd like to see full message details as well. Checking oiriginator SMSC
number is the only way to know if SMS was spoofed.
Comment 5 Mikhail Zabaluev nokia 2010-01-28 16:37:07 UTC
(In reply to comment #4)
> And i'd like to see full message details as well. Checking oiriginator SMSC
> number is the only way to know if SMS was spoofed.

This is a subject for another bug, or perhaps a brainstorm topic.
Comment 6 Andre Klapper maemo.org 2010-02-09 20:01:38 UTC
This has been fixed in the internal build version
10.2010.06-0
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-03-15 20:52:13 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 8 Venomrush 2010-05-25 18:23:28 UTC
Still can't tell which number was sent from.
Comment 9 Venomrush 2010-05-25 18:25:56 UTC
Seems like duplicated of bug 6016

*** This bug has been marked as a duplicate of bug 6016 ***
Comment 10 Mikhail Zabaluev nokia 2010-05-25 18:45:59 UTC
(In reply to comment #9)
> Seems like duplicated of bug 6016

Not quite, this one is for received SMS, and bug 6016 is for sent SMS.
Comment 11 Dawid Lorenz 2010-05-26 20:57:50 UTC
(In reply to comment #8)
> Still can't tell which number was sent from.
> 

In single text message view tap on sender name (or avatar), which should bring
up a contact card with one of the numbers highlighted blue. Pretty uninuitive
but I think that's it.
Comment 12 Mikhail Zabaluev nokia 2010-05-27 13:24:20 UTC
(In reply to comment #11)
> (In reply to comment #8)
> > Still can't tell which number was sent from.
> > 
> 
> In single text message view tap on sender name (or avatar), which should bring
> up a contact card with one of the numbers highlighted blue.

True. Accept as "Fixed with quirks?" :)