Bug 6983 - Show wrong Contact for a SMS after a couple of days
: Show wrong Contact for a SMS after a couple of days
Status: RESOLVED DUPLICATE of bug 6984
Product: Chat & Call & SMS
Messaging
: 5.0/(1.2009.42-11)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-15 13:30 UTC by redex
Modified: 2009-12-15 14:28 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description redex (reporter) 2009-12-15 13:30:04 UTC
SOFTWARE VERSION:
5.0/(1.2009.42-11)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))

I received some Messages from T-Mobile with Bill informations.
I have the Number "received from" not in my Contacts and also not at the SIM
Card.
The N900 shows the name "T-Mobile" as sender - searching in Contacts for
T-Mobile without result, but it shows the Name instead of the Number - i don't
know how it works. A special mark in the SMS?

I received the first SMS on 3. December 2009, 11:34 and the last 11. December
2009. There are 3 ones in this Conversation path.

Conversations shows always the correct Name.

Today i saw it shows for this Conversation a wrong Contact Name. When I tap on
the Icon the 3 phone Numbers from the Contact "Alexander Krauß" appears. Not
from T-Mobile.

After a restart of the Phone and open the Conversation the first time it shows
for about a second "T-Mobile" for the Name. After refreshing the screen and
loading a image of a other contact "T-Mobile" disappers and the Contact
"Alexander Krauß" is linked to the Conversation with "T-Mobile".
Closing and reopening the Conversation - "T-Mobile" shows never again as sender
until the next restart of the Device.

I know from my old phone. The Number the SMS was send from T-Mobile has 4
digits and is very short. The Contact "Alexander Krauß" has no number like this
in the contact details.

EXPECTED OUTCOME:
Show always the correct Person a SMS was send from 

ACTUAL OUTCOME:
Shows always the wrong sender for the T-Mobile SMS Conversation. It works
before just fine.

REPRODUCIBILITY:
I would like to say less than 1/10 - there was no bug at the beginning. It
worked just fine. But once the bug appears it appears always and it is
reproducible on my device.

EXTRA SOFTWARE INSTALLED:
Conboy
eCoach
Password Safe
load-applet
Bounce Evolution

OTHER COMMENTS:
Alexander Krauß is a very common name in germany. So no privacy problems. I
will add some screenshots with red marks over the private content. 

Alexander Krauß is not the first Contact in my Contacts. But it could be
possible that his ID in the Database is the lowest or even the ID is 1, because
it is possible that it was the first created contact during the synchronization
with my old phone.

It would be really nice if the conversation could show the real number a sms
was send from. Or the Plain Message as it was received and stored. 

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR
1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022;
InfoPath.2)
Comment 1 Mikhail Zabaluev nokia 2009-12-15 14:28:59 UTC
Looks like a duplicate posting to bug #6984. Since you have added some useful
attachments there, that bug will go on.

*** This bug has been marked as a duplicate of bug 6984 ***