Bug 6980 - Bugs In The Arabic Hardware Keyboard
: Bugs In The Arabic Hardware Keyboard
Status: RESOLVED FIXED
Product: Ukeyboard
General
: unspecified
: All Maemo
: High normal (vote)
: ---
Assigned To: Roman Moravcik
: general
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-15 11:43 UTC by Ahmed ALHAMAZANI
Modified: 2009-12-26 13:52 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ahmed ALHAMAZANI (reporter) 2009-12-15 11:43:37 UTC
SOFTWARE VERSION:
Nokia N900
Maemo 5
Version: 1.2009.42-11.003

EXACT STEPS LEADING TO PROBLEM: 
1. Go to sitting .
2. Go to Text Input
3. Change "Hardware keyboard layout" to "Arabic, English"
4. Try to use Enter , Ctrl , Shift , Backspace ,The Blue Function Key .

EXPECTED OUTCOME:
It should work .

ACTUAL OUTCOME:
Those buttons doesn't work when changing the hardware keyboard to Arabic
Also , there is no shortcut to change the Arabic/English language like an icon
beside the battery icon to change the language . so now you need to go to
setting then Text input and change it from there every time you want to change
the language !!

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Hope to solve this bugs as soon as possible cause a lot of people will depend
on this application in their daily lives . 

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.1 (KHTML, like Gecko) Chrome/4.0.213.1 Safari/532.1
Comment 1 Abdullah 2009-12-17 20:43:07 UTC
There is no way we could switch between Arabic and English.
Comment 2 Ahmed ALHAMAZANI (reporter) 2009-12-17 21:22:51 UTC
Hello Abdullah ,,

I don't believe that there is something called "no way" specially in this field
:)

My Idea is to put a shortcut in the status bar in the top of the screen that
can change the Hardware keyboard layout , so you don't have to go to setting
--> Text input --> Hardware keyboard layout .

I don't think that this is impossible , because there is other apps that add
shortcuts in the status bar beside the battery information , so absolutely
there is a solution like an update or even an additional app to make the
Hardware keyboard language changing easier to access .
Comment 3 Abdullah 2009-12-17 21:25:44 UTC
Hello Ahmed,


(In reply to comment #2)
> Hello Abdullah ,,
> 
> I don't believe that there is something called "no way" specially in this field
> :)
> 
> My Idea is to put a shortcut in the status bar in the top of the screen that
> can change the Hardware keyboard layout , so you don't have to go to setting
> --> Text input --> Hardware keyboard layout .
> 
> I don't think that this is impossible , because there is other apps that add
> shortcuts in the status bar beside the battery information , so absolutely
> there is a solution like an update or even an additional app to make the
> Hardware keyboard language changing easier to access .
> 

I meant currently there is no easy way to change the language like in desktop
systems, or even Nokia E90.

I hope it will be fixed very soon
Comment 4 Roman Moravcik 2009-12-18 09:38:56 UTC
- Problem of not working special keys, such as Enter, Ctrl, Shift, ... was
problem in general and all ukeyboard's HW keyboards were affected by this
problem. This problem is already fixed in git repository by this commit:

http://repo.or.cz/w/ukeyboard.git/commit/cfae04f543227caa642c2d4b7008b3e7053c3863

- Switching between layouts, I mean between Arabic and English is something
what I'm planing to do in the next days. As soon as it will be fixed I will
upload new version of ukeyboard.
Comment 5 Ahmed ALHAMAZANI (reporter) 2009-12-20 15:19:26 UTC
Hello Roman Moravcik ,

Do you know that you give me a big hope with your comment ? :)

Thanks very much for all what you did and what you will do .




This problem is already fixed in git repository by this commit:

http://repo.or.cz/w/ukeyboard.git/commit/cfae04f543227caa642c2d4b7008b3e7053c3863
about this link , I really could not understand anything , should I do any
thing with the app in my device ? or the problem will be fixed in the next
update ? please tell me if there's a stages to fix it manually or if I have to
wait till the next update .

thanks again :)
Comment 6 Roman Moravcik 2009-12-24 23:12:27 UTC
New version of ukeyboard 2.1-0 was promoted to extras-testing repository.
Please test it and let me know if it's working properly.

http://maemo.org/packages/package_instance/view/fremantle_extras-testing_free_armel/ukeyboard/2.1-0
Comment 7 Ahmed ALHAMAZANI (reporter) 2009-12-25 00:25:15 UTC
I have updated to the new version ukeyboard 2.1-0 on extras-testing and tested
it

The Arabic is not in the hardware keyboard . if you chose "Arabic/English" on
the Hardware keyboard layout , then the hardware keyboard will type only the
English characters .
Comment 8 Roman Moravcik 2009-12-25 00:30:21 UTC
(In reply to comment #7)
> The Arabic is not in the hardware keyboard . if you chose "Arabic/English" on
> the Hardware keyboard layout , then the hardware keyboard will type only the
> English characters .
> 

Switching between layouts is done by pressing magical key combination
Ctrl+Space. This should be described also in N900 user manual.
Comment 9 Ahmed ALHAMAZANI (reporter) 2009-12-25 00:59:28 UTC
Perfect ,, thats what could I say realy .
the bug is solved .

I have some suggestions about changing some characters places such as و , ج and
د  

It is now :

ج = shift + U

د = shift + I

و = shift + C



But it will be better if :

ج = shift + P

د = shift + ,

و switched with لا so :

 و = B

لا = shift + C

because و is an important character on Arabic and we use it a lot Unlike لا
which is a combined of ل + ا

Hope I'm not bothering you :)
Thank you ,,

thanks very much
Comment 10 Roman Moravcik 2009-12-26 13:12:59 UTC
Hi Ahmed
(In reply to comment #9)
> Perfect ,, thats what could I say realy .
> the bug is solved .
> 
> I have some suggestions about changing some characters places such as و , ج
> and د  

No problem, I can modify layout based on your suggestions, but could you please
open a new bug for this. I want to close this one, because it was related to
not working modifier keys and possibility to switch layout. I also found
picture of Arabic N97 and it has similar keyboard then N900. Thank you.

BTW: Could you please also re-test layout with Auto-capitalization option
disabled? (I can't ignore this option for Arabic layout and first entered
character is always Shift+pressed key is this option enabled.
Comment 11 Ahmed ALHAMAZANI (reporter) 2009-12-26 13:52:38 UTC
re-test is passed for the hardware keyboard

it works just fine with or without Auto-capitalization option for the hardware
keyboard

but the virtual keyboard is not , Arabic don't have capitalization as you know
, but when try to use the virtual keyboard it will start with Shift



for the characters I will write another bug report with another small problem