Bug 6951 - Application does not exit after selecting Quit. makes desktop inaccessible.
: Application does not exit after selecting Quit. makes desktop inaccessible.
Status: RESOLVED DUPLICATE of bug 5524
Product: UQM
General
: unspecified
: All Maemo
: Low normal (vote)
: ---
Assigned To: Flandry
: general
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-14 13:04 UTC by mustali
Modified: 2009-12-26 10:28 UTC (History)
1 user (show)

See Also:


Attachments
dimmed UQM screen (19.74 KB, image/png)
2009-12-14 13:05 UTC, mustali
Details
Screenshot when ctrl+backspace is pressed (8.35 KB, image/png)
2009-12-19 12:21 UTC, mustali
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description mustali (reporter) 2009-12-14 13:04:15 UTC
SOFTWARE VERSION: 
0.6.7-0maemo

EXACT STEPS LEADING TO PROBLEM: 
1. Start music player, play music
1. Start UQM
2. Select Quit to exit the application

EXPECTED OUTCOME:
1. Application closes and the desktop appears

ACTUAL OUTCOME:
The screen dims with the UQM selection screen. 
Desktop is inaccessible. The uqm process has to be killed manually.
'End Current Task' option is not available from the power button options.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
I was able to recover from the error and get the desktop back because I was
networked via USB. 

Nokia-N900-42-11:~# ps -ef | grep uqm
 2495 user     46156 S    /opt/uqm/uqm --contentdir=/opt/uqm/content --fullscre
 2512 root      2088 S    grep uqm 
Nokia-N900-42-11:~# kill -9 2495

User-Agent:       Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15
Version/10.10
Comment 1 mustali (reporter) 2009-12-14 13:05:36 UTC
Created an attachment (id=1757) [details]
dimmed UQM screen
Comment 2 Andre Klapper maemo.org 2009-12-18 20:45:06 UTC
Does using Control+Backspace still work in this state?
Comment 3 mustali (reporter) 2009-12-19 12:20:25 UTC
No. Ctrl-Backspace gives a blank screen with the task-switcher icon. see
attachement
Comment 4 mustali (reporter) 2009-12-19 12:21:14 UTC
Created an attachment (id=1800) [details]
Screenshot when ctrl+backspace is pressed
Comment 5 Flandry 2009-12-26 10:28:27 UTC
This seems to be related to the pulseaudio/SDL bug. I'm going to mark it as a
duplicate of that bug report and this can be reopened if that bug is resolved
and this still is a problem.

*** This bug has been marked as a duplicate of bug 5524 ***