Bug 6945 - (int-131245) Skype: merged contact has duplicate phone number
(int-131245)
: Skype: merged contact has duplicate phone number
Status: RESOLVED FIXED
Product: Contacts
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low minor with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-14 10:00 UTC by Rolf Sormo
Modified: 2010-03-15 20:53 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Rolf Sormo (reporter) 2009-12-14 10:00:54 UTC
Problem is that the merged Contacts doesn't recognize the same phone number
represented a little differently internally and by skype as being the same.
This causes duplication of information and functionality that fills the contact
screen(s).

SOFTWARE VERSION:
Maemo 5, 1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Add a contact with a phone number (will be added by the application as
+xxxxxxxxxxx)
2. Configure skype with a contact that in their information has the same phone
number, though written a little differently (+xxx xx xxx xxx)
3. Merge the two contacts above

EXPECTED OUTCOME:
The user's two equal phone numbers written a little differently should show as
just one phone number (either as "+xxxxxxxxxxx" or "+xxx xx xxx xxx").

ACTUAL OUTCOME:
The user seems to have two phone numbers causing the UI to offer several
duplicate functionalities (Mobile, SMS, Call with Skype).

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:
Skype

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.33 Safari/532.0
Comment 1 Rolf Sormo (reporter) 2009-12-15 08:56:04 UTC
Actually this doesn't have anything to do with the difference in the phone
numbers. It happens with equal numbers aswell.
Comment 2 massimo.bilvi 2009-12-15 21:30:11 UTC
I confirm the bug. I have the same problem with a skype contact. It's
impossible to delete the second phone number (imported from skype).
Comment 3 massimo.bilvi 2009-12-16 17:03:58 UTC
I hope that the fix will include also the possibility to delete the duplicated
phone number.
Comment 4 Mikhail Zabaluev nokia 2009-12-16 18:41:04 UTC
(In reply to comment #3)
> I hope that the fix will include also the possibility to delete the duplicated
> phone number.

If it is correctly merged (as in, you can see no duplicate numbers), what is
there to delete?
We cannot delete Skype contacts' own information, for one thing.
Comment 5 massimo.bilvi 2009-12-16 20:40:22 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > I hope that the fix will include also the possibility to delete the duplicated
> > phone number.
> 
> If it is correctly merged (as in, you can see no duplicate numbers), what is
> there to delete?
> We cannot delete Skype contacts' own information, for one thing.
> 

I wanted to say that i want to delete the second phone number (that imported
from Skype) from my phonebook.
Comment 6 Rolf Sormo (reporter) 2009-12-17 08:51:34 UTC
Personally I would like both numbers stay as they are, just not show them both
or at least not offer all the duplicate functionalities (Mobile, SMS, Call with
Skype).

If the one I added is deleted and the contact changes their number in Skype,
will I lose the one I added for good? If the one added through Skype is removed
and the contact changes their number in Skype, will I get an update?
Comment 7 Mikhail Zabaluev nokia 2009-12-17 11:46:34 UTC
(In reply to comment #6)
> If the one I added is deleted and the contact changes their number in Skype,
> will I lose the one I added for good? If the one added through Skype is removed
> and the contact changes their number in Skype, will I get an update?

I may be mistaken, but AFAIK the address book should only mask duplicate
numbers, and never delete something the user has entered. If it does otherwise,
it's a ticketable offense :)
Comment 8 Andre Klapper maemo.org 2009-12-31 17:40:34 UTC
This has been fixed in package
libosso-abook 4.20091214.1.0rtc+0m5
which is part of the internal build version
2009.52-6
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 9 Andre Klapper maemo.org 2010-02-02 22:16:53 UTC
*** Bug 8775 has been marked as a duplicate of this bug. ***
Comment 10 Andre Klapper maemo.org 2010-02-12 17:10:28 UTC
*** Bug 9023 has been marked as a duplicate of this bug. ***
Comment 11 Andre Klapper maemo.org 2010-03-15 20:53:14 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).