Bug 6932 - "More..." view is not sorted at all
: "More..." view is not sorted at all
Status: VERIFIED FIXED
Product: Desktop platform
Application Menu
: 5.0/(1.2009.42-11)
: All Linux
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: task-navigator-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-13 22:27 UTC by Marcin Juszkiewicz
Modified: 2010-01-14 14:21 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Marcin Juszkiewicz (reporter) 2009-12-13 22:27:07 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Boot device
2. open application launcher, tap "more..."
3. try to find application

EXPECTED OUTCOME:
Applications list is sorted alphabetically

ACTUAL OUTCOME:
Applications list is not sorted at all (or maybe sorted by application install
time).

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2009-12-14 15:57:40 UTC
Heja,
this is FIXED in a later release as any apps that were installed *later* are
soreted alphabetically now. This means everything after "X Terminal" is
alphabetical.
Don't know the exact version, but it definitely works in week 49.

For related stuff, also see bug 6401 and bug 3822.
Comment 2 Andre Klapper maemo.org 2010-01-14 12:29:04 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 3 Marcin Juszkiewicz (reporter) 2010-01-14 14:18:22 UTC
I am using catorise now so 'more...' view is not present on my device now and
cant check.
Comment 4 Marcin Juszkiewicz (reporter) 2010-01-14 14:19:48 UTC
13:17 < Jaffa> hrw: It is sorted in PR1.1; although the first 12 are treated
"special"
Comment 5 Andrew Flegg maemo.org 2010-01-14 14:21:14 UTC
Entries after the first 12 (i.e. the start of user-installed ones) are now
sorted in 2.2009.51-1. See bug 7450 for the fact the first 12 aren't sorted.