Bug 6909 - (int-140343) Calendar launches automatically at 4:00 each night
(int-140343)
: Calendar launches automatically at 4:00 each night
Status: VERIFIED FIXED
Product: Calendar
General
: 5.0/(2.2009.51-1)
: All All
: Medium normal with 6 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: calendar-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-13 10:28 UTC by Petrus Lundqvist
Modified: 2010-05-27 17:42 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Petrus Lundqvist (reporter) nokia 2009-12-13 10:28:09 UTC
SOFTWARE VERSION: 1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Make sure calendar is set to remove items older than 1 month
2. Boot device
3. Don't launch any apps (especially not the calendar)
4. Set clock to a few minutes before 4:00
5. At 4:00 the calendar now launches automatically

EXPECTED OUTCOME:
Calendar should not automatically launch at any time

ACTUAL OUTCOME:
Calendar launches at 4:00 when you have it set to remove items older than 1
month.

REPRODUCIBILITY:
Always. But as soon as you set "remove old items" to "never" it stops
happening. Put it back to "remove items older than 1 month" and it continues
happening. This also appears to happen every night at exactly 4:00 - not just
the first night after rebooting.

EXTRA SOFTWARE INSTALLED:
None

OTHER COMMENTS:
The device is retail hardware and the software that came with it. I have not
installed any 3rd party apps on it nor do I have any strange configurations. No
calendar synching is configured.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us)
AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Comment 1 Andre Klapper maemo.org 2009-12-15 23:08:03 UTC
Thanks for reporting this.

For future reference, please use the internal bug database directly if you have
access to it.
Comment 2 Andre Klapper maemo.org 2010-01-22 13:36:07 UTC
This has been fixed in package
calendar 0.6-10+0m5
which is part of the internal build version
2010.03-4
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 3 Andre Klapper maemo.org 2010-03-15 20:51:22 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 4 Andre Klapper maemo.org 2010-03-25 01:08:53 UTC
*** Bug 9690 has been marked as a duplicate of this bug. ***
Comment 5 Tim Samoff maemo.org 2010-05-27 17:28:30 UTC
Confirming as fixed in PR1.2.