Bug 6892 - Add support for tasks descriptions in the n900 calendar application
: Add support for tasks descriptions in the n900 calendar application
Status: RESOLVED WONTFIX
Product: Calendar
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low enhancement with 38 votes (vote)
: ---
Assigned To: unassigned
: calendar-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-12 20:25 UTC by manaryde
Modified: 2012-03-24 11:45 UTC (History)
8 users (show)

See Also:


Attachments
Image showing task description see note 1a (178.67 KB, image/jpeg)
2010-03-23 02:02 UTC, Tim Watt
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description manaryde (reporter) 2009-12-12 20:25:06 UTC
SOFTWARE VERSION: 1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
Open Tasks application

EXPECTED OUTCOME:
You can view and edit task description.

ACTUAL OUTCOME:
You cannot view or edit description.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
None
Comment 1 Venomrush 2009-12-13 17:15:01 UTC
I'm not understanding the issue.

Some screenshots would help you to express your idea.
Comment 2 Andre Klapper maemo.org 2009-12-14 19:22:30 UTC
(In reply to comment #0)
> SOFTWARE VERSION: 1.2009.42-11
> 
> EXACT STEPS LEADING TO PROBLEM: 
> Open Tasks application

This is missing steps. (Explain in detail what you do (e.g. tap on OK) and what
you see (e.g. message Connection Failed appears))

Please also tell us what the "calendar" item is set to when adding a new task.
Comment 3 manaryde (reporter) 2009-12-15 22:53:35 UTC
steps:
- open Calendar
- click top bar (menu)
- select "Go to tasks"
- select "New task"
- you can enter task name
- you can enter task date
- you can select calendar to save task (no matter which calendar you select)
- you can not enter task description. There is no such textbox.

For example, Microsoft Outlook and Nokia Symbian phones has both name AND
description in Tasks. Maemo 5 has only name.
Comment 4 Tim Watt 2009-12-22 03:02:35 UTC
> Calender 
> Tasks
> New Task
> Description (text that accompany task is missing) 

in simple English the n900 has limited PIM functionality as it does not support
task notes (descriptions). 

tasks sync with outlook only displays the Task Name and not the description.
Comment 5 Andre Klapper maemo.org 2010-01-11 15:52:29 UTC
(This is currently not supported.)
Comment 6 Tim Watt 2010-01-16 09:48:30 UTC
When I check my sync logs the task description is synced to the n900, task in
the n900 does not have a description field, so it cant be seen on the n900.
Comment 7 Tim Watt 2010-01-18 17:18:33 UTC
Hi Andre I realize it is no supported as it is not there, my question is given
it is supported in Symbian S40, S60 and S90, could we expect it to be available
in Maemo?
Comment 8 Andre Klapper maemo.org 2010-01-18 17:21:29 UTC
Sorry, I don't know. Features are always up to management decisions as far as I
know, plus comparing to any other codebase does not change something...
Comment 9 Tim Watt 2010-01-18 17:30:07 UTC
Thanks Andre,
How would I go about filing a feature request is this not the place to do it? 
To be honest the n900 is a great technical leap forward but the lack of notes
in tasks is crippling my productivity (it's been a standard feature on most
phones for the last 8 years.
Comment 10 Andre Klapper maemo.org 2010-01-18 17:34:21 UTC
Well, this is the right place for small, non-brainer enhancement requests. Up
to managers/developers to pick them up, or not... Feel free to vote.
Comment 11 Tim Watt 2010-01-22 03:58:33 UTC
Can someone please change the summary of this to better reflect the issue. 
my suggestion is:
"Add support for tasks descriptions in the n900 calendar application" 

to be honest, this feature has nothing to do with Outlook.
Comment 12 Andre Klapper maemo.org 2010-01-22 14:26:20 UTC
Done. Thanks for clarifying!
Comment 13 Andre Klapper maemo.org 2010-01-27 19:16:26 UTC
*** Bug 8482 has been marked as a duplicate of this bug. ***
Comment 14 Tim Watt 2010-03-23 02:02:28 UTC
Created an attachment (id=2500) [details]
Image showing task description see note 1a 

The image attached shows a solution for task description in the layout.
note: the task descriptions appear to be synced with Nokia PC suite they just
can't be viewed or edited.
Comment 15 Andre Klapper maemo.org 2012-03-24 11:45:58 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )