Bug 6882 - (int-129676) Deletes file to move if destination filename already exists and choosing to not overwrite
(int-129676)
: Deletes file to move if destination filename already exists and choosing to n...
Status: RESOLVED FIXED
Product: Utilities
File manager
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low critical with 5 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: file-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-12 07:14 UTC by Jay Gates
Modified: 2010-04-19 10:56 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jay Gates (reporter) 2009-12-12 07:14:20 UTC
SOFTWARE VERSION:
1.2009.42-11.002

EXACT STEPS LEADING TO PROBLEM: 
1. Created a non-empty file: ~/MyDocs/.documents/Test
2. Created a non-empty file: ~/Test
3. Opened File Manager, browsed to ~, selected (long-press) file Test, selected
Rename
4. In "move mode" of file manager, browsed to Documents (~/MyDocs/.documents)
folder, and selected it as destination for file move operation
5. Message "Replace existing file of same name? Yes No" appears
6. Select No, and operation is cancelled

EXPECTED OUTCOME:
Both files (original location and destination location) are unchanged.

ACTUAL OUTCOME:
The file being moved is gone.  In ~, find .|grep Test locates only the 2nd file
(~/MyDocs/.documents/Test)

REPRODUCIBILITY:
Always (3/3)

EXTRA SOFTWARE INSTALLED:
N/A

OTHER COMMENTS:
Is the file being moved to a temporary location (and renamed), then abandoned
or deleted?

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5)
Gecko/20091109 Ubuntu/9.10 (karmic) Firefox/3.5.5
Comment 1 Jay Gates (reporter) 2009-12-12 07:19:55 UTC
Sorry: location of file being moved was ~/MyDocs/Test (to
~/MyDocs/.documents/Test).

The find|grep was indeed run from the ~ directory.
Comment 2 Lucas Maneos 2009-12-12 18:44:43 UTC
Thanks for the report.  Confirming, and setting appropriate severity for data
loss.

> 3. Opened File Manager, browsed to ~, selected (long-press) file Test,
> selected Rename

this should be Move I think.

> Is the file being moved to a temporary location (and renamed), then abandoned
> or deleted?

strace shows it doing a stat64(2) & lstat64(2) on the destination (several
times) and a bit later unlink(2), so no temporary locations seem to be
involved.
Comment 3 redex 2010-01-06 21:34:34 UTC
I had this bug on December the 14th the first time and yesterday the second
time during sorting my contacts Pictures. I was glade to had a backup the first
time. But the second time the new File was only 5 minutes old.

I have only voted for this bug the mid of December and hoped for a fast hotfix. 

So here my tip for everyone moving files with common names from one folder to a
other: When the Dialog "Replace existing file of same name?" appears, turn your
N900 imedially off to avoid loose of data!

You can't cancel this dialog and every answer is wrong!

I hope there is a fast fix on the way. When it is to hard to solve it on a fast
way, please replace the dialog only with: "Can't move. File already exists at
the destination folder." - this will solve the problem for the moment.
Comment 4 Andre Klapper maemo.org 2010-01-15 13:11:50 UTC
This has been fixed in package
osso-filemanager 1:3038.4+0m5
which is part of the internal build version
2010.02-6
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 5 Andre Klapper maemo.org 2010-03-15 20:57:06 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 6 Andre Klapper maemo.org 2010-04-19 10:56:02 UTC
*** Bug 9954 has been marked as a duplicate of this bug. ***