Bug 6877 - (int-92408) Pin / lock code entry dialog reveals digits on backspace
(int-92408)
: Pin / lock code entry dialog reveals digits on backspace
Status: CLOSED FIXED
Product: System software
Device lock
: 5.0/(1.2009.42-11)
: All Maemo
: Low minor (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: device-lock-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-12 02:08 UTC by Chris Pitchford
Modified: 2010-03-02 14:08 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Chris Pitchford (reporter) 2009-12-12 02:08:34 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. power on device and reach "enter pin code" or lock device and reach "enter
lock code" dialog
2. Enter a pin number (each entered digit turns into an asterisk)
3. Press delete/backspace button in dialog box

EXPECTED OUTCOME: Numbers should never be revealed when backspace is used

ACTUAL OUTCOME: Last digit after deletion is revealed as if it has just been
entered (ie turns into a digit then back into an asterisk)

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
Every time with pin entry dialog, seems to affect only first digit in lock code
dialog

EXTRA SOFTWARE INSTALLED:
None
OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Comment 1 Andre Klapper maemo.org 2009-12-12 14:57:59 UTC
This has been fixed in package
codelockui 1:1.6.15+0m5
which is part of the internal build version
2.2009.43-9
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Note that Nokia does not announce release dates of public updates in advance.
Comment 2 Andre Klapper maemo.org 2010-01-14 12:25:57 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 3 Venomrush 2010-03-01 23:13:53 UTC
Verifying for PR1.1