Bug 6874 - Segmentation fault after selecting Slideshow Time
: Segmentation fault after selecting Slideshow Time
Status: RESOLVED DUPLICATE of bug 5517
Product: Canola
Photos
: unspecified
: N900 Maemo
: Low normal (vote)
: ---
Assigned To: Eduardo Lima (Etrunko)
: general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-12 00:04 UTC by mustali
Modified: 2009-12-14 21:50 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description mustali (reporter) 2009-12-12 00:04:35 UTC
SOFTWARE VERSION:
2.0.0-maemo1

EXACT STEPS LEADING TO PROBLEM: 
1. Open an Album 
2. Select a photo and open in fullscreen
3. click setting/list icon on bottom right
4. select Slideshow Time

EXPECTED OUTCOME:
allow setting of slideshow time period

ACTUAL OUTCOME:
application exits

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2a1pre)
Gecko/20090928 Firefox/3.5 Maemo Browser 1.4.1.21 RX-51 N900
Comment 1 mustali (reporter) 2009-12-12 00:05:16 UTC
~ $ canola     
1260568590.3786 ERROR connection:218:maybe_handle_message() Exception in
handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.5/dbus/connection.py", line 214, in
maybe_handle_message
    self._handler(*args, **kwargs)
TypeError: _update_battery_level() takes exactly 2 arguments (3 given)
CANOLA-THUMBNAILER: Pipe closed, exiting
Segmentation fault
Comment 2 mustali (reporter) 2009-12-12 00:06:17 UTC
snippet of output from verbose mode:

1260568708.7935 DBG_W plugin_manager:178:load() no plugin implements filter
'Controller/Options/Folder/Image'
1260568708.7954 DEBUG controller:122:get_controller_class_for_model_type()
looking for controller class with filter 'Controller/Options/Folder' ...
1260568708.7980 DEBUG manager:168:get_class() looking for first class with
filter 'Controller/Options/Folder'
1260568708.7997 DEBUG manager:126:get_classes() looking for classes with filter
'Controller/Options/Folder'
1260568708.8466 DEBUG controller:126:get_controller_class_for_model_type()
found controller class with filter 'Controller/Options/Folder'!
1260568711.2209 DEBUG controller:144:get_controller_for_model() looking for
controller for model with filter
'Model/Options/Folder/Image/Fullscreen/Submenu/SlideshowTime' ...
1260568711.2235 DEBUG controller:122:get_controller_class_for_model_type()
looking for controller class with filter
'Controller/Options/Folder/Image/Fullscreen/Submenu/SlideshowTime' ...
1260568711.2255 DEBUG manager:168:get_class() looking for first class with
filter 'Controller/Options/Folder/Image/Fullscreen/Submenu/SlideshowTime'
1260568711.2292 DEBUG manager:126:get_classes() looking for classes with filter
'Controller/Options/Folder/Image/Fullscreen/Submenu/SlideshowTime'
1260568711.2315 DEBUG controller:126:get_controller_class_for_model_type()
found controller class with filter
'Controller/Options/Folder/Image/Fullscreen/Submenu/SlideshowTime'!
1260568711.2395 DEBUG model:292:load() loading
SlideshowTimeOptionModelFolder(name='Slideshow time', parent=True,
children=False) ...
CANOLA-THUMBNAILER: Pipe closed, exiting
Segmentation fault
Comment 3 Eduardo Lima (Etrunko) maemo.org 2009-12-14 21:50:16 UTC

*** This bug has been marked as a duplicate of bug 5517 ***