Bug 6863 - When a delivery report is received the conversation window opens again
: When a delivery report is received the conversation window opens again
Status: RESOLVED DUPLICATE of bug 6344
Product: Chat & Call & SMS
General
: 5.0/(1.2009.42-11)
: N900 Windows
: Medium enhancement with 1 vote (vote)
: ---
Assigned To: rtcomm@maemo.org
: communication-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-11 17:25 UTC by Geert
Modified: 2009-12-11 20:14 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Geert (reporter) 2009-12-11 17:25:42 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
1. Turn delivery report on
2. Send a text message
3. Close the conversation window before you receive the delivery report
4. When the delivery report is received the conversation window opens again.

EXPECTED OUTCOME:
Just the message that the message was delivered not the conversation window
opening again.

ACTUAL OUTCOME:
Message the the message was delivered and the just closed conversation window
open again

REPRODUCIBILITY:
9/1

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET
CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)
Comment 1 Andre Klapper maemo.org 2009-12-11 20:05:34 UTC
Thanks for reporting this.

(In reply to comment #0)
> EXACT STEPS LEADING TO PROBLEM: 
> 1. Turn delivery report on
> 2. Send a text message
> 3. Close the conversation window before you receive the delivery report
> 4. When the delivery report is received the conversation window opens again.

For future reference please provide exact steps, click by click.
This is too vague.

> EXPECTED OUTCOME:
> Just the message that the message was delivered not the conversation window
> opening again.

Well, if there was only a popup that goes away after 5 seconds it is easy that
the user maybe has not seen it.
Also, other phones have the same behaviour (at least my ancient Nokia 8310
has).
Comment 2 Geert (reporter) 2009-12-11 20:11:49 UTC
No it should definitely not come up again. Just like with all symbian phones it
should just give a message that the message was delivered. In case of the N900
it gives such a message in the same style you would see a message when you
start charging your phone for example but it also pops the conversation back
up.
Comment 3 Mikhail Zabaluev nokia 2009-12-11 20:14:10 UTC

*** This bug has been marked as a duplicate of bug 6344 ***