Bug 6840 - Game hangs phone when listening to music on exit. Needs reboot to restore.
: Game hangs phone when listening to music on exit. Needs reboot to restore.
Status: RESOLVED DUPLICATE of bug 5524
Product: SuperTux
General
: unspecified
: N900 Maemo
: Medium major (vote)
: ---
Assigned To: Valério Valério
: general
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-11 05:50 UTC by jessi3k3
Modified: 2009-12-11 12:13 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description jessi3k3 (reporter) 2009-12-11 05:50:24 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Start Media player and start playing some music
2. Start game
3. Exit the game through the in-game menu (select "Quit")

EXPECTED OUTCOME:
Game exits and returns to the task manager/desktop

ACTUAL OUTCOME:
Game does not exit. You are left with a black screen with a white mouse cursor.
You can move the mouse cursor and that's it. Hitting the power button and
selecting "end task" does not work. You can still select the task switcher (top
left) but you are still left with a black window with a white mouse. There is
no way to return to the desktop other than restarting the phone.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
Built-in Media Player

OTHER COMMENTS:
Similarly, when you have music playing and exit by selecting the big "X" in the
top right, the program hangs and prompts for a force exit. It's then that it
quits and returns you to the desktop.

Additionally, if you stop the music before attempting to exit the game (either
through the in-game menu or the "X") it will then exit properly.

I'm using the latest SuperTux 0.1.3-1.1maemo12

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.30 Safari/532.5
Comment 1 Valério Valério maemo.org 2009-12-11 12:13:36 UTC

*** This bug has been marked as a duplicate of bug 5524 ***