Bug 6839 - Phone network (2g/3g) mode not changable when data connection is active.
: Phone network (2g/3g) mode not changable when data connection is active.
Status: RESOLVED DUPLICATE of bug 6502
Product: Settings and Maintenance
Control panel
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low enhancement (vote)
: ---
Assigned To: unassigned
: control-panel-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-11 03:03 UTC by Ian Stirling
Modified: 2009-12-16 04:59 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ian Stirling (reporter) 2009-12-11 03:03:33 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Go to settings, force 3G mode.
2. Make 3g data connection active.
3. Go to settings, to reenable 2G/3G mode

EXPECTED OUTCOME:
phone is reconfigured so that it will connect to either 2g/3g
ACTUAL OUTCOME:
2g/3g selector is not selectable until data connection is closed.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

Not being able to select 2g/3g mode with an active data connection may be a
function of the hardware.

However, the UI should either store the users preference and activate it when
the data connection terminates (perhaps notifying the user that this will be
the case) or notify the user that the data connection must be closed before
changing this, and asking the user if they want to do this.

The current behaviour of simply making the mode selector unselectable for no
obvious reason is confusing.
Comment 1 Lucas Maneos 2009-12-15 17:42:48 UTC
(In reply to comment #0)

I assume N900 (the only cellular-capable hardware so far), but please do
specify hardware & version.

> 2g/3g selector is not selectable until data connection is closed.

I can confirm the behaviour, but I don't consider it a bug.  If the mode switch
were to happen it would have to drop the data connection (possibly in the
middle of data transfers, VoIP calls etc).  Best to let the user chose when to
drop the connection I think.

For comparison, is the mode switch available during a cellular voice call?  I
don't have a voice-capable SIM that works in the N900 to test at the moment.

> However, the UI should either store the users preference and activate it when
> the data connection terminates (perhaps notifying the user that this will be
> the case) or notify the user that the data connection must be closed before
> changing this, and asking the user if they want to do this.

Interesting suggestions, but more appropriate for brainstorm.  I don't seem to
have access to the MOVED resolution so just setting severity to enhancement for
now.
Comment 2 Jan Knutar 2009-12-15 19:19:19 UTC
IMO it is a bug that the UI does not let the user discover how to perform the
action of changing network mode. 

Should the user be required to know the details of the particular underlying
hardware/software implementation and the potential side-effects or
pre-requisites that changing network mode might have? If the answer to the
previous question is yes, then the User Guide should contain this information.
The user guide does not contain this information, and then this is at the least
a documentation bug, if the answer to the previous question was yes.

This bug is very closely related, most likely classifiable as a duplicate of
bug 6502: https://bugs.maemo.org/show_bug.cgi?id=6502
Comment 3 Lucas Maneos 2009-12-15 19:25:39 UTC
(In reply to comment #2)
> This bug is very closely related, most likely classifiable as a duplicate of
> bug 6502

Ah, thanks for spotting it, it is indeed a dupe.

*** This bug has been marked as a duplicate of bug 6502 ***