Bug 6835 - (int150408/int-151468) Phone contact viewer should allow selection of call type, and filter contacts accordingly
(int150408/int-151468)
: Phone contact viewer should allow selection of call type, and filter contacts...
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Call Application UI
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low minor with 3 votes (vote)
: Harmattan
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-11 01:41 UTC by Josh Triplett
Modified: 2010-06-21 10:59 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Josh Triplett (reporter) 2009-12-11 01:41:33 UTC
Not sure if I've picked the right product to report this against.

The phone application displays all contacts capable of voice calls.  (Or those
it thinks have that capability; bug 5732.)  If you choose the dial pad, you can
explicitly select the type of call: cellular or one of your VoIP-capable
accounts.  I'd like to have the same capability in the phone's contact viewer,
so I can select at the top what type of contact I want, including "Any"
(default), "Cellular", or one of my VoIP accounts.  Changing this selection
would filter the account list to only the contacts capable of the selected type
of call.
Comment 1 Josh Triplett (reporter) 2009-12-11 01:45:55 UTC
Indeed I have; reassigning to the call UI.
Comment 2 Quim Gil nokia 2009-12-15 09:27:04 UTC
Filed as minor bug in the internal bugzilla.
Comment 3 Neil MacLeod maemo.org 2009-12-15 14:07:47 UTC
The problem is that every contact is considered capable of receiving virtually
all types of communication, whether this is actually possible or not.

For example, bug 6375 assumes ALL phone numbers (mobile and landline) are
capable of receiving SMS, similarly ALL phone numbers are shown as capable of
receiving a Skype call when in reality this is the case only if the calling
user has signed up for the chargeable "SkypeOut" service (or the number is
free-of-charge).

Essentially the contacts list needs to make fewer "assumptions" about the
numbers that are entered and instead reflect the reality of the users
circumstances (eg. every single landline number in MY contacts list is
incapable of receiving SMS messages) but I do have SkypeOut so it's correct
that all phone numbers are potentially capable of receiving Skype (but this
won't be the case for all Skype users).

Before more advanced filtering of the Contacts list can be implemented, the
contacts list itself needs to have more intelligence about the numbers it
contains.

Possible dependencies: bug 6850, bug 6375, bug 6728, bug 5732.
Comment 4 Mikhail Zabaluev nokia 2009-12-21 12:30:01 UTC
This is not going to be fixed in Fremantle.
Comment 5 Andre Klapper maemo.org 2010-06-21 10:59:28 UTC
Fixed for Harmattan. WONTFIX for Maemo5.