Bug 6816 - (int140618/int-153218) OpenGL ES 1.1 should be supported
(int140618/int-153218)
: OpenGL ES 1.1 should be supported
Status: VERIFIED FIXED
Product: Core
general
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium critical with 21 votes (vote)
: 5.0/(3.2010.02-8)
Assigned To: unassigned
: core-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-10 17:03 UTC by Javier S. Pedro
Modified: 2010-07-10 03:07 UTC (History)
8 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Javier S. Pedro (reporter) 2009-12-10 17:03:44 UTC
SOFTWARE VERSION: 1.2009.42-2

EXACT STEPS LEADING TO PROBLEM: 
On a N900 device:
1. Install rootsh, open xterm, and execute, as root:
2. apt-get update
3. apt-get install libgles1-sgx-img

EXPECTED OUTCOME:
The package installs. OpenGL|ES 1.1 games work.

ACTUAL OUTCOME:
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  libgles1-sgx-img: Depends: opengles-sgx-img-common (= 0.20090218.55.9+0m5)
but 0.20090218.55.1+0m5 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a
solution).

The package is not installable.

REPRODUCIBILITY: always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

The package can be installed by forcing it (resulting in broken packages
everywhere) and then OpenGL|ES 1.1 applications and demos work.

Since this means OpenGL|ES 1.1 games cannot enter extras, setting normal
severity (OpenGL|ES 2.0 games work).
Comment 1 Andre Klapper maemo.org 2009-12-10 19:58:01 UTC
Confirming.
Comment 2 Mikko Vartiainen 2010-01-12 21:27:06 UTC
Works fine for me with 1.2009.44-1

Nokia-N900-42-11:~# apt-cache policy libgles1-sgx-img
libgles1-sgx-img:
  Installed: (none)
  Candidate: 0.20090218.55.9+0m5
  Version table:
     0.20090218.55.9+0m5 0
        500 https://downloads.maemo.nokia.com ./ Packages
        500 https://downloads.maemo.nokia.com ./ Packages
        100 /var/lib/dpkg/status
Nokia-N900-42-11:~# apt-cache policy opengles-sgx-img-common
opengles-sgx-img-common:
  Installed: 0.20090218.55.9+0m5
  Candidate: 0.20090218.55.9+0m5
  Version table:
 *** 0.20090218.55.9+0m5 0
        500 https://downloads.maemo.nokia.com ./ Packages
        100 /var/lib/dpkg/status
Comment 3 Mikko Vartiainen 2010-01-14 19:36:19 UTC
Works with PR 1.1 too

Nokia-N900-42-11:~# apt-cache policy libgles1-sgx-img
libgles1-sgx-img:
  Installed: 0.20091104.6+0m5
  Candidate: 0.20091104.6+0m5
  Version table:
 *** 0.20091104.6+0m5 0
        500 https://downloads.maemo.nokia.com ./ Packages
        100 /var/lib/dpkg/status
     0.20090218.55.9+0m5 0
        500 https://downloads.maemo.nokia.com ./ Packages
Nokia-N900-42-11:~# apt-cache policy opengles-sgx-img-common
opengles-sgx-img-common:
  Installed: 0.20091104.6+0m5
  Candidate: 0.20091104.6+0m5
  Version table:
 *** 0.20091104.6+0m5 0
        500 https://downloads.maemo.nokia.com ./ Packages
        100 /var/lib/dpkg/status
Comment 4 Andre Klapper maemo.org 2010-01-14 21:41:35 UTC
Currently the platform should not include support for OpenGL ES 1.1...
Maybe some(TM) stuff works though, don't know...


This has been fixed in package
opengles-sgx-img 0.20091104.14+0m5
which is part of the internal build version
2009.53-2
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 5 Mikko Vartiainen 2010-01-14 22:00:01 UTC
(In reply to comment #4)
> Currently the platform should not include support for OpenGL ES 1.1...
> Maybe some(TM) stuff works though, don't know...

Probably depends what is meant with platform. Current gles packages is from
nokia repository and known gles1 games (quake3, openarena) do work. Maybe not
being part of the platform means that if gles1 package is installed, SSU
doesn't work (as happened with PR 1.1). This potentially limits gles1 apps
entering Extras too.
Comment 6 Andre Klapper maemo.org 2010-02-16 14:06:45 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 3.2010.02-8 (also called "PR1.1.1"
sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 7 Javier S. Pedro (reporter) 2010-03-03 16:57:23 UTC
WORKSFORME now (and has since PR1.1).
Comment 8 Javier S. Pedro (reporter) 2010-05-25 18:23:43 UTC
Sorry gentlemen, regression:

1. Flash today's PR1.2 global image
2. Install rootsh, open xterm, execute
2. apt-get update
3. apt-get install libgles1-sgx-img

EXPECTED:
no errors.

ACTUAL OUTCOME:
  libgles1-sgx-img: Depends: opengles-sgx-img-common (= 0.20091104.6.1+0m5) but
0.20091104.34+0m5 is to be installed


Also on http://talk.maemo.org/showthread.php?t=51651&page=5 .

Repository contains both versions of opengles-sgx-img-common, but only 
0.20091104.6.1+0m5 version of libgles1 (well, that one and a useless months old
one); and both versions of libgles2. 

I'm pretty sure forcing everything will work much like with PR1.0.
Comment 9 Mikko Vartiainen 2010-05-25 21:11:44 UTC
This is a blocker for games like GLTron, Tuxrace, Teeworlds, Brain Party in
Extras and ioquake3, openarena, I have no tomatoes in extras-devel
Comment 10 F2thaK 2010-05-26 10:32:05 UTC
morons.
Comment 11 Mikko Vartiainen 2010-05-26 13:09:32 UTC
works for me as of today with PR1.2
Comment 12 Javier S. Pedro (reporter) 2010-05-26 18:42:27 UTC
Indeed. (I wonder if I can mark it as FIXED by myself?).
Comment 13 Sean Ntiforo 2010-05-26 21:04:01 UTC
Does not work for me in PR 1.2, which I was assuming this bug was was opened
for.
Comment 14 Jacob Pennock 2010-05-26 21:31:45 UTC
This still does not work for me in PR 1.2. You guy marked it as fixed while I
was asleep but I am still having the same issues:

The following packages have unmet dependencies:
  libgles1-sgx-img: Depends: opengles-sgx-img-common (= 0.20091104.6.1+0m5) but
0.20091104.34+0m5 is to be installed
E: Broken packages
Comment 15 Jacob Pennock 2010-05-26 21:50:12 UTC
I just re-flashed to PR1.2 again just to be sure. Now I can confirm that
everything does seem to be working now.
Comment 16 Andrew 2010-05-26 23:11:00 UTC
This is still broken for me in PR1.2
Comment 17 Andre Klapper maemo.org 2010-05-26 23:19:51 UTC
"Does not work for me" comments are not helpful.
At least **describe** what you've tried and what is not working.
Comment 18 Sean Ntiforo 2010-05-27 00:30:34 UTC
no, comments like "MORONS" is not helpful.  I have the same dependency issue
that was stated in the reproduction section of the bug.  Specifically for my
purposes, I can't install games and apps that have the opengles dependency. 
specific example:

apt-get install d1x-rebirth fail

The following packages have unmet dependencies:
d1x-rebirth: depends: libgles1-sgx-img (>=0.20092018.51+0m5) but it is not
going to be installed. 

Attempting to install the package libgles1-sgx-img results in the exact message
in teh bug report.  PR1.2.
Comment 19 Javier S. Pedro (reporter) 2010-05-27 00:42:27 UTC
(In reply to comment #18)
> no, comments like "MORONS" is not helpful.  I have the same dependency issue
> that was stated in the reproduction section of the bug.  Specifically for my
> purposes, I can't install games and apps that have the opengles dependency. 
> specific example:
> 

Are you _completely_ sure you ran apt-get update beforehand? If so, are you
using the Global release, or the UK one?
Comment 20 Sean Ntiforo 2010-05-27 01:21:34 UTC
(In reply to comment #19)
> (In reply to comment #18)
> > no, comments like "MORONS" is not helpful.  I have the same dependency issue
> > that was stated in the reproduction section of the bug.  Specifically for my
> > purposes, I can't install games and apps that have the opengles dependency. 
> > specific example:
> > 
> 
> Are you _completely_ sure you ran apt-get update beforehand? If so, are you
> using the Global release, or the UK one?
> 
I upgraded from the app manager.  Twould appear that despite nothing showing up
in the update section, and apt-get dist-upgrade resulted in a ton of packages
to upgrade.  Now its working.  Seems my problem was an incomplete ota upgrade
to 1.2.