Bug 6807 - (int-145380) Wrong default region in E-mail accounts dialog
(int-145380)
: Wrong default region in E-mail accounts dialog
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal (vote)
: 5.0/(20.2010.36-2)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-10 12:38 UTC by Nick Leppänen Larsson
Modified: 2010-10-25 17:12 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Nick Leppänen Larsson (reporter) 2009-12-10 12:38:01 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
Menu -> E-Mail -> (Menu bar) -> New Account -> Next ->

EXPECTED OUTCOME:
Region shows Sweden

ACTUAL OUTCOME:
Region shows Finland

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
ecoach, recorder, supertux, xchat, hermes, maemo-mapper, rdesktop, xournal,
vim, dataviz suite viewer, bounce

OTHER COMMENTS:
SIM-card in use is from the swedish operator Tele2, bought here in Sweden.
Location is Stockholm, Sweden.

Possibly somewhat related side note - the detected internet settings from the
SIM are using tele2.internet.no (instead of .se). Probably due to the fact
thats the old APN used when I bought the SIM-card.


User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.5)
Gecko/20091102 Firefox/3.5.5
Comment 1 Nick Leppänen Larsson (reporter) 2009-12-10 12:43:07 UTC
Forgot to add:

Regional settings:
Device Language: English (UK)
Reginal settings: Svenska (Sverige)

Date and time: Time zone GMT +1 (Stockholm, Sweden)

Hardware keyboard layout: Suomi, Svenska
1st language: Svenska (Sverige), Dictionary: Svenska (Sverige)
2nd language: English (UK), Dictionary: English (UK)
Comment 2 Andre Klapper maemo.org 2009-12-16 20:53:35 UTC
Thanks for reporting this. Interesting bug. :-)

(In reply to comment #0)
> Possibly somewhat related side note - the detected internet settings from the
> SIM are using tele2.internet.no

Sure that this should not be "internet.tele2.no" instead?
If so, can you please open More > X-Terminal, enter the command
         grep "internet.tele2.no" /etc/operator_settings
, mark the entire output (you can do that by using the "Arrow" button in the
toolbar), copy it (from the main menu), and post it here?

How old is that SIM card approxiamtely?
Comment 3 Nick Leppänen Larsson (reporter) 2009-12-16 21:30:21 UTC
(In reply to comment #2)
> Sure that this should not be "internet.tele2.no" instead?
Uh yeah, my bad :)

> If so, can you please open More > X-Terminal, enter the command
>          grep "internet.tele2.no" /etc/operator_settings
> , mark the entire output (you can do that by using the "Arrow" button in the
> toolbar), copy it (from the main menu), and post it here?

Nokia-N900-42-11:~# grep "internet.tele2.no" /etc/operator_settings
240     7       Tele2 NO        INTERNET        Tele2 Internet 
internet.tele2.no

> How old is that SIM card approxiamtely?
> 
Uh, I'm not sure, but it's at least 2 years, might be able to find some old
papers or such if necessary
Comment 4 Andre Klapper maemo.org 2009-12-17 01:49:51 UTC
This has been fixed in internal build version
2.2009.48
(Note: The first number is the branch, 2009 is the year, and the number after
is the week.)

Any future public update released with a later branch number and the year/week
later than this internal build version will include the fix.
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal exists at
  
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 5 Andre Klapper maemo.org 2009-12-28 16:10:40 UTC
According to reports in the duplicate this is NOT fixed. Reopening.
Comment 6 Andre Klapper maemo.org 2009-12-28 16:10:56 UTC
*** Bug 7312 has been marked as a duplicate of this bug. ***
Comment 7 Venomrush 2010-03-20 00:31:07 UTC
(In reply to comment #5)
> According to reports in the duplicate this is NOT fixed. Reopening.
> 

Setting to correct state.
Comment 8 Andre Klapper maemo.org 2010-07-08 14:33:38 UTC
For hackers that want to compile themselves: Fix is at
http://gitorious.org/modest/modest/commit/52c80b784c2fbdb090cf146ccaca94cd8bcfdbba


This has been fixed in package
modest 3.4.5+0m5
which is part of the internal build version
2010.26-8
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 9 Andre Klapper maemo.org 2010-10-25 17:12:24 UTC
The problem reported here should be fixed in the update that was released today
for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
sometimes). Please leave a comment if the problem is not fixed for you in this
update version.