Bug 6792 - (int-142486) FM radio transmitter does not play while USB cord is connected
(int-142486)
: FM radio transmitter does not play while USB cord is connected
Status: RESOLVED FIXED
Product: Multimedia
FM Transmitter
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 6 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: fmtx-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-10 02:04 UTC by Oli G. Håkansson
Modified: 2010-10-16 12:43 UTC (History)
19 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Oli G. Håkansson (reporter) 2009-12-10 02:04:17 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
Driving down the highway, playing music from the N900 on the car's audio
system. The device complains about battery being low and car charges is hence
plugged in.

1. Driving listening to FM transmitter music on car radio
2. Phone needs charging
3. USB cable is plugged in
4. FM transmitter disconnects and won't power on again

EXPECTED OUTCOME:
N900 charges and music keeps playing

ACTUAL OUTCOME:
N900 denies to charge while USB cable is plugged in.

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:
Not relevant

OTHER COMMENTS:
This is obviously thought out by Maemo team, since a yellow message appears
telling me that the transmitter can not be used while USB cable is plugged in. 

A absolutely rediculous decision by the team given that the battery drains
faster on the media player than most other applications, and will undoubtedly
need recharging.

If you're going to keep the USB port and transmitter from being used at the
same time you better add a separate power port to the device.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5)
Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Comment 1 Oli G. Håkansson (reporter) 2009-12-10 02:07:07 UTC
The above should have read 

ACTUAL OUTCOME:
N900 denies to use FM transmitter while USB cable is plugged in and charging.
Comment 2 Andre Klapper maemo.org 2009-12-10 12:36:47 UTC
(In reply to comment #0)
> EXACT STEPS LEADING TO PROBLEM: 
> Driving down the highway, playing music from the N900 on the car's audio
> system. The device complains about battery being low and car charges is hence
> plugged in.

Which model is this. DC-10 USB charger?
When plugging in that charger, is there the popup on the N900 asking you about
Mass storage / PC Suite mode? If so, which decision was made?

> ACTUAL OUTCOME:
> N900 denies to charge while USB cable is plugged in.

For future reference, an exact error message is welcome. I *assume* it is "FM
Transmitter cannot be used while USB is plugged. Unplug the USB to continue
using FM Transmitter."

> OTHER COMMENTS:
> This is obviously thought out by Maemo team, since a yellow message appears
> telling me that the transmitter can not be used while USB cable is plugged in. 
> A absolutely rediculous decision by the team given

Any need to insult here if you have no clue what's going on?
(See, I can also insult. ;-)
This is a bug.
Showing that current message is WRONG.
Hence it's not a "decision" or something.
Comment 3 Oli G. Håkansson (reporter) 2009-12-10 13:52:10 UTC
No this is DC-6 car charger. As said I am driving down the road using the fm
transmitter and the N900 asks for juice. The N900 does not ask about mass
storage 
mode nor PC Suite mode. This is just a charger.

You are right about the message displayed :)
Comment 4 Tuoyo Ejueyitchie 2009-12-11 02:45:30 UTC
If you can't charge and use the FM transmitter at the same time then the FM
transmitter is virtually unusable for its most common use - whilst driving.
Comment 5 Andre Klapper maemo.org 2009-12-11 11:28:56 UTC
(In reply to comment #4)
> If you can't charge and use the FM transmitter at the same time then the FM
> transmitter is virtually unusable for its most common use - whilst driving.

I think that's clear to everybody - no news in that comment.
Comment 6 Andre Klapper maemo.org 2009-12-17 13:58:42 UTC
This has been fixed in package
fmtx-middleware 0.52+0m5
which is part of the internal build version
2009.51-5
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal exists at
  
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Darren Long 2009-12-23 20:25:31 UTC
I get no error message when I plug in a USB charger with the FM Tx active, I
just get a massive drop in signal strength on the FM receiver.  Is this the
same issue, or a different one?
Comment 8 Andre Klapper maemo.org 2009-12-28 14:23:56 UTC
Sounds quite similar to me...
Comment 9 Stephen Birch 2009-12-28 17:20:28 UTC
Here is a workaround for the FM power level drop, this should
help people until the new firmware is available.  Be warned, the
way it works is just a guess, it might be wrong.

The FM transmitter power level can be viewed thus:

  $ cat /sys/class/i2c-adapter/i2c-2/2-0063/power_level

This is changed via a dbus call when power is applied to
the micro USB cable, at that time the reported power level
drops from 112 to 88.

As a quick hack you can use a small program to override this
(run as root) so the FM transmitter runs at full power even when
charging:


#!/usr/bin/python

import time

FILENAME = '/sys/class/i2c-adapter/i2c-2/2-0063/power_level'

def main():
    while True:
        f = open(FILENAME)
        power = f.read()
        f.close()
        if power == '88\n':
            print 'Increasing power to 112'
            f = open(FILENAME, 'w')
            f.write('112')
            f.close()
        time.sleep(2)

if __name__ == '__main__':
    main()
Comment 10 Andre Klapper maemo.org 2009-12-29 16:56:17 UTC
*** Bug 7420 has been marked as a duplicate of this bug. ***
Comment 11 bastler 2009-12-31 16:40:58 UTC
May I ask why the transmitter reduces power level when a usb cable / charger is
plugged in? Thermal concerns?
Comment 12 Ian Stirling 2010-01-02 18:02:06 UTC
Almost certaintly the reason is regulatory concerns.

The USB lead will act as an antenna to some degree.
This will increase the emitted power of the tx, perhaps enough to violate
regulations - which are quite tight in some countries - in some circumstances.
Comment 13 Urho Konttori 2010-01-03 23:11:34 UTC
afaik, reason is that some usb chargers will act as antenna -> thus, increasing
the total output power. It's not possible to detect if this is the case -> it
must lower power always
Comment 14 Andre Klapper maemo.org 2010-01-14 13:40:28 UTC
(Fix not included in today's 2.2009.51-1 update => updating Version field)
Comment 15 Andre Klapper maemo.org 2010-01-16 17:35:56 UTC
*** Bug 8097 has been marked as a duplicate of this bug. ***
Comment 16 Andre Klapper maemo.org 2010-01-18 19:10:19 UTC
*** Bug 8223 has been marked as a duplicate of this bug. ***
Comment 17 Radu Capitanu 2010-01-18 19:23:01 UTC
(In reply to comment #2)

Hi!
I'm using DC-6 and I have 2.2009.51-1 firmware.
In my case  the N900 ask about
Mass storage / PC Suite mode and when I disconect the charger and try to
activate FM Transmision a pop-up is telling me that I can't broadcast with the
USB cable connected. The problem is that the cable is already disconnected so I
have to restart my phone to broadcast again.
Comment 18 bastler 2010-02-23 08:50:40 UTC
Now that the bug has been fixed:

Would it be possible to create some kind of user-accessible setup for these
kinds of regulatory things that the engineers cannot predict, maybe set to the
most restrictive setting by default? I can accept that reducing the power is
required in some locations of the earth, using some chargers, under some
conditions. But I find it a bit overkill to render the FM-TX useless for many
users because of this by enforcing it for everyone.

My charger cable for example does not seem to work as an antenna (at least not
in the 100MHz-frequency band), which unfortunately ment I could not listen to
music while driving through the Atacama desert last week even though it would
have easily been technically possible. I would have highly appreciated such an
option, because while high TX-power might be a concern in New York City or
Stockholm, in many parts of the world simply no one cares and the N900's
usability suffers for nothing...
Comment 19 Andre Klapper maemo.org 2010-02-23 11:34:46 UTC
*** Bug 9224 has been marked as a duplicate of this bug. ***
Comment 20 Andre Klapper maemo.org 2010-02-23 11:51:53 UTC
(In reply to comment #18)
> Would it be possible to create some kind of user-accessible setup

http://maemo.org/community/brainstorm/ should be a good place for this.
Comment 21 Andre Klapper maemo.org 2010-03-03 17:02:16 UTC
*** Bug 9333 has been marked as a duplicate of this bug. ***
Comment 22 Andre Klapper maemo.org 2010-03-15 20:55:36 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 23 Andre Klapper maemo.org 2010-05-17 17:16:20 UTC
*** Bug 10191 has been marked as a duplicate of this bug. ***
Comment 24 Thomas 2010-06-02 02:44:04 UTC
After updating to the new firmware version (10.2010.19-1) this bug still exist
for me.
Comment 25 Andre Klapper maemo.org 2010-06-02 10:52:33 UTC
(In reply to comment #24)
> After updating to the new firmware version (10.2010.19-1) this bug still exist
> for me.

Please provide more information, e.g. steps and exact hardware.
Comment 26 Ian Stirling 2010-06-02 13:33:43 UTC
I see the same problem as a couple of comments ago.
Also PR1.2 here.

Turn on FM transmitter in settings.
Plug in USB cable not connected to anything - works OK. (the n900 cannot detect
this)
Plug other end of USB cable into computer, a yellow banner 
'Unplug USB to continue using FM transmitter'

And the transmitter is turned off, until the cable is unplugged from the host
or the n900. This also happens when the headset is plugged in.

This does not happen with the charger.

This is clearly a bug, exactly what the bug is is another question.

From an 'efficiency as an antenna' point of view - the USB lead plugged into a
PC will be similar to USB plugged into a charger or a headset lead.

Arguably the correct way to handle this is to reduce power when any of these
events happens.

Turning off the FM transmitter when the USB cable is plugged into a host, but
not when plugged into a charger is clearly a bug.
Comment 27 Andre Klapper maemo.org 2010-06-09 16:12:45 UTC
*** Bug 10560 has been marked as a duplicate of this bug. ***
Comment 28 Andre Klapper maemo.org 2010-06-09 16:13:39 UTC
There are three users now stating that this does not work with a DC-6 charger
in PR1.2, but let me check back with Nokia before reopening this...
Comment 29 Mehul J. Rajput 2010-06-15 23:29:34 UTC
I also confirm that the bug exists. I have upgraded to PR 1.2, when charging
with usb, fm xmitter switch on gives error "usb device is connected".
Comment 30 Andre Klapper maemo.org 2010-07-08 14:25:13 UTC
Internal comments:

"Retested in 10.2010.19-1 SSU-ed device. Tested with DC-6 charger.
I am able to turn on FM transmitter with DC-6 charger connected. The only issue
is that the transmission is interrupted after connecting the charger."

"I guess that the USB cable/charger acts as an antenna bringing interferences
to
the FMTx. The signal from FMTx probably acts on the cable which in turn makes
the ground signal for the FMTx dancing. IMHO there isn't much we can do."
Comment 31 Andrew Christian Manson 2010-10-16 12:43:14 UTC
I have the same problem as comment #17. My in car charger asks for "Mass
Storage Mode" or "PC Suite" and I cannot charge while transmitting. The charger
I have is a Belkin in car USB adapter
http://www.amazon.co.uk/gp/product/B002C3AFHG/ref=oss_product . 

Can someone tell me is there a workaround or something that I can do to enable
transmission in this case? I am a developer and am willing to fix this if I can
be given direction. 

Cheers!