Bug 6771 - (int-119614) Currently active connection should be first in Connections list
(int-119614)
: Currently active connection should be first in Connections list
Status: VERIFIED FIXED
Product: Statusbar Widgets
Connection
: 5.0/(1.2009.42-11)
: All All
: Low normal with 1 vote (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: connection-applet-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-09 19:14 UTC by Ville Reijonen
Modified: 2010-01-14 12:26 UTC (History)
1 user (show)

See Also:


Attachments
Screenshot of the connections dialog with usability problem (92.35 KB, image/png)
2009-12-09 19:15 UTC, Ville Reijonen
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Ville Reijonen (reporter) 2009-12-09 19:14:16 UTC
SOFTWARE VERSION:
firmware 2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
Be in place where there are many wlans, for maximum confusion many saved ones.
Click statusbar -> Internet connection

EXPECTED OUTCOME:
A list of available wlans etc, where the active connection would be highlighted

ACTUAL OUTCOME:
List of connections, where the active connection can be anywhere on the list
differentiated only with text Disconnect.

REPRODUCIBILITY:
always

OTHER COMMENTS:
See the attachment for example, where the usability issue is evident.
Comment 1 Ville Reijonen (reporter) 2009-12-09 19:15:18 UTC
Created an attachment (id=1720) [details]
Screenshot of the connections dialog with usability problem
Comment 2 Andre Klapper maemo.org 2009-12-09 21:12:02 UTC
(In reply to comment #0)
> ACTUAL OUTCOME:
> List of connections, where the active connection can be anywhere on the list
> differentiated only with text Disconnect.

I wouldn't say "Anywhere", but alphabetically sorted" instead here. :)
Comment 3 Andre Klapper maemo.org 2009-12-16 04:27:52 UTC
I think it should simply be on top, as the first item, always.
Comment 4 Andre Klapper maemo.org 2009-12-16 14:44:53 UTC
This has been fixed in package
connui-common 2.74+0m5
which is part of the internal build version
2.2009.42-7
(Note that 2009 is the year and the number after is the week.)

A future public update released with or after this build version will include
the fix. Note that 1.2009.42-11 does not include this fix.
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.

To cover popular followup questions:
* Nokia does not announce release dates of public updates in advance.
* There is currently no access to these internal, non-public firmware versions.
A Brainstorm proposal exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 5 Andre Klapper maemo.org 2010-01-14 12:26:37 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.