Bug 677 - Connectivity may lead to reboots
: Connectivity may lead to reboots
Status: RESOLVED FIXED
Product: Connectivity
WiFi
: 2.0
: All All
: Medium critical with 2 votes (vote)
: ---
Assigned To: unassigned
: wifi-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2006-07-05 17:19 UTC by Victor Toni
Modified: 2008-02-29 11:20 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Victor Toni (reporter) 2006-07-05 17:19:12 UTC
It seems that the random reboots are somehow related connectivity/WLAN.
At first it seemed to be browser related but it happend also when the
application installer build up a connection to refresh th repository lists.
Using the device without connections seems pretty stable.
(BTW it would be quite unusual for an appliaction to kill the whole system, a
driver could be suspected to have this effect)
Comment 1 Jussi Kukkonen 2006-07-05 20:01:35 UTC
Confirming random reboots. As far as I remember this has happened while using 
browser, app manager, chat or presence applet -- never while using 'local' apps, 
like fbreader or marbles. Happened already in beta but not in 2005 versions.

setting severity to critical.

(In reply to comment #0)
> (BTW it would be quite unusual for an appliaction to kill the whole system, a
> driver could be suspected to have this effect)

That is intentional -- there is a daemon that reboots the device if it 'notices 
problems' (vital programs not answering, I guess). Not a bad idea in a consumer 
device, but lack of any system logs makes troubleshooting difficult...
Comment 2 Victor Toni (reporter) 2006-07-06 19:16:48 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > (BTW it would be quite unusual for an appliaction to kill the whole system,
> > a driver could be suspected to have this effect)
> 
> That is intentional -- there is a daemon that reboots the device if it 'notices 
> problems' (vital programs not answering, I guess). Not a bad idea in a consumer 
> device, but lack of any system logs makes troubleshooting difficult...
> 
It may be the daemon which initiates the reboots because usually just before
rebooting the download gets stuck.
I am still wondering what the reason is that the download "gets stuck" because
it didn't happen in the 2005 version.
Comment 3 Maemo QA (deprecated) 2006-07-11 20:18:17 UTC
Thanks for filing a report. It's difficult to tell which component is the fault
here. Have you find a way to reproduce this problem? 
Flasher option "--set-rd-flags no-lifeguard-reset" prevents reset.
Comment 4 Siarhei Siamashka 2006-10-10 13:53:12 UTC
This bug may be probably related to the following issue.

Initially reported as:
http://maemo.org/pipermail/maemo-developers/2006-September/005527.html

Can be relatively easy reproduced with 'memtester' program (all three developers
including me who tried to test it, managed to reproduce it):
http://maemo.org/pipermail/maemo-developers/2006-September/005608.html
http://maemo.org/pipermail/maemo-developers/2006-September/005620.html

Final comment which contains information, that lets us make a conclusion that
there is a high probability that it is actually related to wifi (buggy wifi
driver?):
http://maemo.org/pipermail/maemo-developers/2006-September/005633.html
Comment 5 Clemens Eisserer 2006-12-20 01:07:59 UTC
I also saw that problems - reboots while doing for what the product is intended
can hardly be called "production ready". 
Now after so many IT2005/2006 updates stability is still not really statisfying :-/
Comment 6 Tilman Vogel 2007-09-17 18:56:03 UTC
This bug may be related to bug 2006 for which I did some analysis and found a
workaround.