Bug 6743 - (int-154235) Screen sometimes flickers when scrolling through bookmarks triggers rubber banding
(int-154235)
: Screen sometimes flickers when scrolling through bookmarks triggers rubber ba...
Status: RESOLVED FIXED
Product: Browser
Bookmarks
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: Nagineni Sudarsana Babu
: browser-bookmarks-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-08 23:58 UTC by Loek Engels
Modified: 2010-05-09 23:19 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Loek Engels (reporter) 2009-12-08 23:58:27 UTC
SOFTWARE VERSION:
(Settings > General > About product)
5.0/(1.2009.42-11)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Open bookmarks
2. Swipe through your bookmarks such that you scroll past the last bookmark
3. The screen flickers prior to wrapping around to the top of the bookmark list

EXPECTED OUTCOME:
No flickering when wrapping around to the top of the bookmarks

ACTUAL OUTCOME:
I like the wrapping, however the flickering of the screen is annoying.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
Always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
It looks like there are to many redraws with the screen trying to determine
whether the last bookmarks should be redrawn or the topmost bookmarks should be
redrawn

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.15)
Gecko/2009102814 Iceweasel/3.0.6 (Debian-3.0.6-3)
Comment 1 Lucas Maneos 2009-12-09 11:27:02 UTC
I can't reproduce this as I get no wrap-around at all.  When I try to scroll
past the last bookmark I get a "rubberband" effect and the view stays at the
bottom of the bookmark list.
Comment 2 Loek Engels (reporter) 2009-12-11 10:22:43 UTC
Weird. I cannot reproduce it anymore either. Most likely because I have powered
the N900 off and on in between (before I had it powered off, I could always
reproduce it). I have tried a couple of scenarios since, but so far indeed I
have only encountered the expected the "rubberband" effect.
Comment 3 timeless 2009-12-11 13:26:39 UTC
REPRODUCIBILITY:
for one session, not after reboot
Comment 4 Andre Klapper maemo.org 2009-12-15 22:34:07 UTC
=> moreinfo until someone can reproduce
Comment 5 Loek Engels (reporter) 2010-01-10 22:10:08 UTC
I haven't been able to reproduce this anymore.
Comment 6 alextootchie 2010-01-17 04:24:20 UTC
The flickering of the bookmark list, with bouncing to the first bookmark,
appears randomly (but is very annoying) and only when the search/URL box is
present, not when you open the list from a web page ---> w/o search/URL box.
(Maemo 5 1.2009.51-1 <--- the problem persists)
Comment 7 timeless 2010-01-23 18:48:10 UTC
reporter: by 'wrapping', do you mean 'rubber banding'?
Comment 8 Loek Engels (reporter) 2010-01-24 10:45:37 UTC
Timeless: yes.
Comment 9 Andre Klapper maemo.org 2010-02-01 14:44:50 UTC
"Im not able to reproduce it on the internal versions 2010.04-8/04-9. Marking
as Alreadyfixed. If you will see this again please try to catch some
reproducible steps."
Comment 10 Andre Klapper maemo.org 2010-03-15 20:51:22 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 11 Loek Engels (reporter) 2010-05-09 23:19:29 UTC
I ran into this issue again in the 3.2010.02-8 version after having a bookmark
deleted en scrolling through the list of bookmarks.

I will check again if the issue is applicable after the PR1.2 release.