Bug 6739 - (int150903/int-165788) Cannot set Socks5 proxy in the Internet Connection Settings dialog
(int150903/int-165788)
: Cannot set Socks5 proxy in the Internet Connection Settings dialog
Status: RESOLVED FIXED
Product: UI Specification
General
: 5.0/(3.2010.02-8)
: All All
: Low normal with 8 votes (vote)
: Harmattan
Assigned To: Mikko Nurmi
: ui-specification-bugs
:
:
:
: 960
  Show dependency tree
 
Reported: 2009-12-08 22:27 UTC by Thomas Perl
Modified: 2010-06-21 10:46 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Thomas Perl (reporter) 2009-12-08 22:27:09 UTC
SOFTWARE VERSION:
5.0/(1.2009.42-11)

EXACT STEPS LEADING TO PROBLEM: 
1. Open the preferences of a WiFi network
2. Click through the settings until you reach the page with the "Advanced"
button
3. Click the "Advanced" button

EXPECTED OUTCOME:

Setting a Socks5 proxy is possible

ACTUAL OUTCOME:

Only HTTP, HTTPS, FTP and RTSP Proxies are supported

REPRODUCIBILITY:
always

OTHER COMMENTS:

The workaround at the moment is to use Firefox (Fennec) and tweak the prefs.js
file of it to use a Socks5 proxy. Ideally, the built-in browser (and all other
Internet-based apps) should support using a Socks5 proxy, too (e.g. when only
SSH is allowed, and then using the ssh "-D" option to create a local Socks
proxy).
Comment 1 Thomas Perl (reporter) 2009-12-23 17:41:49 UTC
Still an issue in 2.2009.51-1. Tested by having a look at the "Advanced"
settings for one of the WiFi networks saved in the device.
Comment 2 Andre Klapper maemo.org 2010-02-17 21:04:36 UTC
This is a WONTFIX for Maemo5. Now trying to find out about Maemo6...
Comment 3 daperl2 2010-02-22 04:49:30 UTC
Is there a simple explanation why it won't be fixed for Maemo 5?  This is the
only protocol in the API that the connection manager doesn't support.  Doesn't
it work?  Because if it does, it seems like an oversight to exclude such a
powerful feature.
Comment 4 Andre Klapper maemo.org 2010-05-05 15:09:20 UTC
This is planned for Harmattan - setting Target Milestone.
Comment 5 Andre Klapper maemo.org 2010-05-07 20:19:21 UTC
"Meanwhile you can already now configure the socks proxy into icd2 settings
gconf /system/osso/connectivity/IAP/<ICD_CONNECTION_ID>/ with the following
variables:
string   proxy_socks       the socks proxy host name
integer  proxy_socks_port  the socks proxy port number

These will be written into GNOME gconf settings as /system/proxy/socks_host
(string) and /system/proxy/socks_port (integer)."
Comment 6 Andre Klapper maemo.org 2010-06-21 10:46:33 UTC
Fixed and internally verified for Harmattan (the version after Maemo5).
WONTFIX for Maemo5.