Bug 6703 - (int-143191) MfE calendar sync causes dummy email sync account to appear
(int-143191)
: MfE calendar sync causes dummy email sync account to appear
Status: RESOLVED FIXED
Product: Synchronization
Mail for Exchange
: 5.0/(3.2010.02-8)
: N900 Maemo
: Low minor (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: activesync-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-08 05:00 UTC by Alex Smirnoff
Modified: 2010-03-15 20:56 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Alex Smirnoff (reporter) 2009-12-08 05:00:29 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 

1. Set up calendar-only sync with exchange (uncheck "sync email" box) 
2. Go to email application

EXPECTED OUTCOME:
Services list is unchanged

ACTUAL OUTCOME:
"Mail for Exchange" (though never updated) folder appears

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1)
Gecko/20090621 Remi/fc6 Firefox/3.5 GTB6
Comment 1 Andre Klapper maemo.org 2009-12-14 18:10:20 UTC
Thanks for reporting this.

Which Exchange server version is this about?

(In reply to comment #0)
> EXACT STEPS LEADING TO PROBLEM: 
> 1. Set up calendar-only sync with exchange (uncheck "sync email" box) 
> 2. Go to email application

This is missing some steps: Explain in detail what you do (e.g. tap on OK) and
what you see (e.g. message Connection Failed appears)
Comment 2 Alex Smirnoff (reporter) 2009-12-15 00:50:20 UTC
google. there are no failures as i do not sync email at all.
Comment 3 Andre Klapper maemo.org 2009-12-15 13:37:21 UTC
Using Google in MfE is currently unsupported. Adding dependency.
Comment 4 Jack Tanner 2009-12-29 06:29:40 UTC
I confirm this bug. My MfE for Google account syncs only calendar and contacts,
but the list of mail accounts (in Modest? not sure) includes the dummy MfE
account.
Comment 5 Andre Klapper maemo.org 2010-01-11 18:30:13 UTC
------- Comment #5 from Martin Dengler  2010-01-10 02:51 GMT+3 -------
the bug is not specific to which exchange server is set.

-------

So which ones did you test with?
Comment 6 Martin Dengler 2010-01-11 23:41:55 UTC
A supported exchange server is not necessary.  Anything that synchronises, even
partially, causes the problem.

I have tested with Exchange 2003 (supported AFAIK) and Google Mail (unsupported
AFAIK, but works for me).

Do you require additional detail to reproduce and/or mark as CONFIRMED?
Comment 7 Martin Dengler 2010-01-11 23:48:59 UTC
I just looked at #6343 that was added as a dependency.  In case it's possible
to misunderstand my feedback, I don't see #6343 as a dependency.  If more
detail is required to remove #6343 as a dependency please let me know.

(aside: do you not think this gmail-isn't-supported is a massive distraction? 
The mfe email account(s) just shows up in the email accounts list, even if it's
not (currently being) synchronised.  Nothing I've seen gives my any cause to
suspect the exchange server version is at all relevant.  Do you have any more
reason to suspect it *is*?)
Comment 8 Martin Dengler 2010-01-11 23:53:56 UTC
Sorry, I meant I've tested with Exchange 2007.  I have been reading
http://talk.maemo.org/showthread.php?t=35136 too much and had 2003 on the mind.
 At work we use 2007.
Comment 9 Alex Smirnoff (reporter) 2010-01-12 00:06:35 UTC
And seems that the bug is not cosmetic nor harmless, being combined with
another bug:
https://bugs.maemo.org/show_bug.cgi?id=5503
Comment 10 Andre Klapper maemo.org 2010-01-12 17:29:39 UTC
(In reply to comment #8)
> Sorry, I meant I've tested with Exchange 2007.

So you say that you do not use Google with MfE at all?
Comment 11 Martin Dengler 2010-01-12 22:23:49 UTC
The bug is present if one or more of the following obtain:

- an exchange 2007 mfe account is defined
- a google mfe account is defined
Comment 12 Andre Klapper maemo.org 2010-01-15 15:12:13 UTC
Removing Google dependency as per last comments.

So is this still an issue with Exchange Server 2003 or 2007 in Maemo5 version
2.2009.51-1?
Comment 13 Martin Dengler 2010-01-15 18:59:33 UTC
Yes (1.2009.44-1 though).
Comment 14 Rodrigo Linfati 2010-01-15 19:06:22 UTC
if you add an account on mail for exchange, but only sync calendar and/or
contacts... it always show a dummy account on email ( modest )

repro on PR1.0, PR1.0.1 and PR1.1
Comment 15 Andre Klapper maemo.org 2010-01-22 18:01:48 UTC
*** Bug 7532 has been marked as a duplicate of this bug. ***
Comment 16 Andre Klapper maemo.org 2010-02-17 14:55:24 UTC
This has been fixed in the internal build version
10.2010.05-13
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 17 Andre Klapper maemo.org 2010-03-15 20:56:09 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).