Bug 6700 - (int-139674) Semicolon in To field should be ignored when sending a message
(int-139674)
: Semicolon in To field should be ignored when sending a message
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-08 04:55 UTC by Kasper Sandberg
Modified: 2010-03-15 20:56 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Kasper Sandberg (reporter) 2009-12-08 04:55:05 UTC
SOFTWARE VERSION: 5.0/2009.42-11
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
Create a new mail, simply enter in an email address, and try to send, then it
will ask me to select contacts, even though i already wrote an email address..
it wont send then. press "back", and it saves a draft, go into drafts, and it
allows you to send it
When 

EXPECTED OUTCOME:
i can send the mail without first drafting it

ACTUAL OUTCOME:
i have to draft it

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
uhm.. adblock in firefox

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux; X11; x86_64)
KHTML/3.5.5 (like Gecko)
Comment 1 Andre Klapper maemo.org 2009-12-08 19:36:37 UTC
Thanks for reporting this.
This bug report isn't very useful because it doesn't describe the bug well. If
you have time and can still reproduce the bug, please read
https://bugs.maemo.org/page.cgi?id=bug-writing.html and add a more useful
description to this bug.

Please provide exact steps to reproduce:
1.
2.
3.
4.
5.

Also, which exact account type does this refer to? IMAP, POP? How is it set up?
Directly, or via Nokia Messaging Service?
What kind of email address did you enter and how ("simply enter in an email
address")?
What is the *exact* error message you get?
Comment 2 Kasper Sandberg (reporter) 2009-12-08 20:33:28 UTC
uhm, the type is imap, setup directly(i guess i choose the wrong component,
sorry, the bug guide said i should just guess if i werent sure).

1: setup some imap4 account directly (my server is dovecot, not that it should
matter, connected via ssl)
2: press the new message button
3: enter in some email address, could get test@hest.com (i wont post the real
one here, but just tested with test@hest.com)
4: fill out subject/message as you please
5: press the little yellow mail icon thinking it will send, but instead it pops
up a little popup at the bottom asking me to select contact, pressing "done" in
the popup does nothing unless i mark a contact, which i dont want to, as i dont
have the target email address in my contacts. i can then press outside the
popup to cancel it
6: press the "back" button to go out of the mail, thus saving it as a draft
7: go into drafts folder, open the mail, press the same yellow send icon, and
now it sends it perfectly.
Comment 3 Andre Klapper maemo.org 2009-12-14 17:15:50 UTC
(In reply to comment #2)
> pops up a little popup at the bottom asking me to select contact

What's the exact name of that Dialog?
(It's really way easier to search for existing bugs when using the actual terms
from the User Interface.)

I get a "Message has been moved to outbox" here when using Gmail IMAP to
reproduce this. :-/

So you just enter "test@hest.com"? Nothing else, like a comma or semicolon?
Comment 4 Kasper Sandberg (reporter) 2009-12-14 20:55:42 UTC
i just figured out the problem based on your input.

the problem is that i didnt use the "close osk" button in the upper right
corner, but the return button, which then adds the semicolon, and then it wants
another contact.

a little bit confusing interface, but i suppose not strictly a bug.

Now that i know, i dont care about this bug anymore, though for
userfriendlyness sake, i would perhaps suggest accepting "blabal@blabla.com; "
as a valid recipient..
Comment 5 Andre Klapper maemo.org 2009-12-14 23:32:06 UTC
Glad that it works for you now.
Changing summary to reflect the problem.
Comment 6 Neil MacLeod maemo.org 2009-12-15 00:06:17 UTC
(In reply to comment #4)
> Now that i know, i dont care about this bug anymore, though for
> userfriendlyness sake, i would perhaps suggest accepting "blabal@blabla.com; "
> as a valid recipient..
> 

Although it's not really that simple, but it does need fixing I agree as the
email recipient field validation is annoyingly inconsistent.

For example I have a contact with the first name "Work" (no last name) to which
I have assigned my work email address - sometimes I wish to forward emails I
receive "at home" to my work address during the day.

So if I send an email with the word "work" in the "To:" field the email will be
sent OK (and received at my work email address).

But if I specify "work;" then Modest complains "No matching contacts found".
Yet if I specify "work; " then it matches the contact, expands the email
address and send the mail just fine.

So the following work fine:
     "work" (Matches to a contact)
     "work; " (Matches to a contact)
     "abc@domain.com" (email sent immediately)
     "abc@domain.com;" (email sent immediately)

But the following don't work:
     "work;" (no matching contact error)
     "abc@domain.com; " (List of all contacts displayed, choose one and the
email is sent to abc@domain.com and also the selected contact, so modest
probably thinks the space is the name of a contact that needs matching and
expanding)
Comment 7 Sergio Villar Senin 2009-12-15 13:27:02 UTC
I have just committed the fix. We now ignore empty addresses when checking
names.

Fixed in
master a094da1b7109a8be357c9d9e94cf85af8625829d

Thx for reporting!!!
Comment 8 Andre Klapper maemo.org 2009-12-18 13:49:32 UTC
Only fixed for the last address, hence reopening.
Comment 9 Sergio Villar Senin 2009-12-18 17:54:05 UTC
fixed also remaining special cases

modest-3-2 (PR1.2): 12a672c559d983c4e49a7e4054ee14c0177ecb1c
master (community): 74a15bb6c7c53ed184a20c83c4fb9709d03d91e4
Comment 10 Neil MacLeod maemo.org 2009-12-24 01:02:31 UTC
(Not fixed in 2.2009.51-1)
Comment 11 Andre Klapper maemo.org 2010-01-22 12:52:41 UTC
Fixed in modest 3.2.9-1+0m5 which is part of the internal release version
2010.03-12
Comment 12 Andre Klapper maemo.org 2010-03-15 20:56:22 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).