Bug 6687 - (int-150626) Calendar (and Calendar desktop Widget) can take up to 30 seconds to become responsive when a lot of Smart Calendar items are present
(int-150626)
: Calendar (and Calendar desktop Widget) can take up to 30 seconds to become re...
Status: RESOLVED FIXED
Product: Calendar
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 4 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: calendar-general-bugs
:
: performance
:
:
  Show dependency tree
 
Reported: 2009-12-07 20:56 UTC by Tim Samoff
Modified: 2010-04-09 11:12 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Samoff (reporter) maemo.org 2009-12-07 20:56:47 UTC
SOFTWARE VERSION:
2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Make sure several Smart Calendar items are present in an active Calendar
(thanks to the Hermes app, I have over 700 birthdates grabbed from Facebook).
2. Launch the Calendar (or return to a desktop panel that contains the Calendar
widget).

EXPECTED OUTCOME:
A little delay for refresh is expected, but mine takes up to 30 seconds,
sometimes triggering the "unresponsive" dialog box (fyi, if I click "No" in
this dialog -- so the app isn't forced to quit, the app will respond after a
time).

ACTUAL OUTCOME:
Long waits and unresponsiveness.

REPRODUCIBILITY:
always
Comment 1 mobile.lloyd 2009-12-19 00:06:08 UTC
I have similar problem. Calendar is very unresponsive. I have 800+ contacts and
am synching 1 month of calendar items with outlook 2007. 

Switching between calendar views takes a long time. 10+ seconds.

In agenda view, calendar items will not scroll. In week view, calendar will not
scroll to next week with stylus swipe. Pressing arrow key produces delayed
scroll taking 5 seconds.

Alarms due to calendar items will cause phone to freeze with the alarm
stuttering in a loop. Hard reset required.
Comment 2 Thomas MIGLINCI 2009-12-24 14:35:50 UTC
observed with top, /usr/bin/Calender consumes between 45% and 75% percent of
CPU-time - and, my asumption, also battery-life....
Comment 3 William Watte 2009-12-30 15:25:18 UTC
I think there is a dependency with bug 6576 and 7213.

I currently have a major problem with this because I do a daily sync with
Oulook (2003 SP3 in this case) and have many recurring meetings, that also
regularly get updated (agenda, meeting room).

My N900 is currently crashing every hour, because I get loads of reminders,
even of non-existing events (same as last 2 lines of Comment #1). Only
solution: remove battery!
This makes it "major" for me!

I also see /usr/bin/Calendar constantly taking +/- 60% of CPU power.
"kill" helps for 2 minutes, then it comes back.

While waiting for a real solution, can somebody please urgently provide me with
a workaround, e.g.:
+ Way of permanently disabling Calendar and alarm notifications
+ A manual way of deleting/cleaning the alarm-list (as the events don't appear
in the Calendar).

BTW: Tried full resynch with Outlook, but that didn't solve the problem.
Comment 4 William Watte 2009-12-30 16:47:03 UTC
After reading the description of bug 6909 , it triggered me that I indeed
recently changed the "Remove old items" setting in the Calendar.

I now put it back on "Never" and /usr/bin/Calendar has stopped eating up
processor usage (and my battery)!

Don't know yet if this also solves the rest of my problems (next "ghost" alarm
is only expected tomorrow), but I'll post more info when I have it.

At least, I think this is already usefull info for people having a "slow"
Calendar. By changing this setting, my Calendar works fast again.
Comment 5 Thomas MIGLINCI 2009-12-30 18:48:39 UTC
(In reply to comment #4)
> I now put it back on "Never" and /usr/bin/Calendar has stopped eating up
> processor usage (and my battery)!
> 
> At least, I think this is already usefull info for people having a "slow"
> Calendar. By changing this setting, my Calendar works fast again.

Thanx for this info - my N900 now works fast again, and hopefully with a longer
battery life-span.

Thomas
Comment 6 William Watte 2009-12-31 12:57:45 UTC
Unfortunately, this workaround did not solve the "ghost alarms", which I think
should be kept as the key problem in bug 6576 .

However, the workaround now allowed me to acknowledge all the alarms, without
having to remove the battery.

While it's still necessary to have a fix for this, the workaround works for me,
so I'm moving my vote to 6576.
Comment 7 Fredrik Wendt 2010-01-11 19:02:21 UTC
I have 287 birthdays in my "smart" calendar and that is not because of remotely
known people on Facebook. This makes it very close to impossible to arrange
meetings with people when you need to manually "sync" calendars of people
around the table (to find a date and time that works for everyone - I'm always
last to confirm/deny).
Comment 8 Andre Klapper maemo.org 2010-01-18 20:23:54 UTC
Is this still an issue in 2.2009.51-1?
Comment 9 Fredrik Wendt 2010-01-19 01:58:57 UTC
I'd say this is only partly fixed. Bug 7027 is still very present in
2.2009.51-1 - I have to turn the smart birthdays off to be able to use the
calendar efficiently (at an acceptable speed).
Comment 10 Tim Samoff (reporter) maemo.org 2010-01-19 03:27:14 UTC
(In reply to comment #9)
> I'd say this is only partly fixed. Bug 7027 is still very present in
> 2.2009.51-1 - I have to turn the smart birthdays off to be able to use the
> calendar efficiently (at an acceptable speed).
> 

Agreed.
Comment 11 Eero Tamminen nokia 2010-04-09 11:12:37 UTC
The birthday items performance issue is fixed in internal 10.2010.04-4 release.
The fix will be included into PR1.2 public release.