Bug 6685 - (int-149771) Generic pc105 layout is not supported
(int-149771)
: Generic pc105 layout is not supported
Status: RESOLVED WONTFIX
Product: Core
X Server
: 5.0/(3.2010.02-8)
: All Linux
: Low enhancement with 66 votes (vote)
: ---
Assigned To: unassigned
: x-server-bugs
: https://bugs.freedesktop.org/show_bug...
:
:
:
  Show dependency tree
 
Reported: 2009-12-07 19:58 UTC by Valério Valério
Modified: 2011-01-18 16:31 UTC (History)
13 users (show)

See Also:


Attachments
Maemo specific modifications for scratchbox. (2.96 KB, patch)
2009-12-11 20:20 UTC, Rami Ylimaki
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Valério Valério (reporter) maemo.org 2009-12-07 19:58:04 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
1. Enable the support for Bluetooth keyboards -
http://wiki.maemo.org/Fremantle_Unsupported_Bluetooth_profiles#HID_host_.28i.e._support_for_Bluetooth_keyboards.29
2. Connect a Bluetooth keyboard to the N900.


EXPECTED OUTCOME:

For a generic keyboard the pc105 layout should be assigned.

ACTUAL OUTCOME:

Since the generic pc105 layout is not present, the SU-8 layout is assigned to
the generic keyboard and the keyboard can't be used in a proper way (only the
letters 'work out of the box').

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
I know that HID profile is not supported in Maemo5, but this issue prevents the
community from supporting the profile. Please don't close the bug just for this
reason.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.15)
Gecko/2009102815 Ubuntu/9.04 (jaunty) Firefox/3.0.15
Comment 1 Quim Gil nokia 2009-12-09 07:35:32 UTC
"The first step is to upstream our xkeyboard-config changes so that people can
use the full xkb-data debian packages without any missing files. Current Maemo
specific xkb-data package is missing a lot of files because we had to save disk
space on the device. The upstreaming work happens here:

https://bugs.freedesktop.org/show_bug.cgi?id=25507

I'll let you know when it's done. The upstream maintainer Sergey Udaltsov
already gave a green light for this and he will accept Maemo specific changes
to the upstream."
Comment 2 hex 2009-12-10 03:48:13 UTC
I agree - a must have for all of us who use (or used) other Maemo tablets and
were looking for this to replace.

Plenty of devices on the market support BT keyboards and I'm surprised the N900
shipped with no support and no plans to support. Especially since a good
portion of adopters are going to be N-tablet users.

This is one of those 'features' it didn't even cross my mind to research
considering the lineage. I wish I had known the 'no support' issue before fully
committing to it.

Not saying this to make this a complaint, but provide a customer perspective.
Adding things like this help differentiate (or keep in line) with the market
and what's already available or coming available. What may be viewed as minor
(which I am seeing a lot in here) might not be especially when you aggregate
all the 'minor' considerations it becomes a problem.

Personally, I think this should be more than low priority. But, that's just me
getting tired of typing on its not-that-great slide out.
Comment 3 Rami Ylimaki 2009-12-11 20:20:00 UTC
Created an attachment (id=1736) [details]
Maemo specific modifications for scratchbox.

Hi,

Below are instructions on building a new xkb-data package that isn't missing
any mappings.

# Clone the repository that is used on debian.
git clone git://git.debian.org/pkg-xorg/data/xkb-data.git
# Get latest stuff from upstream. The Maemo layouts were added just recently so
# they haven't made it to the debian repository yet. You don't need this step
# anymore when debian makes a new release of this package.
cd xkb-data/
git pull git://anongit.freedesktop.org/xkeyboard-config master
# Apply the attached patch. It contains changes needed to build the package in
# scratchbox for Maemo 5.
git am 0001-Maemo-specific-changes-to-make-the-package-build-in.patch
# Now log into scratchbox and build the package.
dpkg-buildpackage -b -rfakeroot

Finally copy the resulting xkb-data_1.7-2_all.deb on the device and possibly
reboot.

The upstream doesn't contain all Maemo specific xkb-data changes yet. There are
some multi-layout related changes that you don't get with the instructions
described above. However, these changes shouldn't be important, because the
Maemo 5 user space isn't using multi-layouts. The multi-layout changes were
made so that we could later support languages with multiple alphabets (like
Russian) more easily. These changes will be pushed later when there is time to
modify them for upstream, but you probably don't need those changes right now.

Please report any problems with the package. I have tested the package very
quickly and didn't notice any obvious problems. I haven't tested reverting the
package back to the original yet so keep that in mind also.
Comment 4 Valério Valério (reporter) maemo.org 2009-12-14 14:26:14 UTC
Hi,

First thanks for the instructions and patch, everything worked as expected.
During the installation in the device I had the following error:

****
Nokia-N900-42-11:~# dpkg -i xkb-data_1.7-2_all.deb 
(Reading database ... 28224 files and directories currently installed.)
Preparing to replace xkb-data 1.5-2maemo11.1+0m5 (using xkb-data_1.7-2_all.deb)
...
Unpacking replacement xkb-data ...
Setting up xkb-data (1.7-2) ...
removal of /etc/X11/xkb failed
****

Downgrading the package works also without any problems:

****
Nokia-N900-42-11:~# dpkg -i xkb-data_1.5-2maemo11.1\+0m5_all.deb 
Selecting previously deselected package xkb-data.
(Reading database ... 28527 files and directories currently installed.)
Preparing to replace xkb-data 1.7-2 (using xkb-data_1.5-2maemo11.1+0m5_all.deb)
...
Unpacking replacement xkb-data ...
Setting up xkb-data (1.5-2maemo11.1+0m5) ...
****

After checked that the new layouts are in place, I connected my generic
Bluetooth keyboard and the system configured it again as the SU-8.

I tried to change the model and layout via "hildon-im-xkbtool -l us -m pc105
--id=4" but this tool seems to do nothing in maemo5, the same command works as
expect in maemo4. So I changed the layout directly with gconf, now I've: 

***
Nokia-N900-42-11:~# hildon-im-xkbtool -g
Internal keyboard:
Model: nokiarx51
Layout: us
Delay: 600
Interval: 50

External keyboard:
Model: pc105
Layout: us
Delay: 600
Interval: 50
*** 

But the system still can't recognize most of the keypresses, but receive them.

Any more hints or other ways to debug this ?

Thanks
Comment 5 Jeffrey Mark Siskind 2009-12-16 19:18:17 UTC
I found what I believe is another manifestation of this bug. It occurs with the
builtin N900 keyboard, not with the an external bluetooth keyboard. But I
believe it results from the changes to xkb.

If I ssh into a remote (Linux) machine from X Terminal on the N900 and run a
remote xcalc or xmaple then the blue shift key has no effect. It is impossible
to enter numbers of symbols either by pressing blue shift followed by a key or
by pressing blue shift together with a key. In either case, the keystroke
received by the remote app is the underlying unshifted key. I also tried remote
gv, xpdf, xterm, acroread, and matlab. It didn't happen with matlab but did
also happen with some of the others, I just don't remember which.
Comment 6 Jeffrey Mark Siskind 2009-12-16 19:18:59 UTC
I found what I believe is another manifestation of this bug. It occurs with the
builtin N900 keyboard, not with the an external bluetooth keyboard. But I
believe it results from the changes to xkb.

If I ssh into a remote (Linux) machine from X Terminal on the N900 and run a
remote xcalc or xmaple then the blue shift key has no effect. It is impossible
to enter numbers of symbols either by pressing blue shift followed by a key or
by pressing blue shift together with a key. In either case, the keystroke
received by the remote app is the underlying unshifted key. I also tried remote
gv, xpdf, xterm, acroread, and matlab. It didn't happen with matlab but did
also happen with some of the others, I just don't remember which.
Comment 7 Arne 2009-12-22 01:22:31 UTC
Hi!

When trying to send a Google wave from the N900 browser I notice that the shift
and blue shift keys do not work. From one of the other comments it could seem
that this bug is related to this problem?
If so, not being able to use Google waves from N900 I would consider a serious
bug!

Arne
Comment 8 Andre Klapper maemo.org 2009-12-28 12:52:28 UTC
Also see http://www.mail-archive.com/maemo-developers@maemo.org/msg22900.html :
"how to get bluetooth pc105 keyboards to work with N900" by Jeff
Comment 9 Michael 2009-12-28 15:51:08 UTC
This is a must-fix problem. In technical terms, the BT profile should simply
support a keyboard correctly and thus "delight" users trying to take that
route. In marketing terms, you can really promote the n900 as a netbook
replacement (at least for short trips) with full document editing (soon) and
mail handling. The BT keyboard connection is a much-overlooked, but must-have,
feature in a smartphone.
Comment 10 Lance Wex 2010-01-18 16:51:44 UTC
I am saddened and surprised to discover that the bluetooth keyboard I have used
with my N800 does not work at all with my N900. This lack of function weakens
the label 'mobile computer', or 'internet tablet', and makes the N900 more of a
neutered phone.
Comment 11 Andre Klapper maemo.org 2010-01-18 17:03:06 UTC
(In reply to comment #10)
> I am saddened and surprised to discover

Unhelpful comment for this bug report that does not add any additional value.
Please contact Nokia Customer Care if you're unhappy, but this is not a forum.
Thanks.
Comment 12 Alan Bruce maemo.org 2010-01-19 20:49:05 UTC
Re: comment #8: 

Please note that the proposed workaround will probably trigger bug 6365.
Comment 13 Jeffrey Mark Siskind 2010-01-23 20:58:58 UTC
(In reply to comment #12)
> Re: comment #8: 
> 
> Please note that the proposed workaround will probably trigger bug 6365.
> 
I have not noticed it. But I might be wrong.

See http://talk.maemo.org/showthread.php?p=490777#post490777 for an update.
Prior to this others were not able to replicate my my results. I believe this
fixes that.
Comment 14 Andre Klapper maemo.org 2010-02-22 12:26:43 UTC
Forwarding an internal comment and the "WONTFIX for Maemo5" decision:

"On Maemo 5, support for pc105 layouts can be achieved as follows.
- Get sources of xkb-data package from debian-unstable.
- Apply a scratchbox patch. This is needed because build and packaging tools
are obsolete on Maemo 5. Cross compiling in a proper environment (not
scratchbox) doesn't require any patches.
- Build the upstream package inside scratchbox.
- Install the package into device.

However, this doesn't solve the original problem, which is about making BT
keyboards work properly on Maemo 5. The XI extension of Maemo 5 X server
doesn't contain all XI2 support patches. Therefore there are problems with
modifier keys for example. This can't be fixed without updating the Maemo 5 X
server, which most likely isn't going to happen."
Comment 15 anomaly256 2010-04-20 16:11:41 UTC
IMO, this is really a no-brainer.

Who on earth thought dropping this would be a good idea for a 'mobile computer,
not a phone' platform?  What benefit can there possibly be from this?  It's not
like the generic kb profile take up much space on the rootfs.

Seems to me there was some miscommunication between the engineering departments
when it was decided the n900 was to be a mobile computer and not a phone.

I don't think the issue should be 'this will require unbreaking x11/hildon and
so won't be done for maemo5', I think it's more a case of 'This shouldn't have
been done in the first place!  For the love of god lets not make this mistake
again'

Otherwise, please stop calling this a mobile computer.  It borders on blatant
false advertising if you're going to cripple it needlessly and keep it stuck
BEHIND even other models of PHONE!

Sorry for my bit of a rant there but this is so incredibly short sighted that
it actually disgusts me.

Thanks for listening, I hope you heed it for next time.
Comment 16 Daniel Benoy 2010-04-20 16:35:16 UTC
I don't think this is an appropriate place to air grievances about Nokia's
marketing.

You may want to check out these mailing lists:
http://wiki.maemo.org/Community_mailing_lists
Comment 17 anomaly256 2010-04-20 17:11:41 UTC
You're probably right.  I guess I was trying to force some more thought into
the internal 'WONTFIX' decision hoping the nokia maintainers check these bugs
as I can't post to their internal bugs/threads and I'm sure now that they don't
care about the public lists/forums in any great decision-making amount.

I will check the community lists though, thanks.  And sorry for the noise.
Comment 18 Gregor Schaffrath 2010-05-05 01:20:34 UTC
This link might be of interest to folks reading this bug report:
http://wiki.maemo.org/Fremantle_Bluetooth_Keyboard_Layout
Note: depending on the layout, you'll need to copy the latin1 symbols, as well

Cheers!
Comment 19 Andre Klapper maemo.org 2011-01-18 16:31:53 UTC
Internal bug is closed as WONTFIX for Maemo5, see comment 14 - reflecting state
here.

MeeGo Handset is where the unstable development is taking place. If you are a
developer (not a "normal" user) feedback about / retesting on MeeGo Handset
issues is specially welcome, e.g. via the MeeGo bugtracker at
https://bugs.meego.com.
Please note that MeeGo for the Nokia N900 is unstable and by no means ready for
end-users. See http://wiki.meego.com/ARM/N900 for more information and be aware
of the risks of trying unstable software.