Bug 6675 - (int-150910) after failed pairing to bluetooth car kit bluetooth can't be turned on
(int-150910)
: after failed pairing to bluetooth car kit bluetooth can't be turned on
Status: RESOLVED FIXED
Product: Connectivity
Bluetooth
: 5.0/(1.2009.42-11)
: All All
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: bluetooth-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-07 18:24 UTC by Esa Heiskanen
Modified: 2010-01-14 12:28 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Esa Heiskanen (reporter) 2009-12-07 18:24:16 UTC
SOFTWARE VERSION: 1.2009.42.11
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Start pairing with Nokia CK-15W bluetooth car kit
2. Type pairing code
3. Pairing crashes

EXPECTED OUTCOME:
Pairing succeedes and I can start to use bluetooth car kit

ACTUAL OUTCOME:
paring crashes and bluetooth can't be turned on from settings. I can access
bluetooth settings menu, but changes there won't save.


REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
tried with two different devices. I thought bluetooth was broken from first but
same thing happened with second one too.

EXTRA SOFTWARE INSTALLED:

some extras, no dev or testing versions

OTHER COMMENTS:
I noticed that ck-15w isn't in supported devices list, but as bluetooth is
communication standard it should work. At least it shouldn't break bluetooth
permanently... 

if you need any debug info, let me know how to find it from device.


User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB;
rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 FirePHP/0.3
Comment 1 Johan Hedberg nokia 2009-12-07 19:45:08 UTC
(In reply to comment #0)
> I noticed that ck-15w isn't in supported devices list, but as bluetooth is
> communication standard it should work.

I agree. There shouldn't be any reason why this car kit shouldn't work.

> At least it shouldn't break bluetooth permanently... 

By "permanently" do you really mean permanently or just until the next reboot
of the device?

I suspect this might be related to a few known issues in the Bluetooth chip
firmware that you have in your version of the software. It could also be
related to a bluetoothd crash and the UI not being able to cope with the
restart of the daemon. Most of those issues should get fixed by the next update
to maemo5  but unfortunately I don't know exactly when it'll be publicly
available.
Comment 2 Esa Heiskanen (reporter) 2009-12-07 20:19:32 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > I noticed that ck-15w isn't in supported devices list, but as bluetooth is
> > communication standard it should work.
> 
> I agree. There shouldn't be any reason why this car kit shouldn't work.
> 
> > At least it shouldn't break bluetooth permanently... 
> 
> By "permanently" do you really mean permanently or just until the next reboot
> of the device?
> 
> I suspect this might be related to a few known issues in the Bluetooth chip
> firmware that you have in your version of the software. It could also be
> related to a bluetoothd crash and the UI not being able to cope with the
> restart of the daemon. Most of those issues should get fixed by the next update
> to maemo5  but unfortunately I don't know exactly when it'll be publicly
> available.

reboot doesn't help, so it seems that configuration file gets corrupted?

I did some future research:
- bluetoothd stops and starts without any errors. 
- hcitool scans ok. 
- My laptop (Mac) sees the phone (bluetooth address) but can't complete pairing

Is there some other thing to check? hcidump?
Comment 3 Johan Hedberg nokia 2009-12-07 20:28:09 UTC
(In reply to comment #2)
> Is there some other thing to check? hcidump? 

Yes. The output of "hcidump -XVt" when the failure occurs would be interesting.
You could also try playing with hciconfig. E.g. does "hciconfig hci0 reset"
help at all? Does "hciconfig -a" output anything suspicous (like errors)?
Comment 4 Esa Heiskanen (reporter) 2009-12-07 20:41:22 UTC
hciconfig doesn't show any errors (i changed BD address to XXs):

Nokia-N900-42-11:~# hciconfig -a
hci0:    Type: UART
    BD Address: XX:XX:XX:XX:XX:XX ACL MTU: 1017:4 SCO MTU: 64:1
    UP RUNNING PSCAN ISCAN 
    RX bytes:2266 acl:0 sco:0 events:96 errors:0
    TX bytes:10738 acl:0 sco:0 commands:72 errors:0
    Features: 0xbf 0xee 0x0f 0xc6 0x98 0x3d 0x59 0x82
    Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV3 
    Link policy: RSWITCH HOLD SNIFF PARK 
    Link mode: SLAVE ACCEPT 
    Name: 'EsaN900'
    Class: 0x00020c
    Service Classes: Unspecified
    Device Class: Phone, Smart phone
    HCI Ver: 2.1 (0x4) HCI Rev: 0xac LMP Ver: 2.1 (0x4) LMP Subver: 0x410b
    Manufacturer: Broadcom Corporation (15)

And hcidump -XVt with pairing attempt from my laptop:

Nokia-N900-42-11:~# hcidump -XVt
HCI sniffer - Bluetooth packet analyzer ver 1.42
device: hci0 snap_len: 1028 filter: 0xffffffff
2009-12-07 20:32:31.640167 > HCI Event: Connect Request (0x04) plen 10
    bdaddr 00:23:6C:A9:63:F8 class 0x38010c type ACL
2009-12-07 20:32:31.640350 < HCI Command: Accept Connection Request
(0x01|0x0009) plen 7
    bdaddr 00:23:6C:A9:63:F8 role 0x01
    Role: Slave
2009-12-07 20:32:31.641448 > HCI Event: Command Status (0x0f) plen 4
    Accept Connection Request (0x01|0x0009) status 0x00 ncmd 1
2009-12-07 20:32:31.885070 > HCI Event: Connect Complete (0x03) plen 11
    status 0x00 handle 11 bdaddr 00:23:6C:A9:63:F8 type ACL encrypt 0x00
2009-12-07 20:32:31.885101 > HCI Event: Max Slots Change (0x1b) plen 3
    handle 11 slots 5
2009-12-07 20:32:31.885192 < HCI Command: Read Remote Supported Features
(0x01|0x001b) plen 2
    handle 11
2009-12-07 20:32:31.886779 > HCI Event: Command Status (0x0f) plen 4
    Read Remote Supported Features (0x01|0x001b) status 0x00 ncmd 1
2009-12-07 20:32:31.887390 > HCI Event: Read Remote Supported Features (0x0b)
plen 11
    status 0x00 handle 11
    Features: 0xff 0xff 0x8f 0xfe 0x9b 0xff 0x79 0x83
2009-12-07 20:32:31.887451 < HCI Command: Read Remote Extended Features
(0x01|0x001c) plen 3
    handle 11 page 1
2009-12-07 20:32:31.888610 > HCI Event: Command Status (0x0f) plen 4
    Read Remote Extended Features (0x01|0x001c) status 0x00 ncmd 1
2009-12-07 20:32:31.889251 > HCI Event: Read Remote Extended Features (0x23)
plen 13
    status 0x00 handle 11 page 1 max 1
    Features: 0x01 0x00 0x00 0x00 0x00 0x00 0x00 0x00
2009-12-07 20:32:35.885192 < HCI Command: Disconnect (0x01|0x0006) plen 3
    handle 11 reason 0x13
    Reason: Remote User Terminated Connection
2009-12-07 20:32:35.886779 > HCI Event: Command Status (0x0f) plen 4
    Disconnect (0x01|0x0006) status 0x00 ncmd 1
2009-12-07 20:32:35.971862 > HCI Event: Disconn Complete (0x05) plen 4
    status 0x00 handle 11 reason 0x16
    Reason: Connection Terminated by Local Host
---

I could try to connect from phone to laptop if you can give me exact linux
command?

It seems that phones BT settings UI has lost connection, so it just cant ask
pin code? Can it be reinstalled?
Comment 5 Andre Klapper maemo.org 2009-12-16 01:43:43 UTC
Imported.
Comment 6 Andre Klapper maemo.org 2009-12-16 14:47:12 UTC
The issue could not be reproduced in the internal build version
2009.51-0
(Note that 2009 is the year and the number after is the week.)
Also, there have been lots of fixes after 1.2009.42-11 in this area. 

A future public update released with or after this build version will include
the fix.
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.

To cover popular followup questions:
* Nokia does not announce release dates of public updates in advance.
* There is currently no access to these internal, non-public firmware versions.
A Brainstorm proposal exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-01-14 12:28:15 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.