Bug 6575 - (int-142256) Tapping new Email notification does not bring up email message
(int-142256)
: Tapping new Email notification does not bring up email message
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 2 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-04 09:43 UTC by Venomrush
Modified: 2010-03-15 20:56 UTC (History)
8 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Venomrush (reporter) 2009-12-04 09:43:40 UTC
SOFTWARE VERSION:
As above

EXACT STEPS LEADING TO PROBLEM: 
1. Create an Nokia Messaging accoutn and add an email account to it. Setup
Nokia Messaging on the N900
2. Send an email to the email address added in Nokia Messaging
3. Wait for notification and tap the new email window in Task Manager

EXPECTED OUTCOME:
Brings screen to email

ACTUAL OUTCOME:
Brings screen to Nokia Messaging account where it lists all the accounts in
Nokia Messaging

REPRODUCIBILITY:
5/10
Comment 1 Andre Klapper maemo.org 2009-12-05 15:53:57 UTC
*** Bug 6601 has been marked as a duplicate of this bug. ***
Comment 2 Alex Smirnoff 2009-12-05 17:29:46 UTC
Not exactly duplicate: sometimes there is no new notification window at all,
but yes, it is the same bug.
Comment 3 Andre Klapper maemo.org 2009-12-08 18:08:52 UTC
Thanks for reporting this.
Comment 4 Uwe Kaminski 2010-01-06 08:53:08 UTC
This also happens to Exchange Mail accounts. Is this bug enough for them too?
Comment 5 Sergio Villar Senin 2010-01-12 21:05:25 UTC
Seems an old bug in the plugins. It was already fixed. You'll have to wait for
the next sw update.
Comment 6 Andre Klapper maemo.org 2010-01-13 18:17:51 UTC
This is most probably fixed in later internal versions (after the next release
called "PR1.1") as this could not be reproduced anymore.
Comment 7 Andre Klapper maemo.org 2010-01-19 12:29:46 UTC
*** Bug 6875 has been marked as a duplicate of this bug. ***
Comment 8 Andre Klapper maemo.org 2010-01-27 23:57:26 UTC
*** Bug 8089 has been marked as a duplicate of this bug. ***
Comment 9 Alan Peery 2010-02-24 19:10:45 UTC
Please reopen this bug.  I have had this message occur on 5 separate instances
of notification today, and I am on the 51-1 firmware.
Comment 10 Venomrush (reporter) 2010-02-24 19:20:03 UTC
(In reply to comment #9)
> Please reopen this bug.  I have had this message occur on 5 separate instances
> of notification today, and I am on the 51-1 firmware.
> 

Can you provide syslog?

See http://wiki.maemo.org/Documentation/devtools/maemo5/syslog  and
http://wiki.maemo.org/Documentation/devtools/maemo5#Installation for more
information.
If you are not used to Linux, after creating the syslog file you can copy the
syslog file to those folders that are visible in the Maemo File Manager by:
  * Starting X Terminal
  * cp /var/log/syslog /home/user/MyDocs/.documents/
After that you can find the file in the Maemo File Manager by going to Nokia
N900 > Documents.

Once syslog is provided (which has several instances you encountered), I'll
reopen the bug.

Thanks
Comment 11 Johan Compagner 2010-03-10 00:59:00 UTC
isnt this just expected or chosen behavior?

Are you sure that you click on the email notification when it notifies you that
there is ONE email? Then it should go to the email fine. But if that is a
notification for more then one email then it will just open Modest (the the
last window it was on)

Its not that i agree with this behavior, but in the current setup its the only
way to do it. Because to fix this, i think we need a global (new) messages
inbox where you then jump to.
Comment 12 Andre Klapper maemo.org 2010-03-15 20:56:20 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).