Bug 6570 - (int-143568) Double-tapping "Inbox" sometimes opens 'empty' Inbox
(int-143568)
: Double-tapping "Inbox" sometimes opens 'empty' Inbox
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 2 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
: 3762
:
  Show dependency tree
 
Reported: 2009-12-04 04:40 UTC by Tim Samoff
Modified: 2010-04-24 18:12 UTC (History)
3 users (show)

See Also:


Attachments
Screenshot of 'empry' Inbox (29.94 KB, image/png)
2009-12-04 04:42 UTC, Tim Samoff
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Samoff (reporter) maemo.org 2009-12-04 04:40:59 UTC
SOFTWARE VERSION:
2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Launch Modest
2. Tap on an account to enter the account folder view
3. Quickly double-tap Inbox to enter Inboc view
4. If emails appear in view, tap Back button and repeat step 3
5. Continue to try until you enter a view with no emails

EXPECTED OUTCOME:
Inbox always displays emails (if present).

ACTUAL OUTCOME:
Sometimes Inbox appears to be empty.

REPRODUCIBILITY:
7/10

OTHER COMMENTS:
In this case, I'm using IMAP and connecting to GMail, so I don't know if
IMAP/other server or POP3 will produce the same results.
Comment 1 Tim Samoff (reporter) maemo.org 2009-12-04 04:42:16 UTC
Created an attachment (id=1664) [details]
Screenshot of 'empry' Inbox
Comment 2 Max Edin 2009-12-05 18:56:08 UTC
I'm having the same problem, but almost every time I open modest and click on
an inbox when modest is still refreshing my inboxes are empty (I have three
IMAP accounts added currently). All have over 1 000 emails in the inbox.
Running the same software as you. I wonder if this bug is part of the one where
modest hangs/slows down increadibly when opening an Imap account with thousands
of mails in the inbox.
Comment 3 Tim Samoff (reporter) maemo.org 2009-12-05 18:59:56 UTC
(In reply to comment #2)
> I'm having the same problem, but almost every time I open modest and click on
> an inbox when modest is still refreshing my inboxes are empty (I have three
> IMAP accounts added currently). All have over 1 000 emails in the inbox.
> Running the same software as you. I wonder if this bug is part of the one where
> modest hangs/slows down increadibly when opening an Imap account with thousands
> of mails in the inbox.
> 

I'm thinking that this might be a different bug. The double-tapping issue can
occur with just a few emails in the Inbox --@and it doesn't occur with any
other IMAP folders. I've experienced the "continual refresh" issue as well, but
it occurs on a regular tap-through to the Inbox, not a double-tap.
Comment 4 Andre Klapper maemo.org 2009-12-07 13:45:01 UTC
Thanks for reporting this.

This has been fixed in the internal build version
2.2009.46-16 (Note that 2009 is the year and the number after is the week)
as a side effect of the fix that went in for bug 3762.

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
For your information, Nokia does not announce release dates of updates in
advance.
Comment 5 Andre Klapper maemo.org 2010-01-14 12:28:27 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 6 Tim Samoff (reporter) maemo.org 2010-01-14 15:46:43 UTC
Sorry. I can still make this happen in PR1.1.
Comment 7 Tim Samoff (reporter) maemo.org 2010-01-14 19:34:30 UTC
FYI, I can get this to happen with 38 emails in my Inbox.
Comment 8 Andre Klapper maemo.org 2010-02-09 01:14:45 UTC
Any chance to provide a test account?
Comment 9 Andre Klapper maemo.org 2010-04-24 18:12:23 UTC
Internal comment:
"This bug is working fine in a recent PR1.2 image.
Inbox shows progress animation,all downloaded headers are shown.
Hence marking as Resolved/Fixed."

Though this doesn't convince me I'm going to close this ticket and ask you to
verify (confirm or reopen) once PR1.2 is out. :-/