Bug 6530 - (int-140075) Drops WLAN connection to Linksys WRT610N after 10-15 minutes
(int-140075)
: Drops WLAN connection to Linksys WRT610N after 10-15 minutes
Status: CLOSED FIXED
Product: Connectivity
WiFi
: 5.0/(1.2009.42-11)
: All All
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: wifi-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-03 02:21 UTC by Ralph Angenendt
Modified: 2010-01-15 14:19 UTC (History)
2 users (show)

See Also:


Attachments
dmesg from when the connection gets dropped (1.13 KB, application/octet-stream)
2009-12-03 02:24 UTC, Ralph Angenendt
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Ralph Angenendt (reporter) 2009-12-03 02:21:12 UTC
SOFTWARE VERSION:

1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 

When using WLAN, the connection gets dropped after a while. If automatic
connection to 3G networks is enabled, the device will connect to the 3G
network.

The N900 connects against a Linksys WRT610N access point. 

EXPECTED OUTCOME:

N900 stays connected as long as it is in reach of said Router.

ACTUAL OUTCOME:

N900 gets disconnected.

REPRODUCIBILITY:

Always after around 10 to 15 minutes.

OTHER COMMENTS:

I tried fiddling with the WLAN options for that connections - e.g. setting
powersaving to Medium instead of Strongest. The outcome is still the same.
Comment 1 Ralph Angenendt (reporter) 2009-12-03 02:24:16 UTC
Created an attachment (id=1657) [details]
dmesg from when the connection gets dropped

The connection drops at

[20703.080474] slide (GPIO 71) is now closed

The lines before show that the connection has been opened, associated and
authenticated.
Comment 2 Andre Klapper maemo.org 2009-12-03 11:16:44 UTC
Thanks for reporting this.

Kalle, I highly assume that this is the same issue as int-140075 (N900 gets
deauthenticated sometimes when it sends data after being in idle mode for some
time). Do you agree or is more info needed here?


(In reply to comment #0)
> I tried fiddling with the WLAN options for that connections - e.g. setting
> powersaving to Medium instead of Strongest. The outcome is still the same.

Did you also try to completely disable Power Saving Mode?
(Also see bug 5708.)
Comment 3 Ralph Angenendt (reporter) 2009-12-03 13:04:20 UTC
(In reply to comment #2)
> (In reply to comment #0)
> > I tried fiddling with the WLAN options for that connections - e.g. setting
> > powersaving to Medium instead of Strongest. The outcome is still the same.
> 
> Did you also try to completely disable Power Saving Mode?
> (Also see bug 5708.)

Yes, disabling power saving seems to fix the issue (no disconnects during the
last 90 minutes).
Comment 4 Andre Klapper maemo.org 2009-12-08 17:29:03 UTC
Thanks!

This has been fixed in package
kernel 2.6.28-20094802+0m5
which is part of the internal build version
2.2009.48-5
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
For your information, Nokia does not announce release dates of updates in
advance.
Comment 5 Andre Klapper maemo.org 2010-01-14 12:28:13 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 6 Ralph Angenendt (reporter) 2010-01-14 23:52:51 UTC
The issue has been fixed for me with the firmware update.
Comment 7 Andre Klapper maemo.org 2010-01-15 14:19:50 UTC
Thanks for checking again!