Bug 6517 - (int-152496) MfE wont keep Exchange account updated
(int-152496)
: MfE wont keep Exchange account updated
Status: RESOLVED FIXED
Product: Synchronization
Mail for Exchange
: 5.0/(1.2009.42-11)
: All Maemo
: Low major with 5 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: activesync-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-02 21:14 UTC by Tero Ripattila
Modified: 2010-01-22 11:50 UTC (History)
6 users (show)

See Also:


Attachments
MfE syslog (62.94 KB, application/octet-stream)
2009-12-15 18:46 UTC, justinr
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Tero Ripattila (reporter) 2009-12-02 21:14:16 UTC
SOFTWARE VERSION:
Version 1.2009.42-11

PRECONDITIONS:
1. One's successfully setup an Exchange 2007 account.
2. Peak schedule in Settings - Connectivity - Mail for Exchange - Settings must
be set to "Always on"

EXACT STEPS LEADING TO PROBLEM: 
1. Send an email to yourself, no matter whether to use your laptop or N900 to
perform this

EXPECTED OUTCOME:
1. Have the email delivered to your device instantly or in minutes anyway

ACTUAL OUTCOME:
1. Nothing gets delivered to inbox unless I manually invoke "Synchronize
manually" in Settings - Connectivity - Mail for Exchange or choose "Send &
Receive" in the main menu of email application.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
account-plugin-butterfly
Documents to Go Viewer Edition
Facebook widget and photo uploader
FM radio player
ForecaWeather widget
Hermes
mauku
mauku-widget
Microfeed backend
Ogg support
OpenSSH client
Personal dataplan monitor
Personal IP address
rootsh
tutorial-home-applet

OTHER COMMENTS:
I suspect you take advantage of EWS interface. Could this be related to the
notification service and client not receiving any notifications about incoming
mail?


User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us)
AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Comment 1 Tero Ripattila (reporter) 2009-12-02 21:15:27 UTC
I can provide a test account if needed.
Comment 2 Vitaly Repin 2009-12-02 22:15:04 UTC
Could you attach the log?

The procedure to take them:  https://bugs.maemo.org/show_bug.cgi?id=5597#c26

Thank you in advance.
Comment 3 Andre Klapper maemo.org 2009-12-08 17:19:41 UTC
-> moreinfo as per last comment.
Comment 4 Andrea Musci 2009-12-11 12:06:15 UTC
I confirm this bug: push synchronization does not work. Or better it works for
a limited amount of time and then it does not. To synchronize again, I need to
open my mailbox or force a manual synch.
It seems like it looses connection with the exchage server after a certain idle
time instead of keeping this connection always up.
Comment 5 justinr 2009-12-15 16:38:46 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 justinr 2009-12-15 16:41:06 UTC
I also have this problem. The MfE status window always shows:

Last synchronisation: Online
Status: Complete

Some times mail won't come in until you click Synchronise manually, other times
it works fine.
Comment 7 Andre Klapper maemo.org 2009-12-15 16:56:52 UTC
(In reply to comment #6)
> I also have this problem.

Please provide a log, as requested in comment 2. Thanks!
Comment 8 justinr 2009-12-15 18:46:36 UTC
Created an attachment (id=1768) [details]
MfE syslog
Comment 9 justinr 2009-12-15 18:47:06 UTC
Log attached - This shows MfE initially synching OK, last e-mail succesfully in
~16:00, then a manual sync at ~16:25.

Note the mailbox is now on Exchange 2010. We upgraded from 2007 last week, and
the exact same problem was occuring on 2007 - I can reproduce for you if
needed.

Justin
Comment 10 Jake Burns 2010-01-01 02:11:08 UTC
I have this exact same problem.  I am currently using Exchange 2007.  I am able
to synchronize once after rebooting.  Or I am able to manually synchronize the
exchange account, but it does not automatically update.
Comment 11 Paul Barrett 2010-01-06 10:33:33 UTC
I can confirm that i have the same problem
Comment 12 Andre Klapper maemo.org 2010-01-06 13:09:13 UTC
"I can confirm" comments are not helpful to fix the problem, instead just vote
and see comment 2 if you want to help here.
Comment 13 Andre Klapper maemo.org 2010-01-11 11:53:24 UTC
This has been fixed for the upcoming PR1.1 release (note that this is NOT the
1.2009.44-1 release).

Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 14 Andre Klapper maemo.org 2010-01-14 12:26:05 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 15 Andrea Musci 2010-01-15 16:48:26 UTC
It seems this problem is solved. But now it seems to drain battery a lot. I'll
test further and report.
Comment 16 Andre Klapper maemo.org 2010-01-15 17:13:39 UTC
(In reply to comment #15)
> But now it seems to drain battery a lot.

-> bug 6615 probably.
Comment 17 Andrea Musci 2010-01-22 11:50:41 UTC
No, it is not related to bug 6615: push notification drains my battery in 1
day. With every-30-min sync, it lasts for 2 days...