Bug 6506 - (int-149919) Hardware keys do not change volume when status menu in foreground & browser in background
(int-149919)
: Hardware keys do not change volume when status menu in foreground & browser i...
Status: RESOLVED FIXED
Product: Multimedia
Multimedia framework
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: multimedia-framework-bugs
:
:
:
: 6347
  Show dependency tree
 
Reported: 2009-12-02 17:58 UTC by Jan Knutar
Modified: 2010-03-15 20:55 UTC (History)
8 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jan Knutar (reporter) 2009-12-02 17:58:09 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 

1. Open browser
2. Tap lower right to bring browser out of fullscreen
3. Tap status area to get the status menu
4. press volume keys to adjust volume
5. tap outside status menu to return to browser

EXPECTED OUTCOME:

- Browser is opened.
- Browser switches out of fullscreen.
- Status menu appears. Browser is blurred out.
- Volume is adjusted.
- Status menu goes away. Browser is unblurred.


ACTUAL OUTCOME:

Browser is opened.
Browser switches out of fullscreen.
Status menu appears. Browser is blurred out.

* Nothing happens when pressing volume keys.

Status menu goes away. Browser is unblurred.

* Zoom has been changed in browser.

REPRODUCIBILITY:
Always

OTHER COMMENTS:

The browser grabs the volume keys for zooming normally, but when the user taps
the status area and the status menu is visible, the browser isn't really the
main focus of the user, one of the most prominent UI elements visible (not
counting blurred browser) is the volume slider, it would make sense that the
volume keys would now be directed to the status menu and the volume slider in
the status menu, instead of going to the browser that is blurred out and
sitting in the background.
Comment 1 Venomrush 2009-12-05 16:55:23 UTC
> EXACT STEPS LEADING TO PROBLEM: 
> 
> 1. Open browser
> 2. Tap lower right to bring browser out of fullscreen
> 3. Tap status area to get the status menu

What do you mean by 'status area' ?
I can't reproduce it as I don't quite understand the exact steps.
Comment 2 Jan Knutar (reporter) 2009-12-05 20:01:36 UTC
Status area, in upper left corner of the screen, to the right of the icon
consisting of two (or more) rectangles for swapping applications. 

The status area has the clock, signal strength meter, and battery meter, and
other small things depending on device state. 

If an application has focus, then to the right of the status area we have the
window titlebar, from where you can activate a program's own menu. Further to
the right of this, in the right upper corner, is the close "X" button.

When I tap the status area, I get a menu that covers a little less than the top
half of the screen. It has the battery icon "Battery", a speaker icon with a
volume slider, "Clock & Alarms" button, "Profile" button, "Internet connection"
button, "Bluetooth" button, and sometimes more buttons.

Whatever application was open before is blurred out when activating this menu.

When you start the browser, you initially see the bookmarks. The status area is
still visible at this point, and adjusting volume works. Tap a bookmark to
launch the real browser. The browser is fullscreen, and the status area is no
longer visible. Tap lower right to bring browser out of fullscreen, the status
area is now visible again. Tap the status area to bring out the status menu,
press one of the volume/zoom hardware keys on top of the device. Press the
rightmost one, for example, 10 times. Tap outside the status menu, to go back
to browser. Zoom has been changed in browser. Volume has not been changed.

Another related thing: If I tap the window titlebar (right of the status area),
and bring out the browser's menu (New Window, reload, paste, find on page, save
page as, downloads, details, options), then the hardware keys control volume.
Comment 3 Quim Gil nokia 2009-12-07 10:16:25 UTC
If you think the current behaviour is not consistent then this must be
addressed as a back. Note that I'm just triaging enhancement requests and I
haven't attempted to reproduce this case.
Comment 4 Andre Klapper maemo.org 2009-12-08 16:57:17 UTC
Thanks for reporting this.
I can reproduce this in internal version 49-3.

For future reference please only list the expected and actual outcome *AFTER*
performing ALL steps listed above. Thanks!

OTHER COMMENTS:
Works e.g. in Conversations view.
Comment 5 Lucas Maneos 2009-12-08 18:19:56 UTC
The status menu seems to inherit the foreground app's handling of the hardware
keys (in general it works if the foreground app is one that doesn't override
the zoom/volume keys and vice versa).
Comment 6 Neil MacLeod maemo.org 2009-12-26 14:02:57 UTC
Volume level doesn't change at all now (or browser zoom) in 2.2009.51-1 so the
change hasn't implemented expected bahviour only introduced new and seemingly
wrong behaviour. I suggest reopening this bug or open a new for the new
unwanted behaviour.
Comment 7 Neil MacLeod maemo.org 2009-12-27 19:29:59 UTC
Reopening as this bug is not fixed as per "expected outcome":

1. Browser is opened.
2. Browser switches out of fullscreen.
3. Status menu appears. Browser is blurred out.
4. Volume is adjusted.
5. Status menu goes away. Browser is unblurred.

Now instead of the volume adjusting as it should in step 4, the volume keys do
nothing at all when the status menu is visible on top of the browser.

In fact this behaviour can be repeated in x-term, however several other apps
(eg. photo viewer, email) still incorrectly intercept the status menu volume
key event and treat it as a zoom event.

Oddly, the Bookmarks application works as expected (ie. status menu volume key
event changes the volume level).

So we still have 3 different responses to the status menu volume key event
depending on the currently focused application.

This needs to be fixed across the board, irrespective of application: When the
status menu is visible, the volume keys should change the volume level
regardless of the currently focused application.
Comment 8 Neil MacLeod maemo.org 2009-12-27 19:31:32 UTC
Comment #7 relates to firmware 2.2009.51-1.
Comment 9 Andre Klapper maemo.org 2009-12-28 13:25:20 UTC
This has been fixed in package
maemo-statusmenu-volume 0.51+0m5
which is part of the internal build version
2009.52-5
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 10 Andre Klapper maemo.org 2010-01-04 16:33:47 UTC
*** Bug 7634 has been marked as a duplicate of this bug. ***
Comment 11 Andre Klapper maemo.org 2010-03-15 20:55:34 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).