Bug 6494 - (int-148916) Can't change desktop Background
(int-148916)
: Can't change desktop Background
Status: RESOLVED FIXED
Product: Desktop platform
Home
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low critical with 4 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: home-bugs
: http://talk.maemo.org/showthread.php?...
: crash
:
:
  Show dependency tree
 
Reported: 2009-12-02 01:10 UTC by niravegondhia
Modified: 2010-03-15 20:54 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description niravegondhia (reporter) 2009-12-02 01:10:29 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Click on area of homescreen that is empty so that Settings (spanner) icon
appears in Status bar.
2. Click on settings icon and then Change background
3. Attempt to change background

EXPECTED OUTCOME:
List of Themes comes up then browser for images folder then choose image.
ACTUAL OUTCOME:
Homescreen refreshes with some widget loss (so far Ovi Widget disappears).
Change Background option does nothing UNLESS USB CABLE IS CONNECTED TO DEVICE.
REPRODUCIBILITY:
(always unless USB cable is connected to Device & PC)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
This seems to be affecting some people & not others.
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.5)
Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Comment 1 niravegondhia (reporter) 2009-12-02 01:43:03 UTC
Okay.

Here's what I''ve found out.

This only occurs when you add a new .desktop file to the .images folder.

When I don't add a .desktop file to the .images file & add just the images, I
can pick the images up fine but not the image set.

Critical bug as desktop background changes seem not to work and this is an
integral part of the marketing of the device.
Comment 2 Urho Konttori 2009-12-04 10:06:22 UTC
We are working on this.
Comment 3 Andre Klapper maemo.org 2009-12-08 15:52:26 UTC
(In reply to comment #2)
> We are working on this.

Urho, do you know an internal ID for this to set in the Alias field here
(int-xxxxxx)?
Comment 4 Jan Arne Petersen 2009-12-09 18:10:10 UTC
The image files in the .desktop file need to be absolute paths currently
(without the upcoming fix).
Comment 5 Will Thompson 2009-12-09 18:28:21 UTC
(In reply to comment #3)
> Urho, do you know an internal ID for this to set in the Alias field here
> (int-xxxxxx)?

It's 148916.
Comment 6 Andre Klapper maemo.org 2009-12-09 22:36:48 UTC
Thanks.
Comment 7 Jan Arne Petersen 2009-12-09 23:07:48 UTC
(In reply to comment #4)
> The image files in the .desktop file need to be absolute paths currently
> (without the upcoming fix).

And they should not contain trailing spaces.
Comment 8 Andre Klapper maemo.org 2009-12-31 15:48:15 UTC
This has been fixed in package
hildon-home 0.3.63+0m5
which is part of the internal build version
2009.52-10
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 9 Andre Klapper maemo.org 2010-01-11 16:05:49 UTC
*** Bug 7538 has been marked as a duplicate of this bug. ***
Comment 10 Ryan Abel maemo.org 2010-01-19 15:52:42 UTC
*** Bug 8274 has been marked as a duplicate of this bug. ***
Comment 11 Andre Klapper maemo.org 2010-03-15 20:54:11 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).