Bug 6471 - when upgrading ScratchBox, packages can't be installed to /opt anymore
: when upgrading ScratchBox, packages can't be installed to /opt anymore
Status: RESOLVED DUPLICATE of bug 5674
Product: Development platform
SDK
: 5.0-final
: All All
: Low normal (vote)
: ---
Assigned To: Soumya
: sdk-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-01 13:15 UTC by Harald Fernengel
Modified: 2009-12-01 15:24 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Harald Fernengel (reporter) nokia 2009-12-01 13:15:18 UTC
SOFTWARE VERSION: 5.-final
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Update your ScratchBox from an older version
2. Try to install libqt4-maemo5-dev from extras-devel


EXPECTED OUTCOME:

Package is installed

ACTUAL OUTCOME:

Error message:

[sbox-Fremantle_arm: ~] > fakeroot apt-get install libqt4-maemo5-dev ...
...
...
Selecting previously deselected package libqt4-maemo5-dev.
Unpacking libqt4-maemo5-dev (from
.../libqt4-maemo5-dev_4.6.0~git20091125-0maemo1_armel.deb) ...
dpkg: error processing
/var/cache/apt/archives/libqt4-maemo5-dev_4.6.0~git20091125-0maemo1_armel.deb
(--unpack):
trying to overwrite `/opt', which is also in package base-files
dpkg-deb: subprocess paste killed by signal (Broken pipe) ...

REPRODUCIBILITY:

always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

works nice when doing a clean install of ScratchBox, bug only happens when
upgrading from an older SB version. I guess base-files does something to the
/opt directory, since it changed from being a directory to being a symlink.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us)
AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Comment 1 Andre Klapper maemo.org 2009-12-01 15:02:54 UTC
Hi Harald,
sounds like a duplicate of bug 5674 to me.
If you agree, feel free to mark it as a duplicate.
Comment 2 Harald Fernengel (reporter) nokia 2009-12-01 15:24:04 UTC

*** This bug has been marked as a duplicate of bug 5674 ***