Bug 6470 - (int-140880) Charger not recognized when plugged in when in Touch & Key lock
(int-140880)
: Charger not recognized when plugged in when in Touch & Key lock
Status: VERIFIED FIXED
Product: System software
mmc-and-usb
: 5.0/(1.2009.44-1)
: N900 Maemo
: Medium normal with 7 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: Kimmo Hämäläinen
: mmc-and-usb-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-01 12:50 UTC by Yves DESSERTINE
Modified: 2010-01-14 12:25 UTC (History)
9 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Yves DESSERTINE (reporter) 2009-12-01 12:50:48 UTC
Hello,

SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM:
1. Boot the N900
2. Put it in standby mode, i.e. lock screen and keyboard
3. Plug in the AC charger in the phone and in the wall socket

EXPECTED OUTCOME:
Orange LED flashing indicating charge in progress, or green LED indicating
charge is complete

ACTUAL OUTCOME:
Nothing happens, as if the charger where not plugged in.


REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
Only offical software

OTHER COMMENTS:
Workaround :
1. Unplug the charger
2. Put the phone in "active" mode (display the home screen)
3. Plug the charger in the phone.
==> Battery status icon shows battery is charging.


User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.5)
Gecko/20091102 Firefox/3.5.5


Regards,

Yves Dessertine
Comment 1 Andre Klapper maemo.org 2009-12-01 13:41:11 UTC
Thanks for reporting this.

I've just tried this with the internal software version 48-8 and I cannot
reproduce this. Touch & key lock is deactivated when a charger is plugged in.
A confirmation by a second user is welcome.

So after screen+keyboard are locked and you plug in the charger, and you remove
the Screen+Keyboard lock again, there is no "Charging" animation of the battery
in the statusbar I assume?

What is the exact name of the charger?
I have a "AC-10E" here according to what's printed on it.

Does this also happen when using the USB to PC connection for charging?

Leaving the non-working charger plugged in, can you go to "More > X Terminal"
and post the output of the following commands, if possible?
1)
      for i in vbus mode charger suspend mA; do echo -n "$i: "; cat
      /sys/devices/platform/musb_hdrc/$i; done 
2)
      cat /sys/class/i2c-adapter/i2c-1/1-0048/twl4030_usb/vbus

(Notes to myself: If 2) returns 0 this is a coresw-usb issue. Also see
int-140450)
Comment 2 Yves DESSERTINE (reporter) 2009-12-01 15:16:11 UTC
Hi again,

I'm impressed of how fast you answered :)

So after screen+keyboard are locked and you plug in the charger, and you remove
the Screen+Keyboard lock again, there is no "Charging" animation of the battery
in the statusbar I assume?

==> Yes I tried this and I confirm.


What is the exact name of the charger?
I have a "AC-10E" here according to what's printed on it.

==> I have an AC-10E too (it's printed on it).


Does this also happen when using the USB to PC connection for charging?

==> I'll test this when I am back home and keep you in touch (need my cable).


Leaving the non-working charger plugged in, can you go to "More > X Terminal"
and post the output of the following commands, if possible?
1)
      for i in vbus mode charger suspend mA; do echo -n "$i: "; cat
      /sys/devices/platform/musb_hdrc/$i; done 
2)
      cat /sys/class/i2c-adapter/i2c-1/1-0048/twl4030_usb/vbus

==> Unfortunately, I can't reproduce this right now, because (one more info):
When I lock screen&keybrd and plug the AC charger, the led now becomes green
(as expected -- normal behaviour I guess). So I can't reproduce it, maybe
because my battery is fully charged? 
I'll try again when my battery is approx. at half of charge and keep you in
touch.

(Notes to myself: If 2) returns 0 this is a coresw-usb issue. Also see
int-140450)


Yves DESSERTINE
Comment 3 Uwe Kaminski 2009-12-02 11:35:59 UTC
Thanks for this bug report. I noticed this sometimes but I was not able to find
out what was the reason for not charging the phone. I can confirm this bug
using a USB to PC cable. But as I am filling out this comment trying to use the
commandy posted by Andre I'm not able to reproduce this bug. :-/ But anyway
I'll send you the terminal output at the end of this comment.

Steps to reproduce the Problem (sometimes):
1. Boot the N900
2. Lock Screen and keyboard using the little switch on the device's right side
3. Plug in the USB cable into an USB port on the PC side.
4. Plug in the Micro USB plug into the phone's port

Device don't charge.

If you unlock the device's screen before conecting to the USB cable it will
charge.

REPRODUCIBILITY:
If it doesn't work one time it's easy to reproduce this again and again using
the description above.
If it works it also works for a second and third try.... It seems to help to
wait for a wile until a next try then.

------------------------
x-term Output:

> Leaving the non-working charger plugged in, can you go to "More > X Terminal"
> and post the output of the following commands, if possible?
> 1)
>       for i in vbus mode charger suspend mA; do echo -n "$i: "; cat
>       /sys/devices/platform/musb_hdrc/$i; done 

 ~ $ for i in vbus mode charger suspend mA; 
 > do echo -n "$i: "; 
 > cat /sys/devices/platform/musb_hdrc/$i; 
 > done 
 vbus: Vbus off, timeout 1100 
 mode: b_peripheral 
 charger: 0 
 suspend: 1 
 mA: 8 

> 2)
>       cat /sys/class/i2c-adapter/i2c-1/1-0048/twl4030_usb/vbus

 ~ $ cat /sys/class/i2c-adapter/i2c-1/1-0048/twl4030_usb/vbus 
 1 

> (Notes to myself: If 2) returns 0 this is a coresw-usb issue. Also see
> int-140450)

I also tried the first command sequence when the cable was plugged and the
device was charging:

 ~ $ for i in vbus mode charger suspend mA; 
 > do echo -n "$i: "; 
 > cat /sys/devices/platform/musb_hdrc/$i; 
 > done 
 vbus: Vbus off, timeout 1100 
 mode: b_peripheral 
 charger: 0 
 suspend: 0 
 mA: 500 

I hope this helps to find out the problem,
ciao Uwe
Comment 4 Yves DESSERTINE (reporter) 2009-12-02 16:15:43 UTC
Using the AC-10 charger:

> Leaving the non-working charger plugged in, can you go to "More > X Terminal"
> and post the output of the following commands, if possible?
> 1)
>       for i in vbus mode charger suspend mA; do echo -n "$i: "; cat
>       /sys/devices/platform/musb_hdrc/$i; done 

vbus: Vbus off, timeout 1100
charger: 0
suspend: 0
mA: 0


> 2)
>       cat /sys/class/i2c-adapter/i2c-1/1-0048/twl4030_usb/vbus

1

This is easy to reproduce. If the device detects the charger (i.e. it behaves
properly), you can do the following to reproduce:
1. Unplug charger from phone
2. Wait for less than 2 secs (approx) -- tested with approx 1 second
3. Replug the charger.

This triggers the anormal behaviour on my phone.

Yves
Comment 5 massimo.bilvi 2009-12-04 14:42:09 UTC
Confirmed. No charge by using a USB to PC cable.
Comment 6 Venomrush 2009-12-05 13:25:05 UTC
It could be defected cable that came with N900.

Since I have my N900, I never touch the USB that came with it nor the charging
power supply.

I used the N97's and never have this issue for the past 5 days having the
device.

Those who can repeatedly reproduce this, can you try with different cable?
Comment 7 Uwe Kaminski 2009-12-05 17:04:40 UTC
(In reply to comment #6)
> It could be defected cable that came with N900.
[...] 
> Those who can repeatedly reproduce this, can you try with different cable?

At least with 3 different USB cables and two different Chargers I'm able to
reproduce it. So I can't beleive the defect cable theory. But anyway thanks for
this idea :)
Comment 8 Edgardo Calabrese 2009-12-05 19:05:57 UTC
I have a similar issue.

I can't charge the n900 with my car charger (a generic microusb vodafone
branded), if the n900 was previously attacched to the pc.

To explain better:

I plug the n900 on the  pc cable, then  I plug the car charger cable and
nothing happens.

If I reboot the n900 then the car charger charges perfectly.

The car charger was used for months to charge a BB 9500 with no issue.

BTW the same behavior is absent if I use the main charger, no matter if the
Nokia provided one or the BB 9500 one.
Comment 9 Uwe Kaminski 2009-12-05 21:32:34 UTC
(In reply to comment #8)
> I have a similar issue.
> 
> I can't charge the n900 with my car charger (a generic microusb vodafone
> branded), if the n900 was previously attacched to the pc.

This sounds like a different bug to me. For me it does not play a role if the
device was connected to a Pc before. Could you please open  a new bug if you
can reproduce "your" bug again?

Thank you, Uwe
Comment 10 Andre Klapper maemo.org 2009-12-08 16:33:37 UTC
So I still haven't seen output here of
1)
      for i in vbus mode charger suspend mA; do echo -n "$i: "; cat
      /sys/devices/platform/musb_hdrc/$i; done 
2)
      cat /sys/class/i2c-adapter/i2c-1/1-0048/twl4030_usb/vbus
when it actually *happens* that it's not charging.

Highly welcome. :-)
Comment 11 Yves DESSERTINE (reporter) 2009-12-08 16:39:20 UTC
(In reply to comment #10)
> So I still haven't seen output here of
> 1)
>       for i in vbus mode charger suspend mA; do echo -n "$i: "; cat
>       /sys/devices/platform/musb_hdrc/$i; done 
> 2)
>       cat /sys/class/i2c-adapter/i2c-1/1-0048/twl4030_usb/vbus
> when it actually *happens* that it's not charging.
> 
> Highly welcome. :-)
> 

Hello,

My reply (Comment  #4) was what you needed :)

Yves Dessertine
Comment 12 tom hensel 2009-12-08 16:39:35 UTC
this occurs in even more cases:

- device reboots due to watchdog trigger (bug 6334) while charging: does not
resume charging when reboot is complete
- device is charging while switched off: does not resume charging when turned
on

shall i file seperate bugs for you my dear world leading company?
Comment 13 Uwe Kaminski 2009-12-08 16:43:01 UTC
(In reply to comment #10)
> So I still haven't seen output here of
> 1)
>       for i in vbus mode charger suspend mA; do echo -n "$i: "; cat
>       /sys/devices/platform/musb_hdrc/$i; done 
> 2)
>       cat /sys/class/i2c-adapter/i2c-1/1-0048/twl4030_usb/vbus
> when it actually *happens* that it's not charging.
> 
> Highly welcome. :-)
> 
> So I still haven't seen output here of
> 1)
>       for i in vbus mode charger suspend mA; do echo -n "$i: "; cat
>       /sys/devices/platform/musb_hdrc/$i; done 
> 2)
>       cat /sys/class/i2c-adapter/i2c-1/1-0048/twl4030_usb/vbus
> when it actually *happens* that it's not charging.
> 
> Highly welcome. :-)
> 

Please go to comment #3 and read again the xterm output part of the comment.
:-p
Comment 14 Uwe Kaminski 2009-12-08 16:44:29 UTC
(In reply to comment #12)
> this occurs in even more cases:
[...]
> shall i file seperate bugs for you my dear world leading company?

Yes this would be a big help. :)
Comment 15 Andre Klapper maemo.org 2009-12-08 17:55:24 UTC
(In reply to comment #11)
> My reply (Comment  #4) was what you needed :)

Oops, sorry. :-)

(In reply to comment #13)
> Please go to comment #3 and read again the xterm output part of the comment.

Ah. As you wrote "as I am filling out this comment trying to use the
commandy posted by Andre I'm not able to reproduce this bug." I expected the
output to not be from the failure case, but from a normal, working case. :-)

Anyway, this has been reproduced internally now.
Comment 16 Lucas Maneos 2009-12-08 17:59:30 UTC
(In reply to comment #3)
> I noticed this sometimes but I was not able to find
> out what was the reason for not charging the phone. I can confirm this bug
> using a USB to PC cable.

The USB data cable case is bug 6004.  FWIW I can reproduce that quite often,
but the device always starts charging when plugged in to an AC-10E or AC-10X
charger.

For Andre's questions (with data cable):

Nokia-N900-42-11:~# for i in vbus mode charger suspend mA; do echo -n "$i: ";
cat /sys/devices/platform/musb_hdrc/$i; done
vbus: Vbus off, timeout 1100
mode: b_idle
charger: 0
suspend: 1
mA: 0

Nokia-N900-42-11:~# cat /sys/class/i2c-adapter/i2c-1/1-0048/twl4030_usb/vbus
1
Comment 17 Andre Klapper maemo.org 2009-12-10 16:36:18 UTC
This has been fixed in package
kernel 2.6.28-20094201+0m5
which is part of the internal build version
2.2009.42-2
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Note that 1.2009.42-11 does NOT include this fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
For your information, Nokia does not announce release dates of updates in
advance.
Comment 18 Zack Morris 2009-12-16 01:54:31 UTC
I've had my phone on the wall charger for a few hours today, and the led
charging light is on, pulsing yellow, and the battery symbol is doing the
animation where it looks like it's being charged. However once I disconnect the
charger it shows low battery. I checked the battery status in the terminal with

lshal | grep percen 

and it gave me a report of 0 percent

I reset the phone twice and it's still doing this. Luckily I bought an external
charger and can charge my battery that way. However I don't want to have to
turn off my phone everytime I need a charge and take out the battery. The
battery appears to be charging when in fact it is not charging at all.

I just want to insure that this is indeed the bug that is being addressed here
even though I am charging via the wall charger.

Thanks for the help.
Comment 19 Uwe Kaminski 2010-01-01 15:53:58 UTC
(In reply to comment #18)
> I've had my phone on the wall charger for a few hours today, and the led
> charging light is on, pulsing yellow, and the battery symbol is doing the
> animation where it looks like it's being charged. However once I disconnect the
> charger it shows low battery. I checked the battery status in the terminal with

This sounds like an other issue. If there is the pulsing yellow light it
charges. In the case of the bug discussed here there is no yellow light and no
charging. Maybe your N900 is broken because it does not charge even if the
software wants to initiate this?

Beside of this I can verify that this bug is fixed. I wasn't able to reproduce
the bug using the steps described in this bug and it's comments.
Comment 20 Uwe Kaminski 2010-01-01 15:55:58 UTC
I was using 2.2009.51-1
Comment 21 Yves DESSERTINE (reporter) 2010-01-12 01:32:08 UTC
I want to reopen this bug.

I can still reproduce it with the provided USB cable and the 1.2009-44.1
firmware

1. Boot the N900 and wait
2. lock screen and keys
3. plug the USB cable into your running computer
4. plus the USB cable into the N900
5. If the phone charges, remove cable from the phone, wait approx. 10 secs and
plug again.

The problem is still there, IMHO.

Regards,

Yves Dessertine
Comment 22 Uwe Kaminski 2010-01-12 08:48:58 UTC
As written this is fixed in 2009.51-1.

Please feel free to reopen this bug if it appears in this or a later version.
Comment 23 Andre Klapper maemo.org 2010-01-12 13:58:15 UTC
Fix is not included in 1.2009.44-1. Fix is included in the next update.
Comment 24 Andre Klapper maemo.org 2010-01-14 12:25:55 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.