Bug 6460 - Problems with extras-devel repository on N900 ("No Hash entry in Release file")
: Problems with extras-devel repository on N900 ("No Hash entry in Release file")
Status: RESOLVED FIXED
Product: maemo.org Website
Repositories
: 5.0
: All Linux
: High blocker with 6 votes (vote)
: ---
Assigned To: Marcell Lengyel
: repositories@maemo.bugs
: http://lists.maemo.org/pipermail/maem...
:
:
:
  Show dependency tree
 
Reported: 2009-11-30 21:04 UTC by Anderson Lizardo
Modified: 2010-01-18 11:48 UTC (History)
14 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Anderson Lizardo (reporter) 2009-11-30 21:04:27 UTC
SOFTWARE VERSION: Maemo 5 (running on N900)

EXACT STEPS LEADING TO PROBLEM:

1) add extras-devel repository to /etc/apt/sources.list on the N900
2) run "apt-get update"

EXPECTED OUTCOME:

It should work without errors.

ACTUAL OUTCOME:

The following error is shown:

W: Failed to fetch
http://repository.maemo.org/extras-devel/dists/fremantle/Release  No
Hash entry in Release file
/var/lib/apt/lists/repository.maemo.org_extras-devel_dists_fremantle_Release
E: Some index files failed to download, they have been ignored, or old
ones used instead

And the repository indexes are not updated.

REPRODUCIBILITY: always

OTHER COMMENTS:

Originally reported on
http://lists.maemo.org/pipermail/maemo-developers/2009-November/022732.html

Strangely, this problem only happens on the N900. Scratchbox seems
happy with the incomplete Release file (probably the apt-get version
in Scratchbox ignores the error).
Comment 1 Marcell Lengyel maemo.org 2009-12-01 10:44:47 UTC
The repository has been reindexed.
Comment 2 Bas van Oostveen 2009-12-02 20:21:44 UTC
still got this problem. on 02-12-2009 19:20 cet

Fetched 481B in 6s (76B/s)                                                    
W: Failed to fetch
http://repository.maemo.org/extras-devel/dists/fremantle/Release  No Hash entry
in Release file
/var/lib/apt/lists/repository.maemo.org_extras-devel_dists_fremantle_Release

E: Some index files failed to download, they have been ignored, or old ones
used instead.
/home/user #
Comment 3 Anderson Lizardo (reporter) 2009-12-02 20:51:11 UTC
I can confirm that Release file is again truncated.

I'll reopen the bug for now.
Comment 4 Uwe Kaminski 2009-12-03 07:09:06 UTC
I also can confirm this bug. But I never get the same error message using:
apt-get update

Is there somebody who
* get this bug using 'apt-get update'? or
* get this bug not using the device (e.g. scratchbox on a pc)?
Comment 5 Marcell Lengyel maemo.org 2009-12-03 10:33:02 UTC
I have checked it again at 10:31 EET, and I could not reproduce it.
Comment 6 Bas van Oostveen 2009-12-03 12:06:55 UTC
(In reply to comment #5)
> I have checked it again at 10:31 EET, and I could not reproduce it.
> 

works for me aswell today, though i was assuming that the blocker might be set
because of some underlying problem which truncates the release file ?
Comment 7 Andre Klapper maemo.org 2009-12-03 12:22:29 UTC
Blocker because it blocks testing, as per definition.

I also ran into this yesterday, works fine for me again today.
Comment 8 makanakoeln 2009-12-03 12:31:15 UTC
i used apt-get instead. now it works fine again
Comment 9 Anderson Lizardo (reporter) 2009-12-03 12:58:40 UTC
Yes, now http://repository.maemo.org/extras-devel/dists/fremantle/Release is
again complete, last generated at "Thu, 03 Dec 2009 01:58:47 UTC".

But if the script that generates the file is not fixed, it will come up again
I'm afraid :/. It might be that some bug is interrupting the repository indexes
update at some point, because when I see the problem, there are ".bz2.new"
files in
http://repository.maemo.org/extras-devel/dists/fremantle/free/binary-armel/ as
well.

BTW, let me emphasize that the problem is *only* reproducible on the device,
probably because the internal scratchbox apt-get version is different from the
device and just ignores the incomplete Releases file.
Comment 10 Marcell Lengyel maemo.org 2009-12-04 13:54:43 UTC
The setup works like this: all repository management is done on the
garage.maemo.org server for the extras-* repos. Then it is synced over to
repository.maemo.org and served from there. There is nothing wrong with the
scripts as fas as I can tell, but rather with the fact that garage is on its
knees these days and sometimes the sync to r.m.o times out or does not finish
before the next sync starts. I will try to see if it is possible to make the
whole sync process more fool-proof, but the real fix for this issue will be
moving the servers to faster machines. Which is on going atm.
Comment 11 Anderson Lizardo (reporter) 2009-12-04 14:06:09 UTC
Hmm, if rsync is involved, it makes a whole sense now.

I think the problem is that rsync is running while the repository indexes are
still being updated. I suppose that's why we get the incomplete Release file
(which is generated before the indexes are updated, and the hashes are added
after), and .bz2.new files are left behind (generated by bzip2 during
compression).

Is it possible to change the sync script to check for the existence of these
.new files (or even better create a lock file for the whole sync process) so
that the sync is not attempted if a index update is in progress?
Comment 12 Marcell Lengyel maemo.org 2009-12-04 14:25:04 UTC
The lock files are already in the sync scripts. I think that I have found the
problem in the diablo scripts though, that triggered a sync for the whole
extras-devel instead of just the diablo section. So, let's do one more FIXED
and reopen if it comes back round.
Comment 13 Uwe Kaminski 2009-12-07 17:07:47 UTC
Sorry, but today this happens again for me.
Comment 14 Dirk Hartmann 2009-12-07 19:58:01 UTC
(In reply to comment #13)
> Sorry, but today this happens again for me.

ACK here too:
W: Failed to fetch
http://repository.maemo.org/extras-testing/dists/freemantle/free/binary-armel/Packages
 404 Not Found [IP: 80.157.170.73 80]

W: Failed to fetch
http://repository.maemo.org/extras-testing/dists/freemantle/non-free/binary-armel/Packages
 404 Not Found [IP: 80.157.170.73 80]
Comment 15 Anderson Lizardo (reporter) 2009-12-07 20:08:44 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > Sorry, but today this happens again for me.
> 
> ACK here too:
> W: Failed to fetch
> http://repository.maemo.org/extras-testing/dists/freemantle/free/binary-armel/Packages
>  404 Not Found [IP: 80.157.170.73 80]

Note you have a typo here. It's "fremantle" not "freemantle".
Comment 16 Dirk Hartmann 2009-12-07 20:36:36 UTC
(In reply to comment #15)

> Note you have a typo here. It's "fremantle" not "freemantle".

Args sorry indeed. Update worked and I try to hide under a pillow.
Comment 17 tusar 2009-12-08 05:53:07 UTC
Hi,

Today i am getting this error again
"http://repository.maemo.org/extras-devel/dists/fremantle/Release  No Hash
entry in Release file
/var/lib/apt/lists/repository.maemo.org_extras-devel_dists_fremantle_Release
"
Comment 18 J├Ârgen Scheibengruber nokia 2009-12-10 21:54:12 UTC
man, this is annoying... why is this low priority?
Comment 19 Jim Morris 2009-12-10 22:31:31 UTC
Occurring for me today. Agree with the above comment, this needs a higher
priority. It is a stopper for testing lots of software.
Comment 20 Andre Klapper maemo.org 2009-12-10 22:51:00 UTC
See comment 10.

Fixing this requires faster machines. They have been ordered, the first of them
have arrived now, and people are working on fixing this issue already.
Comment 21 Ulrich Norbisrath 2010-01-04 19:59:45 UTC
Any news concerning this bug or the new hardware? Just can confirm to suffer
under the "No Hash entry in Release file" (also using apt-get update), too.
Comment 22 Ulrich Norbisrath 2010-01-04 20:10:39 UTC
I just retried a couple of times and then it worked.
(In reply to comment #21)
> Any news concerning this bug or the new hardware? Just can confirm to suffer
> under the "No Hash entry in Release file" (also using apt-get update), too.
>
Comment 23 Niels Breet maemo.org 2010-01-18 11:48:13 UTC
This issue should now be resolved in the new servers architecture. Please
reopen if this happens again.