Bug 6453 - (int-152506) Unable to transfer certain file types over Bluetooth from Windows Explorer
(int-152506)
: Unable to transfer certain file types over Bluetooth from Windows Explorer
Status: RESOLVED WONTFIX
Product: Connectivity
Bluetooth
: 5.0/(3.2010.02-8)
: N900 Maemo
: Low normal with 2 votes (vote)
: ---
Assigned To: unassigned
: bluetooth-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-30 13:40 UTC by Venomrush
Modified: 2011-06-29 21:19 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Venomrush (reporter) 2009-11-30 13:40:31 UTC
SOFTWARE VERSION:
As above

EXACT STEPS LEADING TO PROBLEM: 
1. Create an Excel file on computer (I'm using Windows 7 32-bit)
2. Connect the N900 to the computer using Bluetooth
3. Attempt to copy the Excel file from the computer to the N900's Dada folder
through its interface in Explorer - N900 (PC-Suite Mode) -> Data
4. When asked 'Do you want to copy xxx to your device?' Select Yes

EXPECTED OUTCOME:
Transfer complete without any errors.

ACTUAL OUTCOME:
See the following screenshot: http://pi.pe/b6k0dz

REPRODUCIBILITY:
Always

OTHER COMMENTS:
The workaround was to right click on the file on the computer, choose 'Send to'
then 'Bluetooth device' and choose N900 from the list.
Comment 1 Andre Klapper maemo.org 2009-11-30 15:12:45 UTC
Please feel encouraged to search for existing reports before filing. Thanks. :)

This particular bug has already been reported into our bug tracking system, but
please feel free to report any further bugs you find. Also feel encouraged to
vote for the original bug report if interested.


*** This bug has been marked as a duplicate of bug 5300 ***
Comment 2 Donn Morrison 2009-11-30 15:19:02 UTC
(In reply to comment #1)
> Please feel encouraged to search for existing reports before filing. Thanks. :)
> *** This bug has been marked as a duplicate of bug 5300 ***

I don't think this is a duplicate. This bug mentions trying to copy from
Windows Explorer to the N900 over Bluetooth, and bug 5300 is trying to send
files over Bluetooth from the N900 file manager.
Comment 3 Andre Klapper maemo.org 2009-11-30 15:38:43 UTC
Uh. True. Thanks for noticing. :)

So does this happen with other files too? If so, which types?
Comment 4 Venomrush (reporter) 2009-11-30 15:50:32 UTC
.txt & .doc & .ppt don't work.

.csv and .pdf works.

Haven't check all images, but jpg works.
Comment 5 Venomrush (reporter) 2009-11-30 15:51:43 UTC
Oh .xls doesn't work too.

basically all the office document type + txt
Comment 6 Andre Klapper maemo.org 2009-12-03 10:51:44 UTC
Also see bug 6538 - might have the same underlying issue.

I'd love to see a confirmation for this by a second user.
Don't have a Windows installation around here...
Comment 7 Andre Klapper maemo.org 2009-12-16 23:03:35 UTC
While thinking about reasons for bug 6791 I got a wild idea for this report:
Maybe it somehow depends on whether an application is available on the N900 to
open such files?

WORKS FOR YOU:
.csv .jpg .pdf work.

DOES NOT WORK FOR YOU:
.doc .ppt .txt .xls don't work.

Does for example .mp3 (should) or .jar (should not) work?
Comment 8 Nick Leppänen Larsson 2009-12-17 00:48:52 UTC
Confirming - same error message when trying to copy an .xls-file here.

(In reply to comment #7)
> Maybe it somehow depends on whether an application is available on the N900 to
> open such files?

Seems likely, after enabling the trial for "Sheet To Go" and reconnecting to PC
Suite over Bluetooth the file transfer is succesful.
Comment 9 Andre Klapper maemo.org 2009-12-17 01:04:57 UTC
ogg might also be a nice testcase, before and after having "ogg-support"
installed.
Comment 10 Nick Leppänen Larsson 2009-12-17 01:28:27 UTC
(In reply to comment #8)
> Confirming - same error message when trying to copy an .xls-file here.
> 

> Seems likely, after enabling the trial for "Sheet To Go" and reconnecting to PC
> Suite over Bluetooth the file transfer is succesful.
> 
My apologize, I misspoke - it does NOT work even after this. I used the wrong
steps to reproduce (launching the file manager from Nokia PC Suite gave me
"Nokia Phone Browser" where I could copy it, instead of under "Portable
Devices" in Explorer where it doesn't work).

(In reply to comment #7)
> Does for example .mp3 (should) or .jar (should not) work?
Both .mp3 and .jar filed copied fine here. When copying the .mp3 (and .txt,
.xls) the following dialog is shown http://irc.frals.se/maemo/bug6453-msg.png.

Also tried copying a .java and a .class file and they both copied (without
giving the dialog linked above).

Using Windows 7 Pro 64-bit.
Comment 11 Venomrush (reporter) 2009-12-17 02:17:56 UTC
(In reply to comment #10)

> My apologize, I misspoke - it does NOT work even after this. I used the wrong
> steps to reproduce (launching the file manager from Nokia PC Suite gave me
> "Nokia Phone Browser" where I could copy it, instead of under "Portable
> Devices" in Explorer where it doesn't work).
> 

I encountered this error while transferring through Explorer (rather than Phone
Browser) for certain type of files.

The underlying issue is why it doesn't copy certain type of files over.
Comment 12 Andre Klapper maemo.org 2009-12-22 17:05:04 UTC
I wonder if this is a case of not sending a file from a PC to N900 over
Bluetooth when the PC uses OBEX FTP instead of OPP for its "Send to..." feature
(which would be int-126950)?

Also, what is your Bluetooth chip in the computer?
Comment 13 Andre Klapper maemo.org 2010-01-12 15:28:52 UTC
Confirmed.
Comment 14 Andre Klapper maemo.org 2011-06-29 21:19:33 UTC
Reflecting internal WONTFIX status for Maemo5 here, though issue might have
been fixed in the meantime.