Bug 6426 - Duplicate contacts after reflashing and restoring from backup
: Duplicate contacts after reflashing and restoring from backup
Status: RESOLVED DUPLICATE of bug 5593
Product: Contacts
General
: 5.0/(1.2009.42-11)
: N900 Maemo
: Medium normal (vote)
: ---
Assigned To: unassigned
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-29 20:30 UTC by Eugene
Modified: 2009-11-30 15:52 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Eugene (reporter) 2009-11-29 20:30:55 UTC
SOFTWARE VERSION:
2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
I had an old firmware 41-10 so it may be fixed already

1. Go to Backup application and make a full backup of everything it offers.
2. Save a copy of this on your PC
3. Reflash device to the latest 2009.42-11
4. Restore all your setting and contacts right after first boot.

EXPECTED OUTCOME:
All contacts are in the same state as previously after setting Availability to
Online and waiting for contacts to syncronize with IM contact lists.

 Example:

 Joe Smith: 
  cell number: xxxxx
  skype account: xxxx
  gtalk: xxxx


ACTUAL OUTCOME:
I see my old contact items plus duplicate separate items from IMs:
 Joe Smith: 
  cell number: xxxxx
  skype account: xxxx
  gtalk: xxxx
 skype: joesmith
 joe.smith@gmail.com

So instead of 170 old items it's 200+ now

REPRODUCIBILITY:
1 out of 1 try I had. Sorry, reflashing isn't an everyday thing.

EXTRA SOFTWARE INSTALLED:
none after first reboot

OTHER COMMENTS:
Comment 1 Jörgen Scheibengruber nokia 2009-11-30 13:37:44 UTC
This is a known (and fixed internally) issue for Skype IM-contacts. Do you say
it happens for GTalk contacts as well?
Comment 2 Eugene (reporter) 2009-11-30 14:51:30 UTC
Oh, you are right. I checked it thoroughly and it's only happened with Skype
contacts.

Could you please merge the current bug with this internal one, because I could
not find it here and decided to add a new.
Comment 3 Jörgen Scheibengruber nokia 2009-11-30 14:56:40 UTC
I am not really familiar whith this bugzilla. The internal bug has 133842.
Andre, could you handle this?
Comment 4 Andre Klapper maemo.org 2009-11-30 15:52:41 UTC
@Eugene:
Thanks for reporting this.
This particular bug has already been reported into our bug tracking system, but
please feel free to report any further bugs you find. Also feel encouraged to
vote for the original bug report if interested.


@Jorgen:
(In reply to comment #3)
> I am not really familiar whith this bugzilla. The internal bug has 133842.
> Andre, could you handle this?

Sure - actually this already had a representation here.
For more info: http://wiki.maemo.org/Bugs:Cloning .

*** This bug has been marked as a duplicate of bug 5593 ***