Bug 6424 - (int-152520) Always keep the email address used by the sender
(int-152520)
: Always keep the email address used by the sender
Status: RESOLVED WONTFIX
Product: Email
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low enhancement with 4 votes (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-29 20:06 UTC by dpuricelli
Modified: 2012-03-24 11:39 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description dpuricelli (reporter) 2009-11-29 20:06:57 UTC
SOFTWARE VERSION:

1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 

1. Tap on Reply button.

EXPECTED OUTCOME:

The email address used by the application should be the one who got the email,
not always the default one.

ACTUAL OUTCOME:

The email address used is always the account default one.

REPRODUCIBILITY:

always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

Hello, I'm using a GMAIL IMAP account, where I receive emails from other
accounts; it'd be important if the app could use the address the email was sent
to, while it always replace it with the address used to log on that account.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5)
Gecko/20091102 Firefox/3.5.5
Comment 1 Andre Klapper maemo.org 2009-11-30 14:43:51 UTC
Thanks for reporting this.

This is missing some steps, e.g. if the Sender is already stored in the
addressbook, and if it has one or both email addresses added already.
Comment 2 dpuricelli (reporter) 2009-11-30 17:48:31 UTC
(In reply to comment #1)
> Thanks for reporting this.
> 
> This is missing some steps, e.g. if the Sender is already stored in the
> addressbook, and if it has one or both email addresses added already.
> 

Sorry, I didn't explain myself in the best way, let's try again.

I use a Gmail IMAP account where I receive emails sent to my foobar@gmail.com
address and where Gmail automatically stores emails downloaded via POP3 from
other personal accounts.

In my Inbox I can find all the emails sent to me, the ones sent to my
foobar@gmail.com and the ones sent to other addresses, like foobar@quux.it.

When I try to reply to an email sent to that foobar@quux.it address, the Email
application ignores that address and forces me to always use the Gmail address.
Comment 3 Quim Gil nokia 2009-12-07 11:08:35 UTC
I think it's better to address this as a UX bug.
Comment 4 Lucas Maneos 2009-12-08 16:01:15 UTC
(In reply to comment #0)
> The email address used by the application should be the one who got the email,
> not always the default one.

Agreed in general, but there are cases where it doesn't make sense or breaks
down (for example if there are multiple recipients none of which matches the
account's email address of if the user was a Bcc recipient).

IMHO the user should be able to specify a list of email addresses that are
delivered to each account, and if one of those is found in the recipient fields
of a message it should be used as the From: address in replies.

Btw, bug 3409 is closely related.
Comment 5 Andre Klapper maemo.org 2009-12-14 15:47:51 UTC
When I try to use a different sender email address than the one that is defined
for the actual account that I use to send that email, this is blocked by most
SMTP server as it's simply spoofing.

I don't consider this a bug at all as "fixing" this would make spamming from
fake addresses way easier, or do I get something wrong?
Comment 6 dpuricelli (reporter) 2009-12-14 16:30:37 UTC
I don't know about spoofing, but since Gmail uses it it'd be really useful to
support it, maybe restricting it to Gmail accounts to avoid any issues.

I just sent an email using the secondary address that received it, with Gmail;
the relevant headers are:

MIME-Version: 1.0
Sender: FOOBAR@gmail.com
Delivered-To: FOOBAR@gmail.com
X-Google-Sender-Auth: STRING
Subject: Re: ciao
From: <FOOBAR@FOOBAR.info>

As you can see Sender and Delivered-To are set to the Gmail account address,
while From uses the secondary address; I guess that SMTP uses the
X-Google-Sender-Auth header to accept it.

If you need other info just tell me.
Comment 7 Lucas Maneos 2009-12-15 13:39:40 UTC
(In reply to comment #5)
> When I try to use a different sender email address than the one that is 
> defined for the actual account that I use to send that email, this is
> blocked by most SMTP server as it's simply spoofing.

Well, that's just a server policy issue (and a bit broken IMHO but out of scope
here).

> I don't consider this a bug at all as "fixing" this would make spamming from
> fake addresses way easier, or do I get something wrong?

Spoofing is a general problem in SMTP that no one has managed to fix yet (aside
from PGP/MIME or S/MIME signatures in the payload). Note that this is about
replies to messages that have already arrived in the user's INBOX so presumably
the user is authorised to use that email address in general.

FWIW, the way my favourite MUA handles this is
<http://www.mutt.org/doc/devel/manual.html#alternates>.
Comment 8 Andre Klapper maemo.org 2010-01-07 22:38:19 UTC
EXACT STEPS LEADING TO PROBLEM: 
1. Have an email account that also receives incoming mail to a different email 
   address forwarded to this account.
2. Go to Inbox.
3. Tap on Reply button of an email with that different recipient email address.
Comment 9 Andre Klapper maemo.org 2010-01-11 12:12:00 UTC
"this was already fixed some time ago. We use the active account for selecting
the sender"
Hence not sure if this will be fixed in PR1.1 release or the release after.
Note that today's 1.2009.44-1 release is not PR1.1.
Comment 10 Lucas Maneos 2010-01-11 12:42:31 UTC
(In reply to comment #9)
> "this was already fixed some time ago. We use the active account for selecting
> the sender"

That was bug 3423.  This one is about multiple email addresses delivered to the
same account.
Comment 11 Sergio Villar Senin 2010-01-11 15:06:57 UTC
(In reply to comment #7)
> (In reply to comment #5)
> > When I try to use a different sender email address than the one that is 
> > defined for the actual account that I use to send that email, this is
> > blocked by most SMTP server as it's simply spoofing.
> 
> Well, that's just a server policy issue (and a bit broken IMHO but out of scope
> here).
> 
> > I don't consider this a bug at all as "fixing" this would make spamming from
> > fake addresses way easier, or do I get something wrong?
> 
> Spoofing is a general problem in SMTP that no one has managed to fix yet (aside
> from PGP/MIME or S/MIME signatures in the payload). Note that this is about
> replies to messages that have already arrived in the user's INBOX so presumably
> the user is authorised to use that email address in general.

Well I'm not sure about this. Most of servers won't allow you to specify a
different "From" as you said, to avoid spoofing. IMO what we do right now is
the safest alternative, i.e, your email is always sent
Comment 12 Lucas Maneos 2010-01-14 02:49:49 UTC
(In reply to comment #11)
> Well I'm not sure about this. Most of servers won't allow you to specify a
> different "From" as you said, to avoid spoofing. IMO what we do right now is
> the safest alternative, i.e, your email is always sent

Note that this is about the From: header, not the SMTP envelope FROM (which
should always match the sending account in any case).  

SMTP servers shouldn't block mail based on headers (IMHO they shouldn't even
look at them, they're just payload), but arbitrary local policies ("550
Rejected: it's Thursday" anyone?) are something to be negotiated between the
user and the service provider and not the MUA's problem.
Comment 13 Andre Klapper maemo.org 2012-03-24 11:39:38 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )