Bug 6407 - (int-149042) microphone doesn't work during a call and after closing fm radio
(int-149042)
: microphone doesn't work during a call and after closing fm radio
Status: RESOLVED FIXED
Product: FM Radio
General
: unspecified
: N900 Maemo
: High critical with 2 votes (vote)
: ---
Assigned To: Martin Grimme
: general
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2009-11-29 00:25 UTC by davidepr
Modified: 2010-06-21 08:54 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description davidepr (reporter) 2009-11-29 00:25:04 UTC
SOFTWARE VERSION:2009.11.15
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. microphone doesn't work during a call and after closing fm radio till reboot
the device.
2. 
3.

EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:always
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.9.1.5)
Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2009-11-29 00:58:28 UTC
davidepr,
Please fill out these fields. They exist for a reason:

EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:always
(always, less than 1/10, 5/10, 9/10)
Comment 2 Martin Grimme 2009-11-30 13:44:36 UTC
This is now fixed in SVN.
It was due to buggy mixer settings and the OS not making sure the mixer
settings are right when a call comes in.
Comment 3 Quim Gil nokia 2009-12-07 12:20:53 UTC
Note that this bug brings loss of major functionality in the device including
the inability of the user of making emergency calls. 

This is VERY SEVERE. Please push a new version to Extras as soon as possible.
You could even demote the current version to Extras-testing while this problem
is not solved in a version available in Extras.

Thank you for your understanding.
Comment 4 marco.ballesio nokia 2009-12-07 13:01:18 UTC
(In reply to comment #2)
> This is now fixed in SVN.
> It was due to buggy mixer settings and the OS not making sure the mixer
> settings are right when a call comes in.
> 

It may be OT (and maybe you already received them), but here are some
suggestions I got from the developers about how to improve this on the
application:

A probably non-exhaustive list of things to be avoided:

  1) directly fiddling around with ALSA switches (for HP/HS-as-antenna)
  2) bypassing speaker protection (by bypassing pulseaudio)
  3) bypassing audio policy (by bypassing pulseaudio)
  4) directly fiddling around with ALSA switches (for routing to IHF)

(I know some of the are quite hard but it's anyway a starting point).

A minimal list of things FM radio is suggested to do:

  1) run audio through pulseaudio to get speaker-protection
  2) ditto for keeping FM radio audio policy-enforceable (calls should preempt
radio, etc.)
  3) interact with policy for the regular ALSA-fiddling

3 appears not to be easily doable but it's anyway something we may put on the
wish-list.
Comment 5 Martin Grimme 2009-12-07 22:56:24 UTC
The overall answer I got from some Nokia guys was:

 1) use pulseaudio for speaker output (because bypassing may damage the
speakers)
 2) do use bypassing for headset output because it's safe and sounds better

Unfortunately at this stage of Maemo OS directly fiddling with alsa switches is
a necessity for FM radio. Future fmradio awareness of the alsaped was mentioned
by someone from Nokia though (actually fragments of it do already exist, see
below).

> A minimal list of things FM radio is suggested to do:
>
>   1) run audio through pulseaudio to get speaker-protection

YES for speaker output. Currently and intentionally NO for headphones output
(see above).

>  2) ditto for keeping FM radio audio policy-enforceable (calls should preempt
radio, etc.)

The policy manager issues a D-Bus signal with mixer settings including those
for fmradio. My app (SVN version) is paying close attention to these
(undocumented) signals. That's why I marked this bug as fixed for SVN.

>  3) interact with policy for the regular ALSA-fiddling

<rant>Welcome to the huge world of undocumented private Maemo
interfaces.</rant>
How to interact with that policy, other than listening to its D-Bus signals?
Comment 6 Quim Gil nokia 2009-12-08 08:27:54 UTC
Martin, I understand you have reasons to complain. Still, I think the current
version of FM Radio should be pulled from Extras since the amount of users
complaining about "mic not working" is considerable and a % of them are
directly victims of this bug (not all though, let's also be clear on this).

Once there is a version in Extras-testing that comes with the fixes we can push
it back to Extras.
Comment 7 Martin Grimme 2009-12-08 09:08:30 UTC
Yes, I already gave Niels my OK to pull it from extras.
I understand that this is a critical issue and the best solution for now is
pulling.

Sorry for ranting (I was quite tired that evening). I just wanted to point out
that it's not really easy for me and my app to get contradictory
recommendations from different people at Nokia when it comes to such critical
stuff as messing with the microphone and mixer settings.
I'm still not sure whether I should bypass the HP filter for headphones or not.
But let's continue this discussion by mail.
Comment 8 marco.ballesio nokia 2009-12-08 09:14:56 UTC
(In reply to comment #7)
> Yes, I already gave Niels my OK to pull it from extras.
> I understand that this is a critical issue and the best solution for now is
> pulling.
> 
> Sorry for ranting (I was quite tired that evening). I just wanted to point out
> that it's not really easy for me and my app to get contradictory
> recommendations from different people at Nokia when it comes to such critical
> stuff as messing with the microphone and mixer settings.
> I'm still not sure whether I should bypass the HP filter for headphones or not.
> But let's continue this discussion by mail.
> 

After reading your comments it appears you got some valid suggestions on one
hand, too complex ones on the other. Please add me to the loop as well.
Comment 9 Niels Breet maemo.org 2009-12-08 14:07:22 UTC
Package was pulled from Extras.
Comment 10 Flandry 2010-06-21 08:52:43 UTC
I encountered a bug that seems a lot like this one recently. I received several
calls while FM Radio was operating. The outcome varied, but at least 2/3 of the
time involved the microphone of the headset not working while the headphones
did (i.e. could here caller but caller couldn't hear me). This could be fixed
by killing the FM Radio process, which would hang when the call came in.

After this happened a few times, the final call caused the FM tuner to be left
inaccessible by the FM Radio app (it complained about not being able to access
the driver), and a reboot was needed to fix this.

For a few of the calls, the radio continued to play after the phone started
"Ringing", and in one case was playing out the right earphone while the
caller's voice came out the left (or perhaps both).

Sorry this isn't more quantitative--in each instance i was more focused on
answering the incoming call than diagnosing the problem.

Discussion here:
http://talk.maemo.org/showpost.php?p=720625&postcount=31
Comment 11 Flandry 2010-06-21 08:54:50 UTC
(In reply to comment #10)
> I encountered a bug that seems a lot like this one recently. I received several
> calls while FM Radio was operating. The outcome varied, but at least 2/3 of the
> time involved the microphone of the headset not working while the headphones
> did (i.e. could here caller but caller couldn't hear me). This could be fixed
> by killing the FM Radio process, which would hang when the call came in.

Sorry for the spam: i wish to clarify that i had to kill the radio app and then
return the call before the mic worked. It wouldn't return for the original call
even when the FM Radio app was killed.