Bug 6396 - (int-153087) Zooming is not working right away when link clicked from desktop
(int-153087)
: Zooming is not working right away when link clicked from desktop
Status: VERIFIED FIXED
Product: Browser
Zooming
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low minor with 6 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: browser-zooming-bugs
:
:
:
: 6347
  Show dependency tree
 
Reported: 2009-11-28 21:51 UTC by Janne Kolehmainen
Modified: 2010-05-26 06:49 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Janne Kolehmainen (reporter) 2009-11-28 21:51:46 UTC
SOFTWARE VERSION:
(Settings > General > About product)
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Click google link from desktop
2. When web page is loaded click volume up key

EXPECTED OUTCOME:
Page is zoomed in

ACTUAL OUTCOME:
First volume bar is shown and volume is adjusted. After few seconds zooming
start working.

REPRODUCIBILITY:
always (always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5)
Gecko/20091102 Firefox/3.5.5
Comment 1 Lucas Maneos 2009-11-29 03:00:10 UTC
Thanks for the report, confirmed.  I wonder if it's related to bug 5825 or
something else entirely.
Comment 2 Andre Klapper maemo.org 2009-12-01 17:47:19 UTC
This looks exactly like the same issue as bug 6048 to me, but this time for the
browser instead of the Email application.
Comment 3 Andre Klapper maemo.org 2009-12-01 17:48:16 UTC
Timing problems, probably.
Browser after start must set a flag to the volume plugin and if you click
in-between that time it's getting weird.
Comment 4 Andre Klapper maemo.org 2010-01-13 17:09:38 UTC
*** Bug 7910 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2010-02-04 21:25:43 UTC
Is this still an issue in 2.2009.51-1?
Comment 6 Janne Kolehmainen (reporter) 2010-02-04 21:31:56 UTC
(In reply to comment #5)
Yes, this happens with the 2.2009.51-1 firmware also.
Comment 7 Andre Klapper maemo.org 2010-02-12 13:35:58 UTC
This has been fixed in package
tablet-browser-ui 2.1.4.4-1+0m5
which is part of the internal build version
10.2010.06-10
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Andre Klapper maemo.org 2010-03-15 20:51:18 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 9 Janne Kolehmainen (reporter) 2010-05-26 06:49:51 UTC
Verified that this works now.