Bug 6372 - (int-149579) Sometimes photos are not deleted if you delete directly after taking them
(int-149579)
: Sometimes photos are not deleted if you delete directly after taking them
Status: VERIFIED FIXED
Product: Images and Camera
Camera
: 5.0/(2.2009.51-1)
: All Linux
: Low normal with 5 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: camera-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-27 21:20 UTC by Alberto Garcia Gonzalez
Modified: 2010-06-07 20:53 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Alberto Garcia Gonzalez (reporter) 2009-11-27 21:20:58 UTC
SOFTWARE VERSION:
42-11

EXACT STEPS LEADING TO PROBLEM:
1. Open camera app and take a photo
2. Quickly delete the photo right after having taken it
   (i.e. from the post-capture view)
3. Open the image viewer and look for the photo you've just deleted

EXPECTED OUTCOME:
The photo is not there

ACTUAL OUTCOME:
The photo is there

REPRODUCIBILITY:
Depends on how fast you are to delete the photo. I'd say 3/10 or so
Comment 1 Andre Klapper maemo.org 2009-12-04 19:54:12 UTC
I can reproduce this too in the internal version 49-3.
Comment 2 Andrés Gómez 2009-12-26 20:09:33 UTC
Adding myself to CC.

Alberto, are the photos not disappearing after some seconds? In which memories
is this happening? Internal/external?

Maybe the problem is that tracker is making use of the picture and, therefore,
the picture could not be deleted straight away bug disappears after some
seconds.

External memory is FAT32 AFAIK, so this should not happen there. If you are
able to reproduce even in FAT32 maybe the bug is even worse than thought.
Comment 3 Andre Klapper maemo.org 2010-01-11 17:44:32 UTC
*** Bug 7656 has been marked as a duplicate of this bug. ***
Comment 4 Alberto Garcia Gonzalez (reporter) 2010-01-14 14:23:08 UTC
(In reply to comment #2)
> Alberto, are the photos not disappearing after some seconds? In
> which memories is this happening? Internal/external?

Internal (I don't have any external memory card).

> Maybe the problem is that tracker is making use of the picture and,
> therefore, the picture could not be deleted straight away bug
> disappears after some seconds.

I don't think it goes away after some seconds. It happened to me
several times that I went to the image viewer and found photos that I
thought I had deleted after taking them.
Comment 5 Andrés Gómez 2010-01-14 15:11:28 UTC
(In reply to comment #4)
...
> I don't think it goes away after some seconds. It happened to me
> several times that I went to the image viewer and found photos that I
> thought I had deleted after taking them.
...

I'm starting to think the problem is that the file system format (FAT32)
doesn't allow a lazy unlink of files. Probably tracker is accessing the files
and camera-ui just doesn't care about the error result of the unlinking
operation.

It would be good if somebody would check this problem with ext3, but it seems
we have another bug which prevents camera to work with ext3 :(

Let's see ...
Comment 6 EC 2010-01-14 15:38:04 UTC
I've just taken four photos deleting them just after the shot, and they are
still in the photo viewer. I'm using PR1.1, someone with appropriate powers
update the version field to the last one.
Comment 7 Andre Klapper maemo.org 2010-02-09 20:00:24 UTC
This has been fixed in package
camera-ui 1.1.4.2+0m5
which is part of the internal build version
10.2010.05-10
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Bartosz Taudul 2010-03-11 01:36:09 UTC
*** Bug 9408 has been marked as a duplicate of this bug. ***
Comment 9 Andre Klapper maemo.org 2010-03-15 20:54:26 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 10 Alberto Garcia Gonzalez (reporter) 2010-06-07 20:53:45 UTC
This works fine now, I tried with 10 photos and I haven't been able to
reproduce this bug.